LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   I am having an opengl problem (http://www.linuxquestions.org/questions/linux-software-2/i-am-having-an-opengl-problem-813881/)

Immutus 06-13-2010 11:16 AM

I am having an opengl problem
 
I latest nvidia driver installed. Video card is nvidia geForce 9400 gt 512 mb ram. CPu is AMD Phenom x4 9500. Motherboard is Gigabyte gm-ma785 something another. Dont have cpu-id to tell me what it is called. Anyway searched internet about opengl problems and read something about glx and dri loading in xorg.conf....below is my xorg.conf and as you can see dri and glx is uncommented in xorg.conf file. Some one please help: Trying to get maya unlimited working

# /.../
# SaX generated X11 config file
# Created on: 2010-06-13T08:34:36-0500.
#
# Version: 8.1
# Contact: Marcus Schaefer <sax@suse.de>, 2005
# Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
#
# Automatically generated by [ISaX] (8.1)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "Files"
FontPath "/usr/share/fonts/misc:unscaled"
FontPath "/usr/share/fonts/local"
FontPath "/usr/share/fonts/75dpi:unscaled"
FontPath "/usr/share/fonts/100dpi:unscaled"
FontPath "/usr/share/fonts/Type1"
FontPath "/usr/share/fonts/URW"
FontPath "/usr/share/fonts/Speedo"
FontPath "/usr/share/fonts/PEX"
FontPath "/usr/share/fonts/cyrillic"
FontPath "/usr/share/fonts/latin2/misc:unscaled"
FontPath "/usr/share/fonts/latin2/75dpi:unscaled"
FontPath "/usr/share/fonts/latin2/100dpi:unscaled"
FontPath "/usr/share/fonts/latin2/Type1"
FontPath "/usr/share/fonts/latin7/75dpi:unscaled"
FontPath "/usr/share/fonts/baekmuk:unscaled"
FontPath "/usr/share/fonts/japanese:unscaled"
FontPath "/usr/share/fonts/kwintv"
FontPath "/usr/share/fonts/truetype"
FontPath "/usr/share/fonts/uni:unscaled"
FontPath "/usr/share/fonts/CID"
FontPath "/usr/share/fonts/ucs/misc:unscaled"
FontPath "/usr/share/fonts/ucs/75dpi:unscaled"
FontPath "/usr/share/fonts/ucs/100dpi:unscaled"
FontPath "/usr/share/fonts/hellas/misc:unscaled"
FontPath "/usr/share/fonts/hellas/75dpi:unscaled"
FontPath "/usr/share/fonts/hellas/100dpi:unscaled"
FontPath "/usr/share/fonts/hellas/Type1"
FontPath "/usr/share/fonts/misc/sgi:unscaled"
FontPath "/usr/share/fonts/xtest"
FontPath "/opt/kde3/share/fonts"
InputDevices "/dev/gpmdata"
InputDevices "/dev/input/mice"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail" "on"
Option "ZapWarning" "on"
EndSection

Section "Module"
Load "glx"
Load "extmod"
Load "dbe"
Load "dri"
EndSection

Section "InputDevice"
# Driver "kbd" will be disabled unless 'Option "AutoAddDevices" "off"'
# is set in "ServerFlags" section.
Driver "kbd"
Identifier "Keyboard[0]"
Option "Protocol" "Standard"
Option "XkbLayout" "us"
Option "XkbModel" "microsoftpro"
Option "XkbRules" "xfree86"
EndSection


Section "InputDevice"
# Driver "mouse" will be disabled unless 'Option "AutoAddDevices" "off"'
# is set in "ServerFlags" section.
Driver "mouse"
Identifier "Mouse[1]"
Option "Buttons" "17"
Option "Device" "/dev/input/mice"
Option "Name" "Microsoft Wireless Desktop Receiver 3.1"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection


Section "Monitor"
Option "CalcAlgorithm" "XServerPool"
DisplaySize 305 230
HorizSync 31-75
Identifier "Monitor[0]"
ModelName "1600X1200@60HZ"
Option "PreferredMode" "1600x1200"
VendorName "--> VESA"
VertRefresh 50-60
UseModes "Modes[0]"
EndSection


Section "Modes"
Identifier "Modes[0]"
EndSection


Section "Screen"
DefaultDepth 24
SubSection "Display"
Depth 15
Modes "1600x1200" "1600x1024" "1600x1000" "1400x1050" "1600x900" "1280x1024" "1440x900" "1280x960" "1366x768" "1360x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1600x1200" "1600x1024" "1600x1000" "1400x1050" "1600x900" "1280x1024" "1440x900" "1280x960" "1366x768" "1360x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1600x1200" "1600x1024" "1600x1000" "1400x1050" "1600x900" "1280x1024" "1440x900" "1280x960" "1366x768" "1360x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1600x1200" "1600x1024" "1600x1000" "1400x1050" "1600x900" "1280x1024" "1440x900" "1280x960" "1366x768" "1360x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
Device "Device[0]"
Identifier "Screen[0]"
Monitor "Monitor[0]"
EndSection


Section "Device"
BoardName "GeForce 9400 GT"
Driver "nvidia"
Identifier "Device[0]"
Option "SaXDualHead"
Option "TwinView"
Option "SaXDualMonitorVendor" "--> VESA"
Option "SaXDualOrientation" "RightOf"
Option "MetaModes" "1600x1200,1600x1200;1600x1024,1600x1024;1600x1000,1600x1000;1400x1050,1400x1050;1600x900,1600x900;1 280x1024,1280x1024;1440x900,1440x900;1280x960,1280x960;1366x768,1366x768;1360x768,1360x768;1280x800, 1280x800;1152x864,1152x864;1280x768,1280x768;1280x720,1280x720;1024x768,1024x768;1280x600,1280x600;1 024x600,1024x600;800x600,800x600;768x576,768x576;640x480,640x480"
Option "SaXDualResolution" "1600x1200"
Option "TwinViewOrientation" "RightOf"
Option "SaXDualMode" "Xinerama"
Option "SecondMonitorVertRefresh" "50-60"
Option "SaXDualHSync" "31-75"
Option "SaXDualMonitorModel" "1600X1200@60HZ"
Option "SaXDualVSync" "50-60"
Screen 0
VendorName "NVIDIA"
EndSection



Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Option "Clone" "off"
Option "Xinerama" "off"
Screen "Screen[0]"
EndSection


Section "DRI"
Group "video"
Mode 0660
EndSection

Section "Extensions"
Option "Composite" "on"
EndSection

Hammett 06-13-2010 03:27 PM

Please comment dri on section Module and try again to see if that works. Do NOT comment GLX module though

Immutus 06-13-2010 06:10 PM

I will try it. Thanks for the tip
 
Quote:

Originally Posted by Hammett (Post 4002401)
Please comment dri on section Module and try again to see if that works. Do NOT comment GLX module though

However what would that mean commenting out dri section. Would that mean I wont play games such as Unreal 2004? Or Neverwinter Nights?

John VV 06-13-2010 08:16 PM

a few questions first
did you use the RECOMMENDED way of installing that driver ?
use YOUR package manager and install the one provided by YOUR distro
-- what is your distro ???

or did you use the nvidia.run from the nvidia web site ?

THERE is a difference between the two

H_TeXMeX_H 06-14-2010 07:49 AM

Use either 'nvidia-settings' or 'nvidia-xconfig' as root to generate an xorg.conf. However, if you are running a new distro, you can just delete 'xorg.conf' or just leave the part that tells it to use the nvidia driver.

Hammett 06-15-2010 05:18 PM

Quote:

Originally Posted by Immutus (Post 4002521)
However what would that mean commenting out dri section. Would that mean I wont play games such as Unreal 2004? Or Neverwinter Nights?

By any means no. nvidia driver is not compatible with dri module, but with glx. If you enable both, chances are driver is not gonna work properly when coming to glx (AKA 3D)

resetreset 06-17-2010 03:14 AM

I'm curious - why do you want Open GL for using *Maya*? Just for the viewport? You do know that your *Renders* won't speed up any more if you use your 3D card, right?

Immutus 06-19-2010 12:42 AM

Quote:

Originally Posted by resetreset (Post 4006268)
I'm curious - why do you want Open GL for using *Maya*? Just for the viewport? You do know that your *Renders* won't speed up any more if you use your 3D card, right?


I dont have any viewports in maya...they are just grey with no grid or anything. In other words no viewports at all. This is why I suspect an openGl proglem


All times are GMT -5. The time now is 01:26 AM.