LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-24-2003, 10:54 AM   #1
bentman78
Member
 
Registered: Mar 2003
Location: Washington DC, USA
Distribution: Redhat
Posts: 212

Rep: Reputation: 30
I am having a problem mounting an NTFS volume to Redhat8.0


I have a Luix box running Redhat8.0. I installed another HD with the NTFS file structure and I can't mount it. The HD is on another IDE channel so it comes up as HDC1, but I can't mount it because it says it's not supported by the kernel, however the book I have says I can mount it. Is there any utilities or anything I need. Any help is appriecated.
 
Old 03-24-2003, 11:31 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
please search this site for an awful lot of information about mounting ntfs.
 
Old 03-24-2003, 11:33 AM   #3
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,570

Rep: Reputation: 171Reputation: 171
mount -t ntfs /dev/hdc1 /mnt/win
should work. If it prints something like "not supported by the kernel" check if you're trying to mount the right partition (using fdisk, for example). I guess you made a mistake and it's not /dev/hdc1, because AFAIK RedHat 8.0 has NTFS support build in. But if it's the right partition and you can't run
modprobe ntfs
without an error saying 'no such module', you may have a kernel without NTFS support. In such case, download another RedHat kernel (upgrade to 2.4.20 from RPMs, for example) and install it.
 
Old 03-24-2003, 12:25 PM   #4
bentman78
Member
 
Registered: Mar 2003
Location: Washington DC, USA
Distribution: Redhat
Posts: 212

Original Poster
Rep: Reputation: 30
I did use the mount/dev/hdc1 /mnt/win and that's were I get the error. I will give it another try and see what happens. must of done something wrong. How would I format the drive. I used the mkfs -t ext3 /dev/hdc1 to format the drive so linux can see it. Then I go to mount it and get the NTFS errors still. Any ideas why?
 
Old 03-24-2003, 12:33 PM   #5
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,570

Rep: Reputation: 171Reputation: 171
Quote:
Originally posted by bentman78
must of done something wrong. How would I format the drive. I used the mkfs -t ext3 /dev/hdc1 to format the drive so linux can see it. Then I go to mount it and get the NTFS errors still. Any ideas why?
You really did it? So it's now ext3 drive...
mount -t ext3 /dev/hdc1 /mnt/win
Make sure you have /mnt/win directory created, if not:
mkdir /mnt/win
 
Old 03-24-2003, 12:59 PM   #6
bentman78
Member
 
Registered: Mar 2003
Location: Washington DC, USA
Distribution: Redhat
Posts: 212

Original Poster
Rep: Reputation: 30
I have a directory created, it's called ftp (it's going to be an FTP directory). In anycase I formatted the partition and ext 3, and when I mount it, it's still getting the NTFS error. How do I blow the drive away? I tried the mount -t ext3 /dev/hdc1 /mnt/ftp and get the error. This is after the mkfs -t ext3 /dev/hdc1. I even added the partition to the fstab file to auto mount and on start up it won't mount the drive.
 
Old 03-24-2003, 01:14 PM   #7
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,570

Rep: Reputation: 171Reputation: 171
If it's formatted, you can delete the partition and create a new one. Use 'fdisk /dev/hdc', delete hdc1, create a new one with the same size, but with 'Linux-native' type, then use
tune2fs -j /dev/hdc1
 
Old 03-24-2003, 01:28 PM   #8
XxAndyxX
Member
 
Registered: Mar 2003
Location: Houston, TX
Distribution: RedHat 8.0
Posts: 79

Rep: Reputation: 15
Okay, I just read through this real quick but, yes RedHat 8.0 comes with NTFS support but no it's not enabled. You have to use xconfig or menuconfig and recompile the kernel, enabling NTFS *you will only be able to read the NTFS partition (Microsoft people are bastards and won't tell use how to access NTFS with write permission)
 
Old 03-24-2003, 08:58 PM   #9
fRoNTtek
LQ Newbie
 
Registered: Mar 2003
Location: Califonia
Distribution: Redhat 8
Posts: 1

Rep: Reputation: 0
Bentman78,

Check out this link.
http://linux-ntfs.sourceforge.net/info/redhat.html#down

The instructions are located above the RPM packages. The only other things you need to know is what type of processor i386, 486, 586, 686 and your kernel version.

I to had issue mounting NTFS volumes untill I installed this package. Then it was smooth sailing from there.


fRoNTtek
 
Old 03-25-2003, 06:11 AM   #10
bentman78
Member
 
Registered: Mar 2003
Location: Washington DC, USA
Distribution: Redhat
Posts: 212

Original Poster
Rep: Reputation: 30
Thanks for all your help guys. i will looking into that in the near future. I just formated the partition and mounted it as an ext3 file systems. I will try to mount an NTFS volume just to do it.
I have one last question. I have a 120 gb HD however only 110gb are shown. When I Fdisked it i did it as an extended partition and mounted to a directory off of root called files (/files). Any reason this is happening?
 
Old 03-25-2003, 12:46 PM   #11
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,570

Rep: Reputation: 171Reputation: 171
120GB written on the disk doesn't really mean 120GB in reality. But if it's really close to 110GB, you probably have some space left when you created partitions.
 
Old 03-25-2003, 01:19 PM   #12
bentman78
Member
 
Registered: Mar 2003
Location: Washington DC, USA
Distribution: Redhat
Posts: 212

Original Poster
Rep: Reputation: 30
I wonder why. I wrote to the full disk. It had 14953 cylinders, and I chose the partition to be the max amount.
 
Old 03-25-2003, 01:41 PM   #13
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,570

Rep: Reputation: 171Reputation: 171
So it looks your disk is smaller than 120GB... Mine 40GB is 38,2GB or something. It's 95% or 40GB. When we think bout your disk, 95% of 120GB is 114GB. I guess it fits...
 
Old 03-26-2003, 10:16 AM   #14
bentman78
Member
 
Registered: Mar 2003
Location: Washington DC, USA
Distribution: Redhat
Posts: 212

Original Poster
Rep: Reputation: 30
I as told why. disk manufactures don't use 1024 sectors equals a byte. They use 1000, so you aren't getting 120gb so to speak. I was told about this last ngiht and can't really remember, it made sense when they told me, I just can't remember what how it was explained to me. Basically disk manufacturing companies lie to the public was what I gathered.
 
Old 09-10-2003, 12:07 AM   #15
Trickster858
LQ Newbie
 
Registered: Sep 2003
Posts: 1

Rep: Reputation: 0
Lightbulb

Technically, a kilobyte is 2^10 bytes = 1024 bytes
a megabyte is 2^20 bytes, and a gigabyte is 2^30 bytes = 1,073,741,824. It is a lot simpler (especially for marketing) to just think of a gigabyte as one billion bytes. The computer is based on binary though so so you end up with a difference of about 7% between the actual binary size and the marketing size.

So a 120 GB drive is really 120,000,000,000 / 1,073,741,824 bytes = 111.75 actual GB.

It is good to know that Linux supports NTFS. I'm cleaning up my Win XP system to make room to install Linux and am considering getting a second 120GB HD instead of a DVD R/W to store data on. I haven't decided how I am going to partition/arrange my drives yet. It would be really nice if Microsoft didn't have its head so far up where it doesn't belong and there was full NTFS read/write capability. It would really make things a lot easier. I could have one NTFS drive that both OSes could share for data and then have a split partition on the other drive for the two OSes. Microsoft won't make the NTFS specs available to developers?



- Patrick
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
mounting ntfs volume/installing sound bluknight43 Linux - Hardware 1 09-08-2005 03:23 PM
Writing to an NTFS volume using captive-ntfs (repairing boot.ini) macskeeball Linux - General 3 02-06-2005 09:28 PM
NTFS Mounting problem, please help... k0rupt Linux - Hardware 2 08-01-2004 05:46 PM
Mounting NTFS problem HiOctane21 Linux - Newbie 7 02-18-2004 02:22 PM
Problem Mounting NTFS sname Linux - General 2 08-16-2002 03:57 AM


All times are GMT -5. The time now is 02:13 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration