LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 02-15-2009, 01:52 AM   #1
Eileen Walsh
LQ Newbie
 
Registered: Feb 2009
Posts: 5

Rep: Reputation: 0
hypermail language problem


Hi,

I'm new to linux and command line programs. When I type hypermail on the command line I get the following message:

Code:
eileen@CDX:/usr/bin$ hypermail
WARNING: locale "en_US", not supported.
hypermail: Can not create directory "archive".
My computer is using US English, and I'm using Kubuntu 8.04.

Any assistance would be much appreciated.

Thanks,

Last edited by Eileen Walsh; 02-15-2009 at 01:55 AM.
 
Old 02-15-2009, 04:55 AM   #2
jdkaye
Senior Member
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 4,961

Rep: Reputation: Disabled
Quote:
Originally Posted by Eileen Walsh View Post
Hi,

I'm new to linux and command line programs. When I type hypermail on the command line I get the following message:

Code:
eileen@CDX:/usr/bin$ hypermail
WARNING: locale "en_US", not supported.
hypermail: Can not create directory "archive".
My computer is using US English, and I'm using Kubuntu 8.04.

Any assistance would be much appreciated.

Thanks,
Hi Eileen,
Can you type
Code:
locale
on the command line and show the output here. For example mine looks like this:
Code:
$ locale
LANG=en_GB.ISO-8859-15
LC_CTYPE="en_GB.ISO-8859-15"
LC_NUMERIC="en_GB.ISO-8859-15"
LC_TIME="en_GB.ISO-8859-15"
LC_COLLATE="en_GB.ISO-8859-15"
LC_MONETARY="en_GB.ISO-8859-15"
LC_MESSAGES="en_GB.ISO-8859-15"
LC_PAPER="en_GB.ISO-8859-15"
LC_NAME="en_GB.ISO-8859-15"
LC_ADDRESS="en_GB.ISO-8859-15"
LC_TELEPHONE="en_GB.ISO-8859-15"
LC_MEASUREMENT="en_GB.ISO-8859-15"
LC_IDENTIFICATION="en_GB.ISO-8859-15"
LC_ALL=
cheers,
jdk
 
Old 02-15-2009, 05:31 AM   #3
Eileen Walsh
LQ Newbie
 
Registered: Feb 2009
Posts: 5

Original Poster
Rep: Reputation: 0
Hello jdk!

Code:
eileen@CDX:~$ locale
LANG=en_CA.UTF-8
LC_CTYPE="en_CA.UTF-8"
LC_NUMERIC="en_CA.UTF-8"
LC_TIME="en_CA.UTF-8"
LC_COLLATE="en_CA.UTF-8"
LC_MONETARY="en_CA.UTF-8"
LC_MESSAGES="en_CA.UTF-8"
LC_PAPER="en_CA.UTF-8"
LC_NAME="en_CA.UTF-8"
LC_ADDRESS="en_CA.UTF-8"
LC_TELEPHONE="en_CA.UTF-8"
LC_MEASUREMENT="en_CA.UTF-8"
LC_IDENTIFICATION="en_CA.UTF-8"
LC_ALL=
Here it is. Looks like I'm tuned for Canada - which is where I am. But my system settings say US ..

Thanks
 
Old 02-15-2009, 05:36 AM   #4
jdkaye
Senior Member
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 4,961

Rep: Reputation: Disabled
Quote:
Originally Posted by Eileen Walsh View Post
Hello jdk!

Here it is. Looks like I'm tuned for Canada - which is where I am. But my system settings say US ..

Thanks
Another Canadian, eh? Me too. Anyway, if hypermail is a program that runs in a terminal then those are the settings that count. Where are you getting you "system settings" from?
cheers,
jdk
 
Old 02-15-2009, 05:54 AM   #5
Eileen Walsh
LQ Newbie
 
Registered: Feb 2009
Posts: 5

Original Poster
Rep: Reputation: 0
KDE System Settings > General > Personal - Regional and Language

Thanks
 
Old 02-15-2009, 06:20 AM   #6
jdkaye
Senior Member
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 4,961

Rep: Reputation: Disabled
Quote:
Originally Posted by Eileen Walsh View Post
KDE System Settings > General > Personal - Regional and Language

Thanks
OK, this is what I suspected. So it seems that your KDE settings and your terminal settings are out of sync. Sadly, KDE doesn't have a Canadian English module so if hypermail requires that they be the same then you'll either have to change your terminal settings to US English or else change them both to British English.
You can temporarily change the language in the terminal with something like this (if I remember correctly)
Code:
export LANG='en_US'
and then see if that sorts out the hypermail issue. If that command doesn't work, try googling and you'll quickly find the correct syntax if I've got it wrong.
Cheers,
jdk
 
Old 02-15-2009, 05:30 PM   #7
Eileen Walsh
LQ Newbie
 
Registered: Feb 2009
Posts: 5

Original Poster
Rep: Reputation: 0
I tweeked the conf file and although hypermail still generates the error message - it also processes the config file and creates the html archive pages.

Thank you jdk
 
Old 02-16-2009, 12:28 AM   #8
jdkaye
Senior Member
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 4,961

Rep: Reputation: Disabled
Quote:
Originally Posted by Eileen Walsh View Post
I tweeked the conf file and although hypermail still generates the error message - it also processes the config file and creates the html archive pages.

Thank you jdk
Hi Eileen,
But did you confirm that the change actually worked. Did typing "locale" on the terminal respond with the en_US locale?
cheers,
jdk
 
Old 02-16-2009, 01:36 AM   #9
Eileen Walsh
LQ Newbie
 
Registered: Feb 2009
Posts: 5

Original Poster
Rep: Reputation: 0
Hi jdk,

Actually, after fiddling with the config file I just ran it without doing
Code:
export LANG='en_US'
.

In the config file, I changed the language to
Code:
en_CA
and I changed the output directory name to one that actually existed. I found the configuration file on the net and hadn't read it through properly. So when I first ran it, the program was trying to find the directory that was listed in the original version of the file - a directory that didn't exist on my machine.

The program gave me an error message about the language but didn't tell me that the output directory didn't exist. As you can see below, I still received an error message but hypermail processed the instructions and gave me the html'ed archive files that I wanted. In English too!

Code:
eileen@CDX:~$ hypermail -c /home/eileen/Desktop/gen.conf
Warning: the body option has been disabled. See the
INSTALL file for instructions on replacing it with a style sheet.
WARNING: locale "en_CA", not supported.
Now all I have to do is change the html templates and write a css file. I downloaded a set of templates and plan on reading them through ...

Thanks for giving me your time.
 
Old 02-16-2009, 01:59 AM   #10
jdkaye
Senior Member
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 4,961

Rep: Reputation: Disabled
Thanks so much for letting us know you got the thing working. Glad to have been of some help.
Cheers,
jdk
 
  


Reply

Tags
archive, program


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
language problem ravikantaryan Linux - Software 3 10-20-2007 12:39 AM
hypermail problem!!! tuxfood Linux - Software 0 05-02-2005 02:03 PM
Hypermail port for Windows ocumo General 2 03-06-2005 12:19 PM
Language Problem LinuxSeeker Mandriva 0 11-11-2004 11:25 AM
Language problem! pk21 Linux - Newbie 6 08-08-2002 04:14 PM


All times are GMT -5. The time now is 07:24 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration