LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
LinkBack Search this Thread
Old 09-15-2004, 01:47 AM   #1
voyciz
Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 425

Rep: Reputation: 40
Huh!? Slow scrolling all of a sudden!?


One day I did something (apparently) foolish. I tried to open a fifo file in a text editor. Was just messing around, I'm still a newbie. Well this caused everything to freeze up, so I had to kill the power. When I tried to boot up again, it froze when loading the kernel. So I then booted with the rescue disk and fscked all of my partitions. Problem fixed, loaded up fine. Everything was good...or so I thought. For some strange reason, when trying to use the backspace key, the delete key, any of the arrows, or paging with 'less', it is incredibly slow. This is everywhere: in the console, in aterm, even in the textbox I'm typing in now. This is very annoying, can it be fixed?
 
Old 09-20-2004, 05:42 PM   #2
voyciz
Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 425

Original Poster
Rep: Reputation: 40
I still cannot find an answer, but I did notice something interesting. In my XF86Config file, the auto repeat delay is set to 500, and the repeat rate is 5. But when I start X, the auto repeat delay is 660 and the repeat rate is 25. Maybe the kernel itself got screwed up somehow and overrides this setting? I really have no clue at all, but since I can't find any help on this one, maybe I'll try recompiling the kernel. Good thing I saved that config file! Well I'll report back here once I've tried it.
 
Old 09-20-2004, 06:06 PM   #3
voyciz
Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 425

Original Poster
Rep: Reputation: 40
Tried it, and it worked...sorta. It was back to it's normal speed at the console right after I started the computer up. When I went into X, it was slow again, with different settings from the ones in the config file. Then when I quit X and was back at the console, it was slow there too. Damn.
 
Old 09-25-2004, 03:33 PM   #4
voyciz
Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 425

Original Poster
Rep: Reputation: 40
Found the answer to my problem! I commented out the "AutoRepeat" option in my XF86Config file, and it's back to normal! Now it works even when I exit X, too. Strange, but whatever, fixed now.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
installed sid but scrolling is very slow tyiooo Debian 8 01-19-2008 09:29 AM
hard scrolling vs soft scrolling (console) haxcess Linux - General 2 08-30-2004 12:17 AM
HuH? Whitehat Programming 0 05-07-2004 01:15 PM
huh huh hey bevis Im guna build a puter! cognosti Linux - Hardware 28 08-12-2003 03:49 PM
Linux runs real slow all of a sudden trentk Linux - Software 2 06-16-2002 09:21 PM


All times are GMT -5. The time now is 04:22 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration