LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 11-05-2005, 11:17 AM   #1
wwnexc
Member
 
Registered: Sep 2005
Location: California
Distribution: Slackware & Debian
Posts: 264

Rep: Reputation: 30
Thumbs up https://


I was wondering how i can implement ssl with apache. I am running slackware (just installed, i changed nothing) and i downloaded and installpkg'ed mod_ssl-2.8.24_1.3.33-i486-1

I looked through many sites i have found with google, but all told me something different, and most of them were only about advanced configuration....

How can i get apache to server the site (or only parts of the website) with https:// ?

Thanks
 
Old 11-05-2005, 11:36 AM   #2
paulsm4
Guru
 
Registered: Mar 2004
Distribution: SusE 8.2
Posts: 5,863
Blog Entries: 1

Rep: Reputation: Disabled
This is a good "howto", especially for Windows - but also for Linux admins:

http://tud.at/programm/apache-ssl-win32-howto.php3

Other good links include:

http://raibledesigns.com/wiki/Wiki.jsp?page=ApacheSSL
http://www.howtoforge.com/node/5/print

There's an "INSTALL" doc that comes with your mod_ssl ... but I wouldn't blame you a bit if you found it unhelpful.

Please look at the above links and give it a shot.

Please post back if you have any questions or run into any problems. And please post back to let us know how things went!

Your .. PSM
 
Old 11-05-2005, 11:38 PM   #3
wwnexc
Member
 
Registered: Sep 2005
Location: California
Distribution: Slackware & Debian
Posts: 264

Original Poster
Rep: Reputation: 30
OK, i installed everything, as described here: http://www.modssl.org/example

The links you provided were of partial help, but i still didn't succeed. I was not really able to "translate" the windows stuff to linux.

When i try to start apache, it only wants to run in normal mode. The ssl/https simply won't work. It gives no error message, but doesn't create the process.

By the way, how can i install other modules to a apache/ssl combo, such as php or mysql support???

Thanks

by the way, what does PSM stand for?

Last edited by wwnexc; 11-05-2005 at 11:42 PM.
 
Old 11-05-2005, 11:57 PM   #4
wwnexc
Member
 
Registered: Sep 2005
Location: California
Distribution: Slackware & Debian
Posts: 264

Original Poster
Rep: Reputation: 30
i also tried to installpkg

http://slackware.it/en/pb/download.p..._1.3.33-i486-1

but i have not figured out, how to get apache to "do https", yet. I have not changed anything in the config files yet, either.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
https Ammad Linux - Networking 3 04-20-2005 04:22 AM
https rocketgo Linux - Newbie 9 12-29-2003 08:25 PM
https? rocketgo Linux - General 1 11-12-2003 08:22 PM
https spank Linux - Newbie 3 10-25-2003 02:08 PM
https Greg21 Slackware 2 06-20-2003 10:12 PM


All times are GMT -5. The time now is 01:45 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration