Visit Jeremy's Blog.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 03-27-2003, 04:04 PM   #1
LQ Newbie
Registered: Mar 2003
Distribution: Slackware
Posts: 7

Rep: Reputation: 0
httpd won't start (apache 2.0 newly installed)

Okay, my new install of Apache 2.0 won't start, saying it can't find a shared library. What am I missing?

Here's a little background:
Slackware 8.1 comes with Apache 1.3 installed and running on boot. This is great, but I thought - why not upgrade to Apache 2.0? So, I removed the 1.3 package (with removepkg) and then added the 2.0 package, like this:

[Download] $ lynx
[InstallPkg] $ installpkg httpd*
[Configure] $ ./configure  
[Compile] $ make  
[Install] $ make install  
[Customize] $ vi /usr/local/apache2/conf/httpd.conf
I also edited apachectl to point to the new httpd in /httpd-2.0.40/bindist/bin, and then I tried "apachectl start". In return for all my love and effort, I get this:

/httpd-2.0.40.bindist/bin/httpd: error while loaing shared libraries: libapruti cannot open shared object file: No such file or directory
/usr/sbin/apachectl start: httpd could not be started
Does anybody have a clue what I can change or what I'm missing?


Last edited by Who; 03-27-2003 at 04:05 PM.
Old 03-28-2003, 08:06 AM   #2
LQ Newbie
Registered: Mar 2003
Distribution: Slackware
Posts: 7

Original Poster
Rep: Reputation: 0

Problem solved with information at this post:

Oddly enough, I found this post by searching Yahoo, not the forum search.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Apache httpd start failed on fedora core 1 k_1701 Linux - Software 10 05-05-2006 07:40 AM
how to start a newly installed application ? QiEr Linux - Newbie 3 02-02-2005 01:45 AM
execute commands in order to start newly installed programs kpachopoulos Linux - Newbie 1 08-05-2004 09:08 AM
Apache httpd won't start rob19 Linux - Software 6 05-06-2003 10:41 PM
Apache problem - httpd won't start. Iced_Falcon Linux - Networking 3 12-22-2001 04:31 PM

All times are GMT -5. The time now is 11:37 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration