LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 08-27-2012, 11:45 AM   #1
mahbubur001
LQ Newbie
 
Registered: Aug 2012
Posts: 3

Rep: Reputation: Disabled
http://localhost/phpmyadmin/ [Access forbidden!]


Hello,

I am using ubuntu 12.04 and just install the xampp 1.8.0 on my ubuntu OS. it's work on http://localhost/

But when i try to access http://localhost/phpmyadmin/ Then it give me message like these ...

Code:
Access forbidden!

New XAMPP security concept:

Access to the requested directory is only available from the local network.

This setting can be configured in the file "httpd-xampp.conf".

If you think this is a server error, please contact the webmaster.
Error 403
localhost
Apache/2.4.2 (Unix) OpenSSL/1.0.1c PHP/5.4.4
Here is my httpd-xampp.conf


Code:
<IfDefine PHP4>
LoadModule php4_module        modules/libphp4.so
</IfDefine>
<IfDefine PHP5>
LoadModule php5_module        modules/libphp5.so
</IfDefine>
# Disabled in XAMPP 1.8.0-beta2 because of current incompatibilities with Apache 2.4
# LoadModule perl_module        modules/mod_perl.so


Alias /phpmyadmin "/opt/lampp/phpmyadmin"
Alias /phpsqliteadmin "/opt/lampp/phpsqliteadmin"

# since XAMPP 1.4.3
<Directory "/opt/lampp/phpmyadmin">
    AllowOverride AuthConfig Limit
    Order allow,deny
    Allow from all
</Directory>

<Directory "/opt/lampp/phpsqliteadmin">
    AllowOverride AuthConfig Limit
    Order allow,deny
    Allow from all
</Directory>

# since LAMPP 1.0RC1
AddType application/x-httpd-php .php .php3 .php4

XBitHack on

# since 0.9.8 we've mod_perl
<IfModule mod_perl.c>
        AddHandler perl-script .pl
	PerlHandler ModPerl::PerlRunPrefork
	PerlOptions +ParseHeaders
        PerlSendHeader On
</IfModule>

# demo for mod_perl responsehandler
#PerlModule Apache::CurrentTime
#<Location /time>
#      SetHandler modperl
#      PerlResponseHandler Apache::CurrentTime
#</Location>

# AcceptMutex sysvsem is default but on some systems we need this
# thanks to jeff ort for this hint
#AcceptMutex flock
#LockFile /opt/lampp/logs/accept.lock

# this makes mod_dbd happy - oswald, 02aug06
# mod_dbd doesn't work in Apache 2.2.3: getting always heaps of "glibc detected *** corrupted double-linked list" on shutdown - oswald, 10sep06
#DBDriver sqlite3

#
# New XAMPP security concept
#
<LocationMatch "^/(?i:(?:xampp|security|licenses|phpmyadmin|webalizer|server-status|server-info))">
	Order deny,allow
        #Deny from all
        Allow from all    
	ErrorDocument 403 /error/XAMPP_FORBIDDEN.html.var
</LocationMatch>

Please help me please .....
 
Old 08-28-2012, 04:56 AM   #2
Snark1994
Senior Member
 
Registered: Sep 2010
Location: Wales, UK
Distribution: Arch
Posts: 1,630
Blog Entries: 3

Rep: Reputation: 345Reputation: 345Reputation: 345Reputation: 345
Well, http://daksh21ubuntu.blogspot.co.uk/...roblem-in.html tells you how to get round it, but I don't understand what this new "feature" does - so I would be hesitant to just work round it. However, if you just want it to work and security's not a priority, then it's probably okay. Otherwise, you'll need to find out what it's meant to do (and how it's meant to be configured for it to work).

Hope this helps,
 
Old 08-29-2012, 12:19 PM   #3
mahbubur001
LQ Newbie
 
Registered: Aug 2012
Posts: 3

Original Poster
Rep: Reputation: Disabled
Thanks it works for me but need to add some permission like this

It look like this out put when i add this edit form this URL (http://daksh21ubuntu.blogspot.co.uk/...roblem-in.html)

Existing configuration file (./config.inc.php) is not readable

I over come from this problem by adding permisson like this

Code:
rasel@rasel-Dell:~$ sudo -s
rasel@rasel-Dell:~$ type your password
root@rasel-Dell:/# cd /opt/lampp/phpmyadmin
root@rasel-Dell:/opt/lampp/phpmyadmin# chmod 644 config.inc.php
root@rasel-Dell:/opt/lampp/phpmyadmin# cd /
root@rasel-Dell: /opt/lampp/lampp restart

Thats all its works for me
 
Old 08-29-2012, 12:22 PM   #4
mahbubur001
LQ Newbie
 
Registered: Aug 2012
Posts: 3

Original Poster
Rep: Reputation: Disabled
Sorry for my duplicat post . You can use it

Last edited by mahbubur001; 08-29-2012 at 12:22 PM. Reason: duplicat post
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
http://localhost/phpMyAdmin/ shows blank page mpr.mktg Linux - Server 5 04-03-2012 02:24 PM
[SOLVED] Access Forbidden to Localhost petelogan Linux - Server 7 12-20-2011 10:43 AM
PhpMyAdmin : 403 forbidden. You don't have permission to access [...] on this server. User-N@me Linux - Server 7 06-23-2011 07:30 PM
HELP FOR#1045 - Access denied for user 'phpmyadmin'@'localhost' (using password: YES) amritpalpathak Linux - Software 1 03-20-2010 05:35 PM
[SOLVED] Ubuntu Server edition 9.10, http://localhost/phpmyadmin = blank white page in browser VipX1 Linux - Server 13 12-19-2009 10:29 AM


All times are GMT -5. The time now is 12:54 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration