LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 02-25-2008, 02:49 AM   #1
Talaash
LQ Newbie
 
Registered: Dec 2007
Posts: 4

Rep: Reputation: 0
"http://localhost/" gives access error & /etc/apache2/httpd.conf is empty


Hi there,

i've got a problem installation a LAMP server on debian etch. I've got apache2 installed but with problems, when i test it with http://localhost/ it gives an error as 'localhost doesn't permit access ..' when i checked the /etc/apache2/httpd.conf, i found it empty.

kindly help..
 
Old 02-26-2008, 10:12 PM   #2
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian Squeeze
Posts: 5,739

Rep: Reputation: 298Reputation: 298Reputation: 298
Look in /etc/apache2 for a file named apache2.conf instead of httpd.conf.
 
Old 03-01-2008, 03:20 AM   #3
Talaash
LQ Newbie
 
Registered: Dec 2007
Posts: 4

Original Poster
Rep: Reputation: 0
Error: "localhost refused connection"

Yes while the httpd.conf is empty & apache2.conf is present with conf data & the "ServerRoot" is reset from "/etc/apache2" to "/var/www" folder which also contains index.html. still

http://localhost/

returns the error as

"localhost" refused the connection

likely causes of the problem are

* some service isn't started, or
* you got the port number wrong.
 
Old 03-01-2008, 06:10 PM   #4
IBall
Senior Member
 
Registered: Nov 2003
Location: Perth, Western Australia
Distribution: Ubuntu, Debian, Various using VMWare
Posts: 2,088

Rep: Reputation: 61
1st thing - is apache running?

Try
Code:
ps -ef | grep apache
to make sure.

Apache2 on Debian Etch should work out of the box without any issues (at least for a basic setup).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't access https after including "SSLVerifyClient require 1" in httpd.conf javiergt Linux - Security 6 01-16-2014 02:22 PM
samba/swat: can't connect to "http://localhost:901/" bioe007 Slackware 5 06-05-2007 11:14 AM
DPKG & "files list file for package `pkg-config' contains empty filename" error :( Angelus Debian 2 04-02-2005 07:34 AM
set, env, source & "completely empty environment..." ? na5m Linux From Scratch 1 01-28-2005 03:29 AM
"socks5" -> "http" proxy protocol, or ssh tunnel to sock5 ? I'm beyond http p vmicho Linux - Networking 2 12-16-2003 05:32 AM


All times are GMT -5. The time now is 11:26 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration