LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 01-27-2002, 11:49 PM   #1
dillera
LQ Newbie
 
Registered: Jan 2002
Posts: 1

Rep: Reputation: 0
HPT370/Abit & RedHat 7.2 Install


Hello:

There are a few threads floating around regaring problems with people installing RedHat 7.2 with ABIT mobos using the HighPoint HPT370 Raid Chipset.



I've been fighting with this all weekend and still haven't got my _own_ kernel to boot with the frigging thing. I refuse to go back to 7.1. I _will_ get this to work on 7.2!

I can do the Hipoint recomended install, and get a 2.4.7-10 initrd system working on RH 7.2. But I need some of my own modules in the kernel (like 802.1Q and IP Tables) and so I need to build my own 2.4.7-10 kernel. The 2.4.7-10 kernel that ships with RH 7.3 dosen't have the 8021Q patches in it.

No matter what I do, the blasted hpt370.o module has un-resolved symbols with my kernels, won't bring up the raid, and my pivot_root fails in the ram disk.

I've gone a built a 2.4.17 kernal which directly supports the HTP370, but I can't seem to pass the correct root partition to it for it to mount my root drive. (I've tried GRUB and lilo)

I think that the abit hpt bios (version 2.0.x for my st6-raid mb) may be the problem, since I see people talking about 2.1 drivers for the highpoint.

Damn Abit, release some updated BIOSs !!!!

I've been using GRUB and lilo, both with the same effect.

My / is the 9th partition, and with the scsi emulation of the 1.1 HP driver, it's sda9.

Now with the kernel-supported ataraid, it's supposed to be d0p9. I can't pass these things to lilo or GRUB and get my 2.4.17 kernel to mount /.

I guess my questions are:

- Who has this working with 7.2 RH, using a:
2.4.7-10 kernel & initrd (that they built)
2.4.17 kernel with ataraid support (no initrd)
what root device do you pass it?

- Who has it working with Lilo vs GRUB?

- Who has BIOS updates for the abit ST6 better than the abit site?

thanks for any comments/tips
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
HPT370 & Debian 3.0R1 install confusion blaint Linux - Hardware 0 11-13-2003 10:31 AM
Install REDHAT 9 on RAID0 (HPT370) anc Linux - Hardware 4 05-21-2003 05:33 PM
Abit KG7-RAID and Redhat 7.2 Install Issues scottbeattie Linux - Hardware 1 04-15-2002 08:30 AM
Damn you LILO... RedHat + Abit/HPT370 ATA100 controller = "LI " neeyo Linux - Software 24 02-13-2002 11:32 PM
SUCCESS! Installed dual book Win2k / RH 7.1 on SMP ABIT-VP6 with HPT370 in RAID-0 jthalhammer Linux - Software 0 12-27-2001 11:59 AM


All times are GMT -5. The time now is 09:10 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration