LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   hplip configure error -- /lib/cpp fails sanity check (http://www.linuxquestions.org/questions/linux-software-2/hplip-configure-error-lib-cpp-fails-sanity-check-288348/)

pncowley 02-09-2005 10:18 PM

hplip configure error -- /lib/cpp fails sanity check
 
I hope my issue isn't one that's been answered directly before... I've spent several hours searching both the forums and googling the internet. It seems the error is a fairly common one, although after trying several potential fixes, I have yet to hit upon a solution.

I'm attempting to install hplip for my HP Photosmart printer. According to information at hpinkjet.sourceforge.net, this should be the right driver package. I've downloaded and extracted the necessary files, and am attempting to run configure using the command ./configure --prefix=/usr . I encountered some earlier errors concerning presence of a c compiler, and overcame those by installing gcc and gcc-c++ packages. Now my error is this:

configure: error: C preprocessor "/lib/cpp" fails sanity check
See `config.log' for more details.
configure: error: /bin/sh './configure' failed for prnt

(I did not post the entire output string in the interest of space).

I've waded through the config.log file generated, but there doesn't appear to be anything meaningful there. I have installed several packages in an attempt to fix the problem, including the gcc and gcc-c++ compilers, m4, libtools, binutils, make, automake, autoconf, and bin86. Is there one I'm missing?

Disk space on my box is a bit of a concern, otherwise I'd just install every development package I could find, but rather than attempt the shotgun approach, I thought I'd post my question here.

Running slackware 10.0 on a PII-400, 3Gb HDD, networked.

320mb 02-12-2005 03:59 PM

just compile your own custom kernel .........that sanity check just
means that the version of Gcc you have installed does not match the Gcc version used to compile the currently running kernel..........
so just compile a new kernel so the Gcc versions match

__J 02-12-2005 06:54 PM

go ahead and post the config.log, your toolchain is busted. and make sure /lib/cpp points back to /usr/lib/cpp (do "ls -l /lib/cpp")

pncowley 02-13-2005 10:49 PM

@320mb: So what you're saying is I need a compiler to recompile so my compiler works? I'm a bit green with linux in general... is there a reasonable resource you could point me to?

@__J: Here's the full output of the ./configure execution, with the config.log following that. Thanks for the interest in my problem.

Full text output from ./configure --prefix=/usr
root@gandalf:/usr/hplip-0.8.8# ./configure --prefix=/usr
checking for a BSD-compatible install... /usr/bin/ginstall -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking for style of include used by make... GNU
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking dependency style of gcc... gcc3
checking for a sed that does not truncate output... /usr/bin/sed
checking for egrep... grep -E
checking for ld used by gcc... /usr/i486-slackware-linux/bin/ld
checking if the linker (/usr/i486-slackware-linux/bin/ld) is GNU ld... yes
checking for /usr/i486-slackware-linux/bin/ld option to reload object files... -r
checking for BSD-compatible nm... /usr/bin/nm -B
checking whether ln -s works... yes
checking how to recognise dependent libraries... pass_all
checking how to run the C preprocessor... /lib/cpp
configure: error: C preprocessor "/lib/cpp" fails sanity check
See `config.log' for more details.

Full text of config.log
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

It was created by configure, which was
generated by GNU Autoconf 2.59. Invocation command line was

$ ./configure --prefix=/usr

## --------- ##
## Platform. ##
## --------- ##

hostname = gandalf
uname -m = i686
uname -r = 2.4.26
uname -s = Linux
uname -v = #6 Mon Jun 14 19:07:27 PDT 2004

/usr/bin/uname -p = unknown
/bin/uname -X = unknown

/bin/arch = i686
/usr/bin/arch -k = unknown
/usr/convex/getsysinfo = unknown
hostinfo = unknown
/bin/machine = unknown
/usr/bin/oslevel = unknown
/bin/universe = unknown

PATH: /usr/local/sbin
PATH: /usr/sbin
PATH: /sbin
PATH: /usr/local/bin
PATH: /usr/bin
PATH: /bin
PATH: /usr/X11R6/bin
PATH: /usr/games
PATH: /opt/www/htdig/bin
PATH: /opt/kde/bin
PATH: /usr/lib/qt/bin


## ----------- ##
## Core tests. ##
## ----------- ##

configure:1538: checking for a BSD-compatible install
configure:1593: result: /usr/bin/ginstall -c
configure:1604: checking whether build environment is sane
configure:1647: result: yes
configure:1712: checking for gawk
configure:1728: found /usr/bin/gawk
configure:1738: result: gawk
configure:1748: checking whether make sets $(MAKE)
configure:1768: result: yes
configure:2015: checking build system type
configure:2033: result: i686-pc-linux-gnu
configure:2041: checking host system type
configure:2055: result: i686-pc-linux-gnu
configure:2075: checking for style of include used by make
configure:2103: result: GNU
configure:2174: checking for gcc
configure:2190: found /usr/bin/gcc
configure:2200: result: gcc
configure:2444: checking for C compiler version
configure:2447: gcc --version </dev/null >&5
gcc (GCC) 3.3.4
Copyright (C) 2003 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

configure:2450: $? = 0
configure:2452: gcc -v </dev/null >&5
Reading specs from /usr/lib/gcc-lib/i486-slackware-linux/3.3.4/specs
Configured with: ../gcc-3.3.4/configure --prefix=/usr --enable-shared --enable-threads=posix -
-enable-__cxa_atexit --disable-checking --with-gnu-ld --verbose --target=i486-slackware-linux
--host=i486-slackware-linux
Thread model: posix
gcc version 3.3.4
configure:2455: $? = 0
configure:2457: gcc -V </dev/null >&5
gcc: `-V' option must have argument
configure:2460: $? = 1
configure:2483: checking for C compiler default output file name
configure:2486: gcc conftest.c >&5
configure:2489: $? = 0
configure:2535: result: a.out
configure:2540: checking whether the C compiler works
configure:2546: ./a.out
configure:2549: $? = 0
configure:2566: result: yes
configure:2573: checking whether we are cross compiling
configure:2575: result: no
configure:2578: checking for suffix of executables
configure:2580: gcc -o conftest conftest.c >&5
configure:2583: $? = 0
configure:2608: result:
configure:2614: checking for suffix of object files
configure:2635: gcc -c conftest.c >&5
configure:2638: $? = 0
configure:2660: result: o
configure:2664: checking whether we are using the GNU C compiler
configure:2688: gcc -c conftest.c >&5
configure:2694: $? = 0
configure:2698: test -z
|| test ! -s conftest.err
configure:2701: $? = 0
configure:2704: test -s conftest.o
configure:2707: $? = 0
configure:2720: result: yes
configure:2726: checking whether gcc accepts -g
configure:2747: gcc -c -g conftest.c >&5
configure:2753: $? = 0
configure:2757: test -z
|| test ! -s conftest.err
configure:2760: $? = 0
configure:2763: test -s conftest.o
configure:2766: $? = 0
configure:2777: result: yes
configure:2794: checking for gcc option to accept ANSI C
configure:2864: gcc -c -g -O2 conftest.c >&5
configure:2870: $? = 0
configure:2874: test -z
|| test ! -s conftest.err
configure:2877: $? = 0
configure:2880: test -s conftest.o
configure:2883: $? = 0
configure:2901: result: none needed
configure:2919: gcc -c -g -O2 conftest.c >&5
conftest.c:2: error: parse error before "me"
configure:2925: $? = 1
configure: failed program was:
| #ifndef __cplusplus
| choke me
| #endif
configure:3060: checking dependency style of gcc
configure:3150: result: gcc3
configure:3167: checking for a sed that does not truncate output
configure:3221: result: /usr/bin/sed
configure:3224: checking for egrep
configure:3234: result: grep -E
configure:3250: checking for ld used by gcc
configure:3317: result: /usr/i486-slackware-linux/bin/ld
configure:3326: checking if the linker (/usr/i486-slackware-linux/bin/ld) is GNU ld
configure:3341: result: yes
configure:3346: checking for /usr/i486-slackware-linux/bin/ld option to reload object files
configure:3353: result: -r
configure:3362: checking for BSD-compatible nm
configure:3404: result: /usr/bin/nm -B
configure:3408: checking whether ln -s works
configure:3412: result: yes
configure:3419: checking how to recognise dependent libraries
configure:3602: result: pass_all
configure:3816: checking how to run the C preprocessor
configure:3851: gcc -E conftest.c
In file included from /usr/include/bits/posix1_lim.h:126,
from /usr/include/limits.h:144,
from /usr/lib/gcc-lib/i486-slackware-linux/3.3.4/include/limits.h:122,
from /usr/lib/gcc-lib/i486-slackware-linux/3.3.4/include/syslimits.h:7,
from /usr/lib/gcc-lib/i486-slackware-linux/3.3.4/include/limits.h:11,
from conftest.c:12:
/usr/include/bits/local_lim.h:36:26: linux/limits.h: No such file or directory
configure:3857: $? = 1
configure: failed program was:
| /* confdefs.h. */
|
| #define PACKAGE_NAME ""
| #define PACKAGE_TARNAME ""
| #define PACKAGE_VERSION ""
| #define PACKAGE_STRING ""
| #define PACKAGE_BUGREPORT ""
| #define PACKAGE "hplip"
| #define VERSION "0.8.8"
| /* end confdefs.h. */
| #ifdef __STDC__
| # include <limits.h>
| #else
| # include <assert.h>
| #endif
| Syntax error
configure:3851: gcc -E conftest.c
In file included from /usr/include/bits/posix1_lim.h:126,
from /usr/include/limits.h:144,
from /usr/lib/gcc-lib/i486-slackware-linux/3.3.4/include/limits.h:122,
from /usr/lib/gcc-lib/i486-slackware-linux/3.3.4/include/syslimits.h:7,
from /usr/lib/gcc-lib/i486-slackware-linux/3.3.4/include/limits.h:11,
from conftest.c:12:
/usr/include/bits/local_lim.h:36:26: linux/limits.h: No such file or directory
configure:3857: $? = 1
configure: failed program was:
| /* confdefs.h. */
|
| #define PACKAGE_NAME ""
| #define PACKAGE_TARNAME ""
| #define PACKAGE_VERSION ""
| #define PACKAGE_STRING ""
| #define PACKAGE_BUGREPORT ""
| #define PACKAGE "hplip"
| #define VERSION "0.8.8"
| /* end confdefs.h. */
| #ifdef __STDC__
| # include <limits.h>
| #else
| # include <assert.h>
| #endif
| Syntax error
configure:3851: gcc -E -traditional-cpp conftest.c
In file included from /usr/include/features.h:291,
from /usr/include/assert.h:36,
from conftest.c:14:
/usr/include/sys/cdefs.h:31: #error "You need a ISO C conforming compiler to use the glibc hea
ders"
configure:3857: $? = 1
configure: failed program was:
| /* confdefs.h. */
|
| #define PACKAGE_NAME ""
| #define PACKAGE_TARNAME ""
| #define PACKAGE_VERSION ""
| #define PACKAGE_STRING ""
| #define PACKAGE_BUGREPORT ""
| #define PACKAGE "hplip"
| #define VERSION "0.8.8"
| /* end confdefs.h. */
| #ifdef __STDC__
| # include <limits.h>
| #else
| # include <assert.h>
| #endif
| Syntax error
configure:3851: gcc -E -traditional-cpp conftest.c
In file included from /usr/include/features.h:291,
from /usr/include/assert.h:36,
from conftest.c:14:
/usr/include/sys/cdefs.h:31: #error "You need a ISO C conforming compiler to use the glibc hea
ders"
configure:3857: $? = 1
configure: failed program was:
| /* confdefs.h. */
|
| #define PACKAGE_NAME ""
| #define PACKAGE_TARNAME ""
| #define PACKAGE_VERSION ""
| #define PACKAGE_STRING ""
| #define PACKAGE_BUGREPORT ""
| #define PACKAGE "hplip"
| #define VERSION "0.8.8"
| /* end confdefs.h. */
| #ifdef __STDC__
| # include <limits.h>
| #else
| # include <assert.h>
| #endif
| Syntax error
configure:3851: /lib/cpp conftest.c
In file included from /usr/include/bits/posix1_lim.h:126,
from /usr/include/limits.h:144,
from /usr/lib/gcc-lib/i486-slackware-linux/3.3.4/include/limits.h:122,
from /usr/lib/gcc-lib/i486-slackware-linux/3.3.4/include/syslimits.h:7,
from /usr/lib/gcc-lib/i486-slackware-linux/3.3.4/include/limits.h:11,
from conftest.c:12:
/usr/include/bits/local_lim.h:36:26: linux/limits.h: No such file or directory
configure:3857: $? = 1
configure: failed program was:
| /* confdefs.h. */
|
| #define PACKAGE_NAME ""
| #define PACKAGE_TARNAME ""
| #define PACKAGE_VERSION ""
| #define PACKAGE_STRING ""
| #define PACKAGE_BUGREPORT ""
| #define PACKAGE "hplip"
| #define VERSION "0.8.8"
| /* end confdefs.h. */
| #ifdef __STDC__
| # include <limits.h>
| #else
| # include <assert.h>
| #endif
| Syntax error
configure:3851: /lib/cpp conftest.c
In file included from /usr/include/bits/posix1_lim.h:126,
from /usr/include/limits.h:144,
from /usr/lib/gcc-lib/i486-slackware-linux/3.3.4/include/limits.h:122,
from /usr/lib/gcc-lib/i486-slackware-linux/3.3.4/include/syslimits.h:7,
from /usr/lib/gcc-lib/i486-slackware-linux/3.3.4/include/limits.h:11,
from conftest.c:12:
/usr/include/bits/local_lim.h:36:26: linux/limits.h: No such file or directory
configure:3857: $? = 1
configure: failed program was:
| /* confdefs.h. */
|
| #define PACKAGE_NAME ""
| #define PACKAGE_TARNAME ""
| #define PACKAGE_VERSION ""
| #define PACKAGE_STRING ""
| #define PACKAGE_BUGREPORT ""
| #define PACKAGE "hplip"
| #define VERSION "0.8.8"
| /* end confdefs.h. */
| #ifdef __STDC__
| # include <limits.h>
| #else
| # include <assert.h>
| #endif
| Syntax error
configure:3934: result: /lib/cpp
configure:3958: /lib/cpp conftest.c
In file included from /usr/include/bits/posix1_lim.h:126,
from /usr/include/limits.h:144,
from /usr/lib/gcc-lib/i486-slackware-linux/3.3.4/include/limits.h:122,
from /usr/lib/gcc-lib/i486-slackware-linux/3.3.4/include/syslimits.h:7,
from /usr/lib/gcc-lib/i486-slackware-linux/3.3.4/include/limits.h:11,
from conftest.c:12:
/usr/include/bits/local_lim.h:36:26: linux/limits.h: No such file or directory
configure:3964: $? = 1
configure: failed program was:
| /* confdefs.h. */
|
| #define PACKAGE_NAME ""
| #define PACKAGE_TARNAME ""
| #define PACKAGE_VERSION ""
| #define PACKAGE_STRING ""
| #define PACKAGE_BUGREPORT ""
| #define PACKAGE "hplip"
| #define VERSION "0.8.8"
| /* end confdefs.h. */
| #ifdef __STDC__
| # include <limits.h>
| #else
| # include <assert.h>
| #endif
| Syntax error
configure:3958: /lib/cpp conftest.c
In file included from /usr/include/bits/posix1_lim.h:126,
from /usr/include/limits.h:144,
from /usr/lib/gcc-lib/i486-slackware-linux/3.3.4/include/limits.h:122,
from /usr/lib/gcc-lib/i486-slackware-linux/3.3.4/include/syslimits.h:7,
from /usr/lib/gcc-lib/i486-slackware-linux/3.3.4/include/limits.h:11,
from conftest.c:12:
/usr/include/bits/local_lim.h:36:26: linux/limits.h: No such file or directory
configure:3964: $? = 1
configure: failed program was:
| /* confdefs.h. */
|
| #define PACKAGE_NAME ""
| #define PACKAGE_TARNAME ""
| #define PACKAGE_VERSION ""
| #define PACKAGE_STRING ""
| #define PACKAGE_BUGREPORT ""
| #define PACKAGE "hplip"
| #define VERSION "0.8.8"
| /* end confdefs.h. */
| #ifdef __STDC__
| # include <limits.h>
| #else
| # include <assert.h>
| #endif
| Syntax error
configure:4033: error: C preprocessor "/lib/cpp" fails sanity check
See `config.log' for more details.

## ---------------- ##
## Cache variables. ##
## ---------------- ##

ac_cv_build=i686-pc-linux-gnu
ac_cv_build_alias=i686-pc-linux-gnu
ac_cv_c_compiler_gnu=yes
ac_cv_env_CC_set=
ac_cv_env_CC_value=
ac_cv_env_CFLAGS_set=
ac_cv_env_CFLAGS_value=
ac_cv_env_CPPFLAGS_set=
ac_cv_env_CPPFLAGS_value=
ac_cv_env_CPP_set=
ac_cv_env_CPP_value=
ac_cv_env_CXXCPP_set=
ac_cv_env_CXXCPP_value=
ac_cv_env_CXXFLAGS_set=
ac_cv_env_CXXFLAGS_value=
ac_cv_env_CXX_set=
ac_cv_env_CXX_value=
ac_cv_env_F77_set=
ac_cv_env_F77_value=
ac_cv_env_FFLAGS_set=
ac_cv_env_FFLAGS_value=
ac_cv_env_LDFLAGS_set=
ac_cv_env_LDFLAGS_value=
ac_cv_env_build_alias_set=
ac_cv_env_build_alias_value=
ac_cv_env_host_alias_set=
ac_cv_env_host_alias_value=
ac_cv_env_target_alias_set=
ac_cv_env_target_alias_value=
ac_cv_exeext=
ac_cv_host=i686-pc-linux-gnu
ac_cv_host_alias=i686-pc-linux-gnu
ac_cv_objext=o
ac_cv_path_install='/usr/bin/ginstall -c'
ac_cv_prog_AWK=gawk
ac_cv_prog_CPP=/lib/cpp
ac_cv_prog_ac_ct_CC=gcc
ac_cv_prog_cc_g=yes
ac_cv_prog_cc_stdc=
ac_cv_prog_egrep='grep -E'
ac_cv_prog_make_make_set=yes
am_cv_CC_dependencies_compiler_type=gcc3
lt_cv_deplibs_check_method=pass_all
lt_cv_file_magic_cmd='$MAGIC_CMD'
lt_cv_file_magic_test_file='/lib/libc.so.6 /lib/libc-2.3.2.so'
lt_cv_ld_reload_flag=-r
lt_cv_path_LD=/usr/i486-slackware-linux/bin/ld
lt_cv_path_NM='/usr/bin/nm -B'
lt_cv_path_SED=/usr/bin/sed
lt_cv_prog_gnu_ld=yes

## ----------------- ##
## Output variables. ##
## ----------------- ##

ACLOCAL='${SHELL} /usr/hplip-0.8.8/missing --run aclocal-1.9'
AMDEPBACKSLASH='\'
AMDEP_FALSE='#'
AMDEP_TRUE=''
AMTAR='${SHELL} /usr/hplip-0.8.8/missing --run tar'
AR=''
AUTOCONF='${SHELL} /usr/hplip-0.8.8/missing --run autoconf'
AUTOHEADER='${SHELL} /usr/hplip-0.8.8/missing --run autoheader'
AUTOMAKE='${SHELL} /usr/hplip-0.8.8/missing --run automake-1.9'
AWK='gawk'
CC='gcc'
CCDEPMODE='depmode=gcc3'
CFLAGS='-g -O2'
CHKCONFIG_PATH=''
CPP='/lib/cpp'
CPPFLAGS=''
CUPS_BACKEND_PATH=''
CXX=''
CXXCPP=''
CXXDEPMODE=''
CXXFLAGS=''
CYGPATH_W='echo'
DEFS=''
DEPDIR='.deps'
ECHO='echo'
ECHO_C=''
ECHO_N='-n'
ECHO_T=''
EGREP='grep -E'
EXEEXT=''
F77=''
FFLAGS=''
ICON_FILE=''
ICON_PATH=''
INSTALL_DATA='${INSTALL} -m 644'
INSTALL_PROGRAM='${INSTALL}'
INSTALL_SCRIPT='${INSTALL}'
INSTALL_STRIP_PROGRAM='${SHELL} $(install_sh) -c -s'
LDFLAGS=''
LIBOBJS=''
LIBS=''
LIBTOOL=''
LN_S='ln -s'
LSB_INSTALL_PATH=''
LTLIBOBJS=''
MAKEINFO='${SHELL} /usr/hplip-0.8.8/missing --run makeinfo'
OBJEXT='o'
PACKAGE='hplip'
PACKAGE_BUGREPORT=''
PACKAGE_NAME=''
PACKAGE_STRING=''
PACKAGE_TARNAME=''
PACKAGE_VERSION=''
PATH_SEPARATOR=':'
RANLIB=''
SET_MAKE=''
SHELL='/bin/sh'
STRIP=''
VERSION='0.8.8'
ac_ct_AR=''
ac_ct_CC='gcc'
ac_ct_CXX=''
ac_ct_F77=''
ac_ct_RANLIB=''
ac_ct_STRIP=''
am__fastdepCC_FALSE='#'
am__fastdepCC_TRUE=''
am__fastdepCXX_FALSE=''
am__fastdepCXX_TRUE=''
am__include='include'
am__leading_dot='.'
am__quote=''
am__tar='${AMTAR} chof - "$$tardir"'
am__untar='${AMTAR} xf -'
bindir='${exec_prefix}/bin'
build='i686-pc-linux-gnu'
build_alias=''
build_cpu='i686'
build_os='linux-gnu'
build_vendor='pc'
datadir='${prefix}/share'
exec_prefix='NONE'
host='i686-pc-linux-gnu'
host_alias=''
host_cpu='i686'
host_os='linux-gnu'
host_vendor='pc'
includedir='${prefix}/include'
infodir='${prefix}/info'
install_sh='/usr/hplip-0.8.8/install-sh'
libdir='${exec_prefix}/lib'
libexecdir='${exec_prefix}/libexec'
localstatedir='${prefix}/var'
mandir='${prefix}/man'
mkdir_p='mkdir -p --'
oldincludedir='/usr/include'
prefix='/usr'
program_transform_name='s,x,x,'
rpm_install=''
sbindir='${exec_prefix}/sbin'
sharedstatedir='${prefix}/com'
subdirs=''
sysconfdir='${prefix}/etc'
target_alias=''

## ----------- ##
## confdefs.h. ##
## ----------- ##

#define PACKAGE "hplip"
#define PACKAGE_BUGREPORT ""
#define PACKAGE_NAME ""
#define PACKAGE_STRING ""
#define PACKAGE_TARNAME ""
#define PACKAGE_VERSION ""
#define VERSION "0.8.8"

configure: exit 1

AwesomeMachine 02-13-2005 11:05 PM

If you are new to linux, do yourself a favor and get debian linux before you try slackware. All you have to do is download the first testing CD (sarge CD 1) and that will install enough stuff to get ftp working and the os(debian) will automatically download the rest and install it for you. Just don't use the 2.6 kernel in sarge or reiserfs, use 2.4 kernel and ext3. Or better yet, at the boot prompt, just hit enter and follow the directions. Slackware is not a newb distro, which is what you need for like the first year.

__J 02-14-2005 12:08 AM

looks like you need to install the kernel-headers package (not to be confused with the kernel-source package - not the same thing).

pncowley 02-24-2005 02:24 PM

Thanks... took a while to get back to the problem, but installing kernel-headers took care of the problem and creates a good makefile. Now I just need to get snmp installed on the box so I can compile with network support.


Paul.

danielganea 03-07-2005 09:16 AM

I had the same problem and i had instaled kernel-headers,but to make it work i used gcc-g++ packet.

Andrey14 04-28-2006 01:08 PM

hey dudex.. i had the same problem and searched a few days for an answer.. kernel-headers was what i needed. i see the the thread is a lil' old.. but i just signed up to thank you :)


All times are GMT -5. The time now is 06:14 AM.