LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 01-19-2007, 01:42 AM   #1
efm
Member
 
Registered: Apr 2005
Location: indonesia
Distribution: suse 10
Posts: 101

Rep: Reputation: 15
how to use dosemu+alsa+timidity?


hello,
i know that perhaps it's a cliche question,
i have tried suggestions from the net, but i can't get nowhere.
i've just set alsa by using alsaconf, and it's running.
then, i did these steps:

$ rm ~/.dosemu/run/dosemu-midi
$ mknod ~/.dosemu/run/dosemu-midi p
$ timidity -ir 8080 &
$ midid -p8080 ~/.dosemu/run/dosemu-midi
$ xdosemu

but the dos game still can't produce music,
then i tried:

$ rm ~/.dosemu/run/dosemu-midi
$ mknod ~/.dosemu/run/dosemu-midi p
$ timidity -iA &
$ aconnect 14:0 128:0
$ midid -p14:0 ~/.dosemu/run/dosemu-midi (i tried -p128:0 too),
$ xdosemu

with no luck,
and then i tried:

$ rm ~/.dosemu/run/dosemu-midi
$ mknod ~/.dosemu/run/dosemu-midi p
$ midid ~/.dosemu/run/dosemu-midi &

still with no luck..so, what should i do?

btw, if i type aconnect -o -l, it will show me this:

client 14: 'Midi Through' [type=kernel]
0 'Midi Through Port-0'

and there is no /dev/midi, or /dev/sequencer/ or /dev/snd/midi****

please help
 
Old 01-19-2007, 06:59 AM   #2
bobdevis
Member
 
Registered: Nov 2006
Distribution: Ubuntu 64bit
Posts: 49

Rep: Reputation: 15
I spend quite some time trying to config Dosmeu. Gave up. Tried Dosbox, it worked instantly and perfectly.
 
Old 01-21-2007, 07:06 PM   #3
efm
Member
 
Registered: Apr 2005
Location: indonesia
Distribution: suse 10
Posts: 101

Original Poster
Rep: Reputation: 15
i tried dosbox myself, but dosbox runs very slow on my computer...
dosemu is faster, way faster...
have i configure dosbox incorrectly?
 
Old 02-27-2007, 01:53 PM   #4
mkoyle
LQ Newbie
 
Registered: Feb 2007
Location: Western Ohio, USA
Distribution: Ubuntu
Posts: 3

Rep: Reputation: 0
Quote:
Originally Posted by efm
i tried dosbox myself, but dosbox runs very slow on my computer...
dosemu is faster, way faster...
have i configure dosbox incorrectly?
Without more information, my suggestions below are a shot in the dark. You might want to post your dosbox.conf file here. If you don't have a dosbox.conf file, that is the problem. See http://ubuntuforums.org/archive/index.php/t-246894.html for one example of a modified dosbox.conf (remember that not every setting will work on every system; your best bet is to start with the default and change a few things at a time).

The default settings for dosbox seem to emulate something like a 386 (or perhaps even something slower). As long as you have something faster than a AMD Athlon XP 1800+, I believe that changing the 'cycles=' under [cpu] to 8000 or 10000 should make it work better.

Pressing Ctrl+F8 (increase the number of frames skipped) and Ctrl+F12 (increase clock speed) several times each should also help you determine what value you can put in the cycles= and frameskip= settings (but this only modifies the current session so you need to save to a dosbox.conf file).

An explanation of the key combinations can be found at http://dosbox.sourceforge.net/wiki/i...ge=SpecialKeys

--Matthew
 
Old 02-28-2007, 07:22 PM   #5
efm
Member
 
Registered: Apr 2005
Location: indonesia
Distribution: suse 10
Posts: 101

Original Poster
Rep: Reputation: 15
hello,
here is my dosbox.conf file, but with that configuration, dosemu still runs faster (although
there is no music)

[sdl]
fullscreen=false
fulldouble=false
fullresolution=original
windowresolution=original
output=surface
autolock=true
sensitivity=100
waitonerror=true
priority=higher,normal
mapperfile=mapper.txt
usescancodes=true

[dosbox]
language=
machine=vga
captures=capture
memsize=16

[render]
frameskip=0
aspect=false
scaler=normal2x

[cpu]
#core=normal
core=full
cycles=auto
cycleup=500
cycledown=20

[mixer]
nosound=false
rate=22050
blocksize=2048
prebuffer=10

[midi]
mpu401=intelligent
device=default
config=

[sblaster]
sbtype=sb16
sbbase=220
irq=7
dma=1
hdma=5
mixer=true
oplmode=auto
oplrate=22050

[gus]
gus=true
gusrate=22050
gusbase=240
irq1=5
irq2=5
dma1=3
dma2=3
ultradir=C:\ULTRASND

[speaker]
pcspeaker=true
pcrate=22050
tandy=auto
tandyrate=22050
disney=true

[bios]
joysticktype=2axis

[serial]
serial1=dummy
serial2=dummy
serial3=disabled
serial4=disabled

[dos]
xms=true
ems=true
umb=true

[ipx]
ipx=false

[autoexec]
# Lines in this section will be run at startup.
 
Old 03-03-2007, 11:00 AM   #6
mkoyle
LQ Newbie
 
Registered: Feb 2007
Location: Western Ohio, USA
Distribution: Ubuntu
Posts: 3

Rep: Reputation: 0
Since we last messaged, dosbox has released verion 0.70; I would recommend an upgrade. After doing that, change the following sections of your dosbox.conf:

Code:
[dosbox]
language=
machine=vga
captures=capture
memsize=64

[render]
frameskip=0
aspect=false
scaler=normal2x

[cpu]
#core=normal
core=dynamic
cycles=auto
cycleup=500
cycledown=20
If the game still is not fast enough, try setting cycles manually (start with perhaps cycles=16000) and make frameskip=2 (this you can change a little-- I am guessing you already know it just makes dosbox skip rendering two frames between each of the frames it displays).

If you have opengl working on your system (this requires closed source drivers) you might change output=surface to output=opengl. For me this caused a memory leak in dosbox 0.56, but they may have fixed it (or it may even be a problem related to my hardware/drivers).

by the way, are your alsa midi modules loaded? I see you mentioned not having midi. Something like (remember I use Debian and I forget what your distro uses)
Code:
modprobe alsa-snd-seq
modprobe alsa-midi-emul
You might have to look around to figure out which modules you need to get your midi working. Also, the default setting for the midi port may not work under linux. Under [midi] I got mine working partially by setting it to config=128,0

--Matthew

Last edited by mkoyle; 03-03-2007 at 11:08 AM.
 
  


Reply

Tags
dos, dosbox


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
timidity as alsa sequencer Hyakutake Slackware 1 11-06-2006 08:10 PM
Timidity ahchewyy Suse/Novell 9 09-08-2006 09:43 AM
TiMidity++ ALSA interface dullard Linux - Newbie 0 07-29-2006 10:00 PM
Timidity as ALSA sequencer client: doesn't work after upgrade to kernel 2.6.15 vharishankar Linux - General 1 02-23-2006 09:21 AM
timidity paul62 Linux - Software 1 06-07-2005 10:59 PM


All times are GMT -5. The time now is 03:21 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration