LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Closed Thread
 
Search this Thread
Old 08-08-2003, 09:36 AM   #1
apimple2002
LQ Newbie
 
Registered: Aug 2003
Posts: 3

Rep: Reputation: 0
Question how to set network addresses for running NISTNET on red Hat Linux 9.0


Hi everybody,
I have redhat linux 9.0 installed on my machine with 2 fast ethernet NICs.
The task I want to accompish is to send traffic through the machine (through Nistnet emulator) and recieve on the other end.
Both the transmitting and recieving ports are on one network testing instrument.
Now, thw IP addresses assigned are
Transmitting port of testing instrument : 10.4.23.24
Recieving port of testing instrument : 10.4.23.25
NIC 1: 10.4.23.26
NIC 2: 10.4.23.27

I have enabled IP-forwarding using
< echo "1" > /proc/sys/net/ipv4/ip_forward >

I have also made changes to the routing table as
destination for eth0 and eth1 are 10.0.0.0 , so that it can let the traffic go through it.

But Nistnet emulator is still not working.
I am using xnistnet with GUI.
I entered source as 10.4.23.24
destination as 10.4.23.25
and vice versa in the next line.
It does not show me any readings.

Moreover When I type command "xnistnet", though the GUI screen appears, the message on the terminal is
"globalstatnistnet: no such device"
And when I enter source and destination addresses and press the "update" button, it gives me message as
"util_binaddnistnet: no such device
Error adding 10.4.23.24 ->10.4.23.25 "

Please guide me if I am wrong somewhere, because I am novice in the field of networking as well as linux.

Atul
 
  


Closed Thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to set network addresses for running NISTNET on red Hat Linux 9.0 apimple2002 Linux - Software 5 06-30-2005 06:42 AM
How do I set up a network between Windows XP and Red Hat Linux 9? G_Freeman76 Linux - Networking 4 03-04-2005 04:44 PM
Identifying port addresses in Red Hat Bondfire Linux - Newbie 8 02-07-2005 02:04 PM
Network problem on Red Hat 9 running on Microsoft Virtual PC Studious79 Linux - Newbie 1 08-18-2004 10:13 PM
how to set up FTP server on Red Hat Linux 8 therock Linux - Newbie 1 01-14-2003 05:08 AM


All times are GMT -5. The time now is 03:38 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration