LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 04-25-2013, 07:54 PM   #1
Doug Hutcheson
Member
 
Registered: Jun 2009
Location: Queensland
Distribution: Fedora 19 i686
Posts: 143

Rep: Reputation: 17
How to set default image program when mounting a card from a camera?


I am running Fedora 17. My laptop (Lenovo T61) has a card reader. For the first time, I have tried reading the card from a digital camera. When the card was automatically mounted, a dialog appeared asking if I wanted to view the contents using Shotwell, or dismount the card: there was no option to do anything else. The dialog remained in the foreground, even though I clicked away to use Nautilus to browse the card. How do I stop my system from demanding that I use Shotwell, or dismount the card? I want to use the Gimp Image Viewer, or Nautilus, not Shotwell.
 
Old 04-25-2013, 09:19 PM   #2
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,023

Rep: Reputation: 558Reputation: 558Reputation: 558Reputation: 558Reputation: 558Reputation: 558
Open file manager then find the card, right-click & select "Open With" & find Gimp , select it & if there's a box that needs to be checked to make default then check it.
 
Old 04-27-2013, 01:40 AM   #3
Doug Hutcheson
Member
 
Registered: Jun 2009
Location: Queensland
Distribution: Fedora 19 i686
Posts: 143

Original Poster
Rep: Reputation: 17
Thanks for your reply, Eddy1. Unfortunately, your suggestion does not solve the problem. I inserted the card, found it in File Manager (Nautilus), right-clicked, selected to open it under File Manager (there was no option to set this as a default) and looked at the contents. Then, I ejected the card and reinserted it. Once again, I was presented with a foreground dialog with just two options: open in Shotwell, or eject. My system did not remember my earlier instruction to open it in File Manager.

Clearly, there is some program being too clever by half, in that it assumes I want to look at the photos in Shotwell, even though I have never set such an option as a default. If I mount a file system, I want to control how my system deals with it and will almost always want to use File Manager. How do I find and fix the errant setting?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Set default sound card ursusca Gentoo 2 03-22-2010 04:55 PM
mounting memory card -low level formatted by the camera- rob07mxa Linux - General 2 09-29-2008 11:43 AM
Text file default opening program - have set, and it still ignores me! sandaili Linux - Newbie 1 09-09-2008 03:12 PM
Mounting usb camera memory card colabus Linux - Newbie 4 05-24-2004 03:39 AM
problem with mounting flash memory card from digital camera jogurt666 Linux - Hardware 3 12-07-2003 12:54 PM


All times are GMT -5. The time now is 05:57 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration