LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-04-2003, 12:01 PM   #1
caphclimber
LQ Newbie
 
Registered: Sep 2003
Location: Belgrade, Serbia
Distribution: SuSE 8.1
Posts: 23

Rep: Reputation: 15
Question How to REALY shut down the computer?


I have SuSE 8.1 and ATX mainboard, so I expect that, when I say: shutdown now, linux realy turn off the computer. Insted it say that all the processes have been killed and that te level 6 have been reached or something like that. The monitor is still turned on as well as the computer so, I have to switch the computer off manualy.

So, how to turn it off automaticaly???

Thanks for the answers...
 
Old 09-04-2003, 12:09 PM   #2
shanenin
Member
 
Registered: Aug 2003
Location: Rochester, MN, U.S.A
Distribution: Gentoo
Posts: 987

Rep: Reputation: 30
you could try poweroff
 
Old 09-04-2003, 12:14 PM   #3
quatsch
LQ Addict
 
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 48
You're telling it to shutdown now from the graphical login screen, right? If it is reaching runlevel 6, then your system is setup to reboot when you tell it to shutdown now (and it probably fails to reboot for some reason or other; mine doesn't reboot either when I tell it to). There should be an option somewhere, maybe kde control center, or some other suse sys admin tool, where you can set it to actually shutdown when you tell it to.
 
Old 09-04-2003, 01:08 PM   #4
Mega Man X
LQ Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 64
If I'm not mistaken, you need to load apm module before shutdown. Do this as root:

modprobe apm

Then you do the command you did:

shutdown -h now

If it works, you can add the line modprobe apm at your /etc/rc.d/rc.modules or rc.local, I don't know how it's in Suse

Good luck!
 
Old 09-05-2003, 12:05 PM   #5
waht
LQ Newbie
 
Registered: Sep 2003
Distribution: Red Hat 9
Posts: 1

Rep: Reputation: 0
perhaps you could try putting

init 0

into the command line as root?
 
Old 09-08-2003, 12:13 PM   #6
caphclimber
LQ Newbie
 
Registered: Sep 2003
Location: Belgrade, Serbia
Distribution: SuSE 8.1
Posts: 23

Original Poster
Rep: Reputation: 15
None of this works. I have APM module running, I can turn on and off stand by and the rests in Control Panel, but nothing changes (except standing by the computer, of course!).

Thanks on replys...
 
Old 09-08-2003, 03:45 PM   #7
wr3ck3d
Member
 
Registered: Dec 2002
Location: IL
Distribution: NetBSD, Slackware, Gentoo, Debian, FreeBSD
Posts: 444

Rep: Reputation: 31
#halt -n


I dont have any acpi or apm so it goes as far as just about to turn off. And ends at 'power off'
 
Old 09-08-2003, 03:53 PM   #8
andrewlkho
Member
 
Registered: Jul 2003
Location: London
Posts: 548

Rep: Reputation: 30
yes, to get from "power off" to actually turning off, you need to have a case that supports APM, and also to have enabled it in the kernel / installed as a module.
 
Old 09-08-2003, 09:24 PM   #9
caphclimber
LQ Newbie
 
Registered: Sep 2003
Location: Belgrade, Serbia
Distribution: SuSE 8.1
Posts: 23

Original Poster
Rep: Reputation: 15
I did it. First, I have turned apm on in grub loader, and shutdown -h worked correctly. But problem was that after a 20 seconds of inactivity my screen was scrabbled with lines and comp was blocked. I tried to change things in sysconfig and apmd_proxy but nothing helped. After about an hour of wasting time with that I have turned off APM an turned on ACPI in GRUB and for now , all is going well...

Thanks...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Computer doesn't turn off after shut down... figfighter Mandriva 3 07-22-2005 03:04 AM
HELP! -> Computer won't shut down! chocobanana Linux - Hardware 19 03-24-2005 10:15 AM
Computer Won't Shut Down djabbot Linux - General 3 01-11-2005 02:07 AM
Debian 3.0 - can't shut down computer everest Linux - Software 5 06-25-2004 05:25 PM
power off the computer after shut down gary.chan Linux - Software 1 01-05-2003 11:35 AM


All times are GMT -5. The time now is 02:27 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration