LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 04-14-2005, 04:17 PM   #1
Erin
LQ Newbie
 
Registered: Apr 2005
Posts: 4

Rep: Reputation: 0
How to pipe the default audio h/w device directly to hw:0,2


Dear all,

I run a SB!Live card. It has a co-ax out on it. Obviously, the default output port is the most commonly used one which is /dev/dsp or hw:0,0. What I would like to do is directly pipe the audio stream to hw:0,2. The reason for the semi-permenant pipe is because some applications, Ryhthmbox for example, do not seeingly support changing the output.

Google has provided some info as has Alsa's site. Bith suggest using an .asoundrc file and a plug entry. However, this does not work. I cannot get it to pipe directly. Typing "aplay -D plug:0,2 nix.wav" plays the file to hw:0,2 and I can hear it. It doesn't solve the problem though.

I have pasted .asoundrc in to a /etc/asound.conf and my own .asoundrc but nothing changes except aplay now winges (output below).

swallow:/etc# aplay /home/jerry/Utopia.WAV
ALSA lib pcm_dmix.c:1192_snd_pcm_dmix_open) Unknown field card
aplay: main:508: audio open error: Invalid argument

I am struggling with this one. Even using aoss doesn't alter anything!

Can anyone please give me any tips, hints or pointer to help my cause. I bet the answer is really simple, just I cannot get it!

Thanks in advance,
Erin
 
Old 04-14-2005, 06:35 PM   #2
foo_bar_foo
Senior Member
 
Registered: Jun 2004
Posts: 2,553

Rep: Reputation: 51
ok there is something very confusing about this post

you shouldn't have to do this kind of stuff

that's what mixers do

Simple mixer control 'IEC958 Coaxial',0
Simple mixer control 'IEC958 Optical Raw',0
Simple mixer control 'IEC958 TTL',0
Simple mixer control 'SB Live Analog/Digital Output Jack',0
Simple mixer control 'Wave LFE',0
 
Old 04-15-2005, 06:42 AM   #3
Erin
LQ Newbie
 
Registered: Apr 2005
Posts: 4

Original Poster
Rep: Reputation: 0
So, correct me if I am wrong, that toggling those to off will force the hw output device to be SPDIF as default for all applications?

Thanks Erin
 
Old 04-16-2005, 12:55 PM   #4
Erin
LQ Newbie
 
Registered: Apr 2005
Posts: 4

Original Poster
Rep: Reputation: 0
SOLVED:

Toggling 'IEC958 Optical Raw' to off sorted it.

Thanks, Erin
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Why I can't use USB audio device when onboard audio enabled in install RockyZ Fedora 6 03-28-2009 08:40 PM
default audio volume ShreeK Linux - Newbie 5 07-17-2005 12:28 AM
device default? CryptDragoon Slackware 2 02-06-2004 03:13 PM
audio CD default application hildog Linux - Newbie 1 10-04-2003 06:50 PM
change default audio device (debian woody) zhynn Debian 3 07-04-2003 05:35 PM


All times are GMT -5. The time now is 03:46 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration