LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 01-11-2007, 04:35 PM   #1
ginda
Member
 
Registered: Mar 2004
Distribution: SUSE8.2, 9.2, Knoppix
Posts: 322

Rep: Reputation: 31
How to load kernel modules


Hi guys, need your help

I have just compiled a kernel 2.6.18.6 on my fedora core 6 box and configured it with toshiba_acpi and few other bits i wanted. I added some things as modules and some into the kernel. How do i load the modules???? i can see whole bunch of files in /lib/modules/new-kernel/....


Thanks in advance
 
Old 01-11-2007, 04:52 PM   #2
FnordPerfect
Member
 
Registered: Dec 2006
Location: Germany
Distribution: Kubuntu (Feisty Fawn), Debian (SID)
Posts: 127

Rep: Reputation: 15
Manually with modprobe <module-name> or insmod /lib/modules/<kernel-version>/path/to/module.ko

some modules are loaded automatically on demand.

There ought to be a file in /etc where you can list all modules that should be loaded automatically during boot time.
 
Old 01-12-2007, 06:06 AM   #3
ginda
Member
 
Registered: Mar 2004
Distribution: SUSE8.2, 9.2, Knoppix
Posts: 322

Original Poster
Rep: Reputation: 31
Hi

I have tried what you said but receiving the following errors.

[root@localhost ~]# insmod /lib/modules/2.6.18.6-custom/kernel/net/ieee80211/ieee80211.ko
insmod: error inserting '/lib/modules/2.6.18.6-custom/kernel/net/ieee80211/ieee80211.ko': -1 Invalid module format
[root@localhost ~]# modprobe /lib/modules/2.6.18.6-custom/kernel/net/ieee80211/ieee80211.ko
FATAL: Module /lib/modules/2.6.18.6_custom/kernel/net/ieee80211/ieee80211.ko not found.

[root@localhost Desktop]# insmod /lib/modules/2.6.18.6-custom/kernel/drivers/acpi/toshiba_acpi.ko
insmod: error inserting '/lib/modules/2.6.18.6-custom/kernel/drivers/acpi/toshiba_acpi.ko': -1 No such device
[root@localhost Desktop]# modprobe /lib/modules/2.6.18.6-custom/kernel/drivers/acpi/toshiba_acpi.ko
FATAL: Module /lib/modules/2.6.18.6_custom/kernel/drivers/acpi/toshiba_acpi.ko not found


As you may have noticed i compiled a custom kernel, i did this to add support for toshiba laptops and wifi. Any ideas why im getting these problems.


Thanks again
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2.6.17 kernel runs but no modules will load!? stardotstar Linux - Kernel 3 08-11-2006 03:55 PM
How to Load Kernel Modules? binarybob0001 Linux - General 5 11-16-2005 10:15 AM
Custom kernel does not load modules Ankardo Linux - Newbie 2 06-10-2005 06:30 AM
new kernel 2.6.7 cant load modules short101 Debian 8 08-21-2004 09:59 PM
Can't load modules because I'm using an old kernel with everything else updated... leeman_s Slackware 1 05-22-2004 03:30 AM


All times are GMT -5. The time now is 01:37 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration