LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 03-10-2013, 11:08 AM   #16
doussa
LQ Newbie
 
Registered: Feb 2013
Posts: 29

Rep: Reputation: Disabled

Quote:
Originally Posted by knudfl View Post
# 14 .

What do you mean ? ?

The tests, './test' and './leach_test' must be run from ns-allinone-2.27/ns-2.27/.
That's the required location.
OK
when I extracted the mit.tar.gz under NS2.27 I have a folder nammed mit inwhich I have test file leach_test file tcl common apps ...and a mit(inwhich leach_sims,rca,uAMPS).
 
Old 03-10-2013, 11:38 AM   #17
doussa
LQ Newbie
 
Registered: Feb 2013
Posts: 29

Rep: Reputation: Disabled
Quote:
Originally Posted by doussa View Post
OK
when I extracted the mit.tar.gz under NS2.27 I have a folder nammed mit inwhich I have test file leach_test file tcl common apps ...and a mit(inwhich leach_sims,rca,uAMPS).
Now I move test file and leach_test under NS2.27 an I have the following msg
Code:
num_nodes is set 3
warning: Please use -channel as shown in tcl/ex/wireless-mitf.tcl
INITIALIZE THE LIST xListHead
Loading connection pattern...
Loading scenario file...
Starting Simulation...
channel.cc:sendUp - Calc highestAntennaZ_ and distCST_
highestAntennaZ_ = 1.5,  distCST_ = 550.0
SORTING LISTS ...DONE!
NS EXITING...
./leach_test: line 37: mit/leach_sims/leach.err: No such file or directory
If I replace this path with mit/mit/leach_sims/leach.err,can this resolve the problem ?
I'm witing for your help
 
Old 03-10-2013, 03:17 PM   #18
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,668

Rep: Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544
# 16 .
Quote:
when I extracted the mit.tar.gz under NS2.27 I have a folder named mit
in which I have test file leach_test file tcl common
That's wrong. You are supposed to use 'tar xvf mit.tar.gz' inside ns-2.27,
( only the command line can be used ) and you will get :
apps/
common/
mac/
mit/
tcl/
trace/
leach_test*
test*
package_up*
... I.e. if you are using a GUI archive tool for the unpack,
an extra folder mit/ is created : mit/mit/ is absolutely wrong.

-
 
Old 03-10-2013, 03:42 PM   #19
doussa
LQ Newbie
 
Registered: Feb 2013
Posts: 29

Rep: Reputation: Disabled
Smile

Quote:
Originally Posted by knudfl View Post
# 16 .

That's wrong. You are supposed to use 'tar xvf mit.tar.gz' inside ns-2.27,
( only the command line can be used )
... I.e. if you are using a GUI archive tool for the unpack,
an extra folder mit/ is created : mit/mit/ is absolutely wrong.

-
Ah ok you're right.Thankx for the advice.
ok I will try that.
sorry but I have another question if you can help me:I installed leach in NS2.34 at the same time and I have no problem with the installation of ns2.34 but when I run the "make"(installing leach) I got
Code:
for i in indep-utils/cmu-scen-gen/setdest indep-utils/webtrace-conv/dec indep-utils/webtrace-conv/epa indep-utils/webtrace-conv/nlanr indep-utils/webtrace-conv/ucb; do ( cd $i; make all; ) done
make[1]: Entering directory `/home/doussa/ns-allinone-2.34/ns-2.34/indep-utils/cmu-scen-gen/setdest'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/home/doussa/ns-allinone-2.34/ns-2.34/indep-utils/cmu-scen-gen/setdest'
make[1]: Entering directory `/home/doussa/ns-allinone-2.34/ns-2.34/indep-utils/webtrace-conv/dec'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/home/doussa/ns-allinone-2.34/ns-2.34/indep-utils/webtrace-conv/dec'
make[1]: Entering directory `/home/doussa/ns-allinone-2.34/ns-2.34/indep-utils/webtrace-conv/epa'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/home/doussa/ns-allinone-2.34/ns-2.34/indep-utils/webtrace-conv/epa'
make[1]: Entering directory `/home/doussa/ns-allinone-2.34/ns-2.34/indep-utils/webtrace-conv/nlanr'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/home/doussa/ns-allinone-2.34/ns-2.34/indep-utils/webtrace-conv/nlanr'
make[1]: Entering directory `/home/doussa/ns-allinone-2.34/ns-2.34/indep-utils/webtrace-conv/ucb'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/home/doussa/ns-allinone-2.34/ns-2.34/indep-utils/web
Does it mean that is no problem?
and when I run "bash ./test",I got no errors in leach.err but the total energy=319 which is ellogical result.
thx knudfl for your efforts.
 
Old 03-10-2013, 03:55 PM   #20
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,668

Rep: Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544
# 19 .
Quote:
Nothing to be done for `all'.
Means : Everything is OK, because you did build this with a previous 'make'.


Quote:
when I run "bash ./test",I got no errors in leach.err
Perfect.


Quote:
energy=319 which is ellogical result.
Same as post # 13 : Please read answers about energy, probably by @deepa_2111 .
→ I.e. in the two long leach threads.

-
 
Old 03-10-2013, 04:14 PM   #21
doussa
LQ Newbie
 
Registered: Feb 2013
Posts: 29

Rep: Reputation: Disabled
Quote:
Originally Posted by knudfl View Post
# 19 .

Same as post # 13 : Please read answers about energy, probably by @deepa_2111 .


-
ok knudfl thx a lot.
 
  


Reply

Tags
leach, ns2, ns227


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
i am using ubuntu as os. for NS2 to implement a routing protocol in ns2. sujovasu Programming 1 07-27-2010 01:44 AM
NS2.34 won't install on ubuntu 9.10 insync Linux - Wireless Networking 1 02-25-2010 02:34 AM
How to install NS2 simulator(version 2.29) in Fedora 7. mrbhush General 1 05-06-2009 01:41 AM
32 bits version distros running 64 bits CPU javb Linux - General 4 04-02-2006 07:21 AM


All times are GMT -5. The time now is 03:42 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration