LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   How to install fvwm? (http://www.linuxquestions.org/questions/linux-software-2/how-to-install-fvwm-757117/)

MTK358 09-22-2009 07:59 PM

How to install fvwm?
 
I have downloaded fvwm source code, and now I have some problems:
  • When I run the ./configure script, it says that it is optimized for GNOME and GTK is not detected. But I need GTK and don't want GNOME.
  • How do I stop GNOME and Metacity and start FVWM instead?
  • How to make it come up on startup instead of GNOME and Metacity?

slakmagik 09-22-2009 08:16 PM

I don't remember having to disable gnome and certainly haven't had to for years. I believe '--without-gnome-includes --without-gnome-libs --without-gnome' might get it done. I also don't use the gtk stuff for fvwm but I believe it is gtk1 and you probably don't have gtk1 on your system (or at least not gtk1 dev stuff). This won't affect your ability to run your normal gtk2 apps - it basically just affects an fvwm module or two. If you really need it, install the gtk1 dev stuff, I guess.

-- Yeah, all this is in the INSTALL.fvwm document. Read that.

As far as killing metacity, I think it's a gconf setting - search for 'metacity' and where it's being defined as the WM, replace it with fvwm. I think it's KDE that has the KWM variable or whatever.

-- I'm sure this comes up a lot. Try searching the web/this site.

As far as making it come up, it's an xsession issue. I don't know the details.

-- Ditto on the search.

But surely you can install fvwm from an rpm? (Assuming this is for Fedora.) Then it would probably take care of the Xsession stuff for you... though it likely is linked to gnome stuff then. Still, the rpm thing will do the deps, right?

Anyway - always read the docs and search the web.

knudfl 09-23-2009 01:46 AM

Welcome to LQ.

You can also do : # yum install fvwm

.. to get a genuine Fedora 11 package.
Then you will avoid all -devel packages,
required for compiling, and it is easy
to uninstall, if you don't like the
Fedora version of fvwm.
.....

MTK358 09-23-2009 06:47 AM

Quote:

Originally Posted by slakmagik (Post 3693574)
I don't remember having to disable gnome and certainly haven't had to for years. I believe '--without-gnome-includes --without-gnome-libs --without-gnome' might get it done.

configure still outputs this:

Code:

blah blah blah...

  With GNOME Window Manager hints?  yes
  With GTK support for FvwmGtk?      no: Failed to detect GTK, see config.log
  With Multibyte support?            no: Use --enable-multibyte to enable
  With ReadLine sup. in FvwmConsole? yes
  With RPlay support in FvwmEvent?  no: Can't find working librplay
  With Shaped window support?        yes
  With Session Management support?  yes
  With Stroke support?              no: Can't find working libstroke
  With Xinerama support?            yes Good, because I have dual monitors
  With XPM support?                  yes

Quote:

Originally Posted by slakmagik (Post 3693574)
I also don't use the gtk stuff for fvwm but I believe it is gtk1 and you probably don't have gtk1 on your system (or at least not gtk1 dev stuff). This won't affect your ability to run your normal gtk2 apps - it basically just affects an fvwm module or two. If you really need it, install the gtk1 dev stuff, I guess.

Does that mean that FvwmButtons, etc will not work?

MTK358 09-23-2009 07:23 AM

OK, I decided to skip the trouble and just use what "sudo yum install fvwm" gave me. but what to do with it now?

i92guboj 09-23-2009 11:11 AM

The window manager hints have nothing to do with the gtk support, though I absolutely know nothing concrete about what's it about in fvwm.

Second, the only gtk support in fvwm is for FvwmGtk. FvwmGtk is an alternative for the fvwm builtin menus and FvwmForms, and as far as I know, that's all its scope. I've *never* compiled the gtk support in fvwm, and never missed it certainly, your mileage may vary. However, and in any case, it requires gtk *1.x*, and it won't work with 2.x.

About how to use it... well, it depends. Do you want to use it inside of gnome (in place of metacity) or do you want to use it standalone? How are you starting X? startx or gdm?

ps. FvwmButtons has nothing to do with this. As said, the only relevant module for gtk is FvwmGtk. The rest will work perfectly. I have no idea if the fedora pre-built fvwm has that enabled or not (i'd guess not). fvwm -V might tell you something about what has been compiled in.

MTK358 09-23-2009 11:16 AM

Quote:

Originally Posted by i92guboj (Post 3694364)
About how to use it... well, it depends. Do you want to use it inside of gnome (in place of metacity) or do you want to use it standalone?

I want to use fvwm standalone.

Quote:

Originally Posted by i92guboj (Post 3694364)
How are you starting X? startx or gdm?

I don't know. When it boots, it brings up a window where I click my username and enter my password, and it just starts.

i92guboj 09-23-2009 11:34 AM

Quote:

Originally Posted by MTK358 (Post 3694370)
I want to use fvwm standalone.

Right.


Quote:

I don't know. When it boots, it brings up a window where I click my username and enter my password, and it just starts.
That's the login manager. Look around, there should be an options menu where you should be able to choose what kind of session you want to start. Fvwm should be there.

If it isn't, the you would need to select probably the default session or something similar, after putting fvwm in your ~/.xsession file. It's been years since I used a graphical login manager so I am really not sure, but it should be a matter of editing ~/.xsession, inserting a single line containing "fvwm", save it, and in the next login select the default session, user defined or something along those lines.

MTK358 09-23-2009 12:13 PM

That worked, there were no icons/taskbar, and the GUI widget theme changed to a bluish-glassy looking one like when I installed Fedora. I wonder if it is the GTK default or something?

But one HUGE problem: Even though this is not a laptop, I am using a PCI WiFi card (RaLink RT2860 chipset) because this computer is on the second floor very far from the router. It is using a driver I installed by executing "sudo yum install rt2860". The problem is that the program that connects me to the home network runs in GNOME panel (in the about box, it says it's "NetworkManager Applet"), so in FVWM I have no internet! I had to log out and choose GNOME to get back online and write this. What should I do?

i92guboj 09-23-2009 12:39 PM

Quote:

Originally Posted by MTK358 (Post 3694437)
That worked, there were no icons/taskbar

The fvwm default configuration only includes a menu that appears when you click on the root window (the surface where the wallpaper would normally appear in other wm's). It is far more configurable that most wm's, but the default config is as simple as it can get.

Here's a guide that you can use to give your first steps into fvwm, a bit old but it mostly works ok:

http://www.zensites.net/fvwm/guide/index.html

Of course, feel free to ask any specific question, here or in the fvwm user mailing list.

Quote:

, and the GUI widget theme changed to a bluish-glassy looking one like when I installed Fedora. I wonder if it is the GTK default or something?
There's a number of ways to configure the gtk theme outside of gnome (if it's truly the gtk theme what you mean, which I am not 100% sure). You can try installing gtk-chtheme, or lxappereance if my memory serves and the spelling is correct, these will allow you to configure the aspect of gtk applications :p

Quote:

But one HUGE problem: Even though this is not a laptop, I am using a PCI WiFi card (RaLink RT2860 chipset) because this computer is on the second floor very far from the router. It is using a driver I installed by executing "sudo yum install rt2860". The problem is that the program that connects me to the home network runs in GNOME panel (in the about box, it says it's "NetworkManager Applet"), so in FVWM I have no internet! I had to log out and choose GNOME to get back online and write this. What should I do?
I understand very little about wireless stuff, but this applets are usually a frontend to something else which is what actually does the work. For the time being I guess you could run gnome-panel inside of fvwm. Assuming that the gnome-panel tool is still called "gnome-panel", you should be able to load it at startup by including this line in your fvwm config (usually at ~/.fvwm/config):

Code:

AddToFunc StartFunction I Test (Init) Exec exec gnome-panel
Or, just click on the background, choose "issue fvwm commands", and in the window that appears run this command:

Code:

Exec exec gnome-panel
The later is not permanent though but it can serve you as a quick test to see if gnome-panel starts ok. If it works, you should see the gnome panel there (don't worry about the window decoration and the position, that can be fixed later), if that's acceptable for you, then it's ok, if not, then you are going to have to research how to use the wireless stuff without the gnome network manager. There's a way for sure, but I am not into wireless nor into gnome so I wouldn't really know where to start looking to solve that.

You can always open a new thread "looking for a substitute for the gnome network manager" ;)

MTK358 09-23-2009 12:49 PM

Quote:

Originally Posted by i92guboj (Post 3694475)
You can always open a new thread "looking for a substitute for the gnome network manager" ;)

Guess so.

EDIT: I already did so: http://www.linuxquestions.org/questi...10#post3694510

Elv13 09-23-2009 10:38 PM

Start nm-applet in any windows manager supporitng systray and it will work, you may wwant to add it to the autoload list.

MTK358 09-24-2009 07:20 AM

I'm not sure what that means.

i92guboj 09-24-2009 09:47 AM

I think that nm-applet is the gnome network manager. For what he says, nm-applet will work outside of gnome as well because it's an application that lives iconified in the system tray, and not a gnome panel applet. That's good news because if you want, you can continue using it in fvwm.

It will need a system tray to live into. Fvwm has no system tray, but an external one can be used (a popular one is stalonetray). So, you would need to install and run stalonetray to get a system tray, then nm-applet. Again, don't worry about integration, everything can be arranged at a later stage. Just install stalonetray, then launch it, and once stalonetray is working (you should see an empty window) try to launch nm-applet, if it works then you should see a tray icon inside the stalonetray window, and you should be able to manage your network as you always did.

MTK358 09-24-2009 10:00 AM

I'll see how that goes. I was actually wondering about the system tray in FVWM.

EDIT: I can't seem to find "standalonetray" anywhere.


All times are GMT -5. The time now is 09:37 PM.