LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   how to install both ns2.28 and ns2.34 versions on ubuntu 10.04? (http://www.linuxquestions.org/questions/linux-software-2/how-to-install-both-ns2-28-and-ns2-34-versions-on-ubuntu-10-04-a-4175445028/)

popoaung 01-10-2013 01:37 PM

how to install both ns2.28 and ns2.34 versions on ubuntu 10.04?
 
Dear Sir,
i want to know how to install both ns2.28 and ns2.34 on ubuntu10.04? but i have already installed ns2.34. please help me.

knudfl 01-10-2013 03:31 PM

'ns-allinone-2.28' : Post # 15 here
http://www.linuxquestions.org/questi...0-04-a-842773/

Using the Ubuntu g++-4.1 : sudo apt-get install g++-4.1
... the install command is then :
cd ns-allinone-2.28/ && export CC=gcc-4.1 CXX=g++-4.1 && ./install

Ndia 06-10-2013 02:16 PM

Similar question to post #1 but not same

I have ns2.29 already installed on my windows 7 over Cygwin,how do I go about installing ns2.34?

knudfl 06-10-2013 05:52 PM

# 3 .

Don't know how Cygwin works.
If is like a normal Linux OS, you can have an infinite number
of executable ns in /usr/local/bin/ : ns ns-orig ns229 ns234 etc. etc.
I.e. the trick is to use different names for all your "ns executable".
(Or you can use './ns' instead of having ns in a particular PATH.)

Most simulations will work with any name for 'ns' :
$ ns229 example.tcl , $ ns234 example.tcl , etc.

-


All times are GMT -5. The time now is 08:35 PM.