LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 04-17-2006, 10:56 PM   #1
thisObject
Member
 
Registered: Apr 2006
Posts: 170

Rep: Reputation: 30
how to install apache2-threaded-dev_2.0.54-5_i386.deb


I found out that to connect apache and tomcat I need to install this package: apache2-threaded-dev_2.0.54-5_i386.deb.

Step by step procedure how to merge apache and tomcat I got here:
http://www.linuxquestions.org/questi...ache+connector

I do not know how to install this package. How would I do that?

Thanks
 
Old 04-18-2006, 12:24 AM   #2
thisObject
Member
 
Registered: Apr 2006
Posts: 170

Original Poster
Rep: Reputation: 30
i.e to run this command:
./configure --with-apxs=/usr/bin/apxs2
I need to have apxs. I saw that I need a package httpd-devel-2.2.0-6.i386.rpm to have apxs
Installation of this package fails.
I have not idea how to procede.
I am amazed that there is no documentation on how to configure Apache and Tomcat for FC5 anywhere. Seems that Tomcat is a widely-used technology but not documentation what so ever for it.

Did anyone had to configure Tomcat and Apache to work together?
Are there any good docs on this?

Thanks
 
Old 04-18-2006, 01:17 AM   #3
thisObject
Member
 
Registered: Apr 2006
Posts: 170

Original Poster
Rep: Reputation: 30
Here is the error that I get

[root@mydomain Desktop]# rpm -i httpd*
error: Failed dependencies:
apr-devel is needed by httpd-devel-2.2.0-6.i386
apr-util-devel is needed by httpd-devel-2.2.0-6.i386
httpd = 2.2.0-6 is needed by httpd-devel-2.2.0-6.i386
 
Old 04-18-2006, 01:39 AM   #4
thisObject
Member
 
Registered: Apr 2006
Posts: 170

Original Poster
Rep: Reputation: 30
I installed apr-devel and apr-util-devel using yum
yum install ....
now i have only:
httpd = 2.2.0-6 is needed by httpd-devel-2.2.0-6.i386
is httpd a package?
thanks
 
Old 04-18-2006, 01:52 AM   #5
thisObject
Member
 
Registered: Apr 2006
Posts: 170

Original Poster
Rep: Reputation: 30
I tried to install this package:
httpd-2.2.0-6.i386.rpm but got thie error:
rpm -ivh httpd-2.2.0-6.i386.rpm
Preparing... ########################################### [100%]
file /usr/bin/ab from install of httpd-2.2.0-6 conflicts with file from package httpd-2.2.0-5.1.2
file /usr/bin/htdbm from install of httpd-2.2.0-6 conflicts with file fr om package httpd-2.2.0-5.1.2
file /usr/bin/htdigest from install of httpd-2.2.0-6 conflicts with file from package httpd-2.2.0-5.1.2
file /usr/bin/htpasswd from install of httpd-2.2.0-6 conflicts with file from package httpd-2.2.0-5.1.2
file /usr/bin/logresolve from install of httpd-2.2.0-6 conflicts with fi le from package httpd-2.2.0-5.1.2
file /usr/lib/httpd/modules/mod_actions.so from install of httpd-2.2.0-6 conflicts with file from package httpd-2.2.0-5.1.2
file /usr/lib/httpd/modules/mod_alias.so from install of httpd-2.2.0-6 c onflicts with file from package httpd-2.2.0-5.1.2
file /usr/lib/httpd/modules/mod_asis.so from install of httpd-2.2.0-6 co nflicts with file from package httpd-2.2.0-5.1.2
file /usr/lib/httpd/modules/mod_auth_basic.so from install of httpd-2.2. 0-6 conflicts with file from package httpd-2.2.0-5.1.2
file /usr/lib/httpd/modules/mod_auth_digest.so from install of httpd-2.2 .0-6 conflicts with file from package httpd-2.2.0-5.1.2
file /usr/lib/httpd/modules/mod_authn_alias.so from install of httpd-2.2 .0-6 conflicts with file from package httpd-2.2.0-5.1.2
file /usr/lib/httpd/modules/mod_authn_anon.so from install of httpd-2.2. 0-6 conflicts with file from package httpd-2.2.0-5.1.2
file /usr/lib/httpd/modules/mod_authn_dbd.so from install of httpd-2.2.0 -6 conflicts with file from package httpd-2.2.0-5.1.2
file /usr/lib/httpd/modules/mod_authn_dbm.so from install of httpd-2.2.0 -6 conflicts with file from package httpd-2.2.0-5.1.2
file /usr/lib/httpd/modules/mod_authn_default.so from install of httpd-2 .2.0-6 conflicts with file from package httpd-2.2.0-5.1.2
file /usr/lib/httpd/modules/mod_authn_file.so from install of httpd-2.2. 0-6 conflicts with file from package httpd-2.2.0-5.1.2
file /usr/lib/httpd/modules/mod_authnz_ldap.so from install of httpd-2.2 .0-6 conflicts with file from package httpd-2.2.0-5.1.2
file /usr/lib/httpd/modules/mod_authz_dbm.so from install of httpd-2.2.0 -6 conflicts with file from package httpd-2.2.0-5.1.2
file /usr/lib/httpd/modules/mod_authz_default.so from install of httpd-2 .2.0-6 conflicts with file from package httpd-2.2.0-5.1.2
file /usr/lib/httpd/modules/mod_authz_groupfile.so from install of httpd -2.2.0-6 conflicts with file from package httpd-2.2.0-5.1.2
file /usr/lib/httpd/modules/mod_authz_host.so from install of httpd-2.2. 0-6 conflicts with file from package httpd-2.2.0-5.1.2
file /usr/lib/httpd/modules/mod_authz_owner.so from install of httpd-2.2 .0-6 conflicts with file from package httpd-2.2.0-5.1.2
file /usr/lib/httpd/modules/mod_authz_user.so from install of httpd-2.2. 0-6 conflicts with file from package httpd-2.2.0-5.1.2
file /usr/lib/httpd/modules/mod_autoindex.so from install of httpd-2.2.0 -6 conflicts with file from package httpd-2.2.0-5.1.2
file /usr/lib/httpd/modules/mod_cache.so from install of httpd-2.2.0-6 c onflicts with file from package httpd-2.2.0-5.1.2
file /usr/lib/httpd/modules/mod_cern_meta.so from install of httpd-2.2.0 -6 conflicts with file from package httpd-2.2.0-5.1.2
file /usr/lib/httpd/modules/mod_cgi.so from install of httpd-2.2.0-6 con flicts with file from package httpd-2.2.0-5.1.2
file /usr/lib/httpd/modules/mod_cgid.so from install of httpd-2.2.0-6 co nflicts with file from package httpd-2.2.0-5.1.2
file /usr/lib/httpd/modules/mod_dav.so from install of httpd-2.2.0-6 con flicts with file from package httpd-2.2.0-5.1.2
file /usr/lib/httpd/modules/mod_dav_fs.so from install of httpd-2.2.0-6 conflicts with file from package httpd-2.2.0-5.1.2
file /usr/lib/httpd/modules/mod_dbd.so from install of httpd-2.2.0-6 con flicts with file from package httpd-2.2.0-5.1.2
file /usr/lib/httpd/modules/mod_deflate.so from install of httpd-2.2.0-6 conflicts with file from package httpd-2.2.0-5.1.2
file /usr/lib/httpd/modules/mod_dir.so from install of httpd-2.2.0-6 con flicts with file from package httpd-2.2.0-5.1.2
file /usr/lib/httpd/modules/mod_disk_cache.so from install of httpd-2.2. 0-6 conflicts with file from package httpd-2.2.0-5.1.2
file /usr/lib/httpd/modules/mod_dumpio.so from install of httpd-2.2.0-6 conflicts with file from package httpd-2.2.0-5.1.2
file /usr/lib/httpd/modules/mod_env.so from install of httpd-2.2.0-6 con flicts with file from package httpd-2.2.0-5.1.2
file /usr/lib/httpd/modules/mod_expires.so from install of httpd-2.2.0-6 conflicts with file from package httpd-2.2.0-5.1.2
file /usr/lib/httpd/modules/mod_ext_filter.so from install of httpd-2.2. 0-6 conflicts with file from package httpd-2.2.0-5.1.2
file /usr/lib/httpd/modules/mod_file_cache.so from install of httpd-2.2. 0-6 conflicts with file from package httpd-2.2.0-5.1.2
file /usr/lib/httpd/modules/mod_filter.so from install of httpd-2.2.0-6 conflicts with file from package httpd-2.2.0-5.1.2
file /usr/lib/httpd/modules/mod_headers.so from install of httpd-2.2.0-6 conflicts with file from package httpd-2.2.0-5.1.2
file /usr/lib/httpd/modules/mod_ident.so from install of httpd-2.2.0-6 c onflicts with file from package httpd-2.2.0-5.1.2
file /usr/lib/httpd/modules/mod_imagemap.so from install of httpd-2.2.0- 6 conflicts with file from package httpd-2.2.0-5.1.2
file /usr/lib/httpd/modules/mod_include.so from install of httpd-2.2.0-6 conflicts with file from package httpd-2.2.0-5.1.2
file /usr/lib/httpd/modules/mod_info.so from install of httpd-2.2.0-6 co nflicts with file from package httpd-2.2.0-5.1.2
file /usr/lib/httpd/modules/mod_ldap.so from install of httpd-2.2.0-6 co nflicts with file from package httpd-2.2.0-5.1.2
file /usr/lib/httpd/modules/mod_log_config.so from install of httpd-2.2. 0-6 conflicts with file from package httpd-2.2.0-5.1.2
file /usr/lib/httpd/modules/mod_log_forensic.so from install of httpd-2. 2.0-6 conflicts with file from package httpd-2.2.0-5.1.2
file /usr/lib/httpd/modules/mod_logio.so from install of httpd-2.2.0-6 c onflicts with file from package httpd-2.2.0-5.1.2
file /usr/lib/httpd/modules/mod_mem_cache.so from install of httpd-2.2.0 -6 conflicts with file from package httpd-2.2.0-5.1.2
file /usr/lib/httpd/modules/mod_mime.so from install of httpd-2.2.0-6 co nflicts with file from package httpd-2.2.0-5.1.2
file /usr/lib/httpd/modules/mod_mime_magic.so from install of httpd-2.2. 0-6 conflicts with file from package httpd-2.2.0-5.1.2
file /usr/lib/httpd/modules/mod_negotiation.so from install of httpd-2.2 .0-6 conflicts with file from package httpd-2.2.0-5.1.2
file /usr/lib/httpd/modules/mod_proxy.so from install of httpd-2.2.0-6 c onflicts with file from package httpd-2.2.0-5.1.2
file /usr/lib/httpd/modules/mod_proxy_ajp.so from install of httpd-2.2.0 -6 conflicts with file from package httpd-2.2.0-5.1.2
file /usr/lib/httpd/modules/mod_proxy_balancer.so from install of httpd- 2.2.0-6 conflicts with file from package httpd-2.2.0-5.1.2
file /usr/lib/httpd/modules/mod_proxy_connect.so from install of httpd-2 .2.0-6 conflicts with file from package httpd-2.2.0-5.1.2
file /usr/lib/httpd/modules/mod_proxy_ftp.so from install of httpd-2.2.0 -6 conflicts with file from package httpd-2.2.0-5.1.2
file /usr/lib/httpd/modules/mod_proxy_http.so from install of httpd-2.2. 0-6 conflicts with file from package httpd-2.2.0-5.1.2
file /usr/lib/httpd/modules/mod_rewrite.so from install of httpd-2.2.0-6 conflicts with file from package httpd-2.2.0-5.1.2
file /usr/lib/httpd/modules/mod_setenvif.so from install of httpd-2.2.0- 6 conflicts with file from package httpd-2.2.0-5.1.2
file /usr/lib/httpd/modules/mod_speling.so from install of httpd-2.2.0-6 conflicts with file from package httpd-2.2.0-5.1.2
file /usr/lib/httpd/modules/mod_status.so from install of httpd-2.2.0-6 conflicts with file from package httpd-2.2.0-5.1.2
file /usr/lib/httpd/modules/mod_suexec.so from install of httpd-2.2.0-6 conflicts with file from package httpd-2.2.0-5.1.2
file /usr/lib/httpd/modules/mod_unique_id.so from install of httpd-2.2.0 -6 conflicts with file from package httpd-2.2.0-5.1.2
file /usr/lib/httpd/modules/mod_userdir.so from install of httpd-2.2.0-6 conflicts with file from package httpd-2.2.0-5.1.2
file /usr/lib/httpd/modules/mod_usertrack.so from install of httpd-2.2.0 -6 conflicts with file from package httpd-2.2.0-5.1.2
file /usr/lib/httpd/modules/mod_version.so from install of httpd-2.2.0-6 conflicts with file from package httpd-2.2.0-5.1.2
file /usr/lib/httpd/modules/mod_vhost_alias.so from install of httpd-2.2 .0-6 conflicts with file from package httpd-2.2.0-5.1.2
file /usr/sbin/htcacheclean from install of httpd-2.2.0-6 conflicts with file from package httpd-2.2.0-5.1.2
file /usr/sbin/httpd from install of httpd-2.2.0-6 conflicts with file f rom package httpd-2.2.0-5.1.2
file /usr/sbin/httpd.worker from install of httpd-2.2.0-6 conflicts with file from package httpd-2.2.0-5.1.2
file /usr/sbin/httxt2dbm from install of httpd-2.2.0-6 conflicts with fi le from package httpd-2.2.0-5.1.2
file /usr/sbin/rotatelogs from install of httpd-2.2.0-6 conflicts with f ile from package httpd-2.2.0-5.1.2
file /usr/sbin/suexec from install of httpd-2.2.0-6 conflicts with file from package httpd-2.2.0-5.1.2


???
 
Old 04-18-2006, 09:47 AM   #6
thisObject
Member
 
Registered: Apr 2006
Posts: 170

Original Poster
Rep: Reputation: 30
This is actually a part of a bigger problem - I need to have a connector between Apache and Tomcat to serve jsp pages (as I mentioned above). I can’t find good docs on this. If anyone can help me out on this it’d be great!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to install .deb ??? harlemno1 Linux - Software 3 08-11-2006 11:48 PM
Make Install xmms-plugin install fail - deb sarge Khepri Linux - Software 2 02-18-2006 10:05 PM
deb install in fedora??? kevingpo Linux - General 2 07-30-2005 08:23 AM
What is the difference between a "Threaded version" and "Non Threaded" packages? davidas Linux - Newbie 1 04-05-2004 06:23 PM
Can apt4rpm use deb repositories or install .deb packages? raylpc Linux - General 0 08-18-2003 01:49 AM


All times are GMT -5. The time now is 03:07 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration