LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 09-01-2005, 01:23 AM   #1
mukeshj
LQ Newbie
 
Registered: Jun 2005
Posts: 17

Rep: Reputation: 0
Question how to install and run Xfbdev?


hi,

i have fedoa core 4 installed on my system. i dont know which xserver it uses by default. i just want to install and run Xfbdev xserver in order to check its performance.

i dont have any idea of it. but i have successfully built Xfbdev executable (only) from xfree86 source tree. now i want to know how to proceed in order to install and run Xfbdev on my system and system boots up with some xserver running (installed with fedora core installation).

please help.
 
Old 09-01-2005, 12:55 PM   #2
mukeshj
LQ Newbie
 
Registered: Jun 2005
Posts: 17

Original Poster
Rep: Reputation: 0
Angry installed Xfbdev but could not find /dev/fb0

hi,

i am here again, i have installed Xfbdev on my system successfully. but when i restarted my system, X did not start, as it could not find /dev/fb0. /dev/fb0 is not present on my system.

please could any one tell me how to create /dev/fb0 or how to get Xfbdev working?

thanx in advance.
 
Old 09-04-2005, 11:17 AM   #3
mukeshj
LQ Newbie
 
Registered: Jun 2005
Posts: 17

Original Poster
Rep: Reputation: 0
Wink its working ...

hi,

when i just peeped into my friends systems, which has RED HAT 9 and FEDORA2. Both OS have /dev/fb, but when i installed Xfbdev on them, same problem came.

then i googled for it, and found some important things that you have to specify the framebuffer size and other parameters in boot options, then only device for framebuffer will be created (in case of udev - fedora 3 and 4). i have added following lines in my grub.conf and installed it on mbr. and everything worked.

title Fedora Core (2.6.11-1.1369_FC4) Xfbdev & framebuffer
root (hd0,9)
kernel /vmlinuz-2.6.11-1.1369_FC4 ro root=LABEL=/1 rhgb quiet vesafb:mtrr,ywrap vga=0x318
initrd /initrd-2.6.11-1.1369_FC4.img

here i just added "vesafb:mtrr,ywrap vga=0x318", other things were present previously.

and my xfbdev server is running well.

thanx for everyone who showed interest in solving my problem.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to run after install joepesci Linux - Newbie 1 08-07-2004 10:34 AM
Trying to run photoshop in wine. Install, but wont run. bruno buys Linux - Software 14 07-15-2004 04:30 PM
How to install and run sh in Redhat 9??? DeanB Linux - General 1 09-24-2003 04:55 PM
how to install .run files? wed3k Linux - Newbie 2 08-19-2003 09:11 PM
Netscape Won't run after Install.. mrl Linux - Software 0 05-08-2001 02:09 PM


All times are GMT -5. The time now is 12:06 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration