LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 08-26-2005, 02:02 AM   #1
Lucas10
Member
 
Registered: Jun 2005
Location: Sainte-Louise, Nouveau-Brunswick, Canada
Distribution: Mandrake 10.1 Official
Posts: 34

Rep: Reputation: 15
How to install a driver for my printer?


Hi
Mandriva LE 2005 don't have the driver for my printer but I have find one in the Samsung site. How do you install a driver?
Thank you for reading me
 
Old 08-26-2005, 02:39 AM   #2
routers
Member
 
Registered: Aug 2005
Location: Malaysia - KULMY / CNXTH
Distribution: Slackware, Fedora, FreeBSD, Sun O/S 5.10, CentOS
Posts: 771
Blog Entries: 6

Rep: Reputation: 75
common: unpack the driver and inside sure got one file "README" read it
 
Old 08-26-2005, 04:14 AM   #3
linmix
Senior Member
 
Registered: Jun 2004
Location: Spain
Distribution: FC5
Posts: 1,993
Blog Entries: 1

Rep: Reputation: 46
What format is the driver in? (.bin .rpm .src ...)
 
Old 08-26-2005, 04:17 AM   #4
Lucas10
Member
 
Registered: Jun 2005
Location: Sainte-Louise, Nouveau-Brunswick, Canada
Distribution: Mandrake 10.1 Official
Posts: 34

Original Poster
Rep: Reputation: 15
I have read the readme file...

Requirements :
- GTK+ 1.2 libraries ; these usually come with the GNOME desktop environment,
but if your distribution didn't install those by default, you will need to
install them before you can use the graphical tools from this package.
- A working Ghostscript installation
- CUPS 1.1.x is the preferred printing system for this package, but the
Linux Package will accommodate any other printing system based on LPD.
CUPS 1.1.14 packages are provided as a convenience with this program, and can
be installed or upgraded from the installer. However, users of Debian and
Slackware distributions should make sure they have an active printing system
(such as LPD) before proceeding with the installation.

I have read the installation file and try to install the driver but it fail. You will see in the Requirements on top something I don't understand.

Unable to find file 'ppd/fr'
/usr/local/linuxprinter/tmp_script_zp19Kd: line 11: /etc/rc.d/init.d/cups: No such file or directory
Could not determine an installed printing system!Keeping existing configurationfile.
FATAL: Could not configure the printing system backend!
Warning: LPP_Init() failed! Waiting 2 seconds...
FATAL: Could not configure the printing system backend!
Warning: LPP_Init() failed! Waiting 2 seconds...
FATAL: Could not configure the printing system backend!
Warning: LPP_Init() failed! Waiting 2 seconds...
FATAL: Could not configure the printing system backend!

When I have try to install I have the feedback below.
thank you reading me
 
Old 08-26-2005, 04:45 PM   #5
linmix
Senior Member
 
Registered: Jun 2004
Location: Spain
Distribution: FC5
Posts: 1,993
Blog Entries: 1

Rep: Reputation: 46
Have you been able to establish you have all the dependencies installed? (try '# rpm -q gtk' and '# rpm -q cups' to check they are installed.

Actually, reading your message again. it looks like you either don't have cups installed or have never used it so it didn't make the file the installation is looking for. If cups is not installed ... I don't use mandrake but there must be an entry in your menu somewhere for installing packages. Install 'printer support' or 'cups' and try again.
 
Old 08-27-2005, 03:08 PM   #6
Lucas10
Member
 
Registered: Jun 2005
Location: Sainte-Louise, Nouveau-Brunswick, Canada
Distribution: Mandrake 10.1 Official
Posts: 34

Original Poster
Rep: Reputation: 15
GTK+

I have read all the file name INSTALL and I thing I have all the dependencies install. The last dependencie was MAKE 3.8.0. Now I can use the command ./configure for GTK+ but not the command MAKE . I'm mixe up.
 
Old 08-27-2005, 03:29 PM   #7
linmix
Senior Member
 
Registered: Jun 2004
Location: Spain
Distribution: FC5
Posts: 1,993
Blog Entries: 1

Rep: Reputation: 46
try small letters: "make"
 
Old 08-28-2005, 05:11 AM   #8
Lucas10
Member
 
Registered: Jun 2005
Location: Sainte-Louise, Nouveau-Brunswick, Canada
Distribution: Mandrake 10.1 Official
Posts: 34

Original Poster
Rep: Reputation: 15
I'm using small letter for make.
I thing I have install all the dependencies for gtk+-2.8.1 but I receive this message when I ./configure gtk...

Requested 'glib-2.0 >= 2.7.1' but version of GLib is 2.6.3
configure: error: Package requirements (glib-2.0 >= 2.7.1 atk >= 1.0.1 pango >= 1.9.0 cairo >= 0.9.2) were not met.
Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively you may set the BASE_DEPENDENCIES_CFLAGS and BASE_DEPENDENCIES_LIBS environment variables
to avoid the need to call pkg-config. See the pkg-config man page for
more details.

Thank you helping me
 
Old 08-30-2005, 04:19 PM   #9
linmix
Senior Member
 
Registered: Jun 2004
Location: Spain
Distribution: FC5
Posts: 1,993
Blog Entries: 1

Rep: Reputation: 46
you need a newer version of glib. Yours is 2.6.3 but you need 2.7.1 or above. Also make sure the vesrions for 'atk' 'pango' and 'cairo' are according to the specifications in the error message.
Use

# rpm -q atk (or any other app you need to check)

to check version number
 
Old 08-30-2005, 04:31 PM   #10
Komakino
Senior Member
 
Registered: Feb 2004
Location: Somerset, England
Distribution: Slackware 10.2, Slackware 10.0, Ubuntu 9.10
Posts: 1,938

Rep: Reputation: 53
You're all leading this poor guy on a wild goose chase! He doesn't need to upgrade GTK2 to 2.7, the system requirements specify GTk 1.2 which is an ENTIRELY different library to GTK 2.x. He certainly does not want to be installing atk, pango and cairo. I would agree with whoever said that he doesn't seem to have CUPS installed, as that looks to be the cause to me too.
 
Old 08-30-2005, 04:42 PM   #11
linmix
Senior Member
 
Registered: Jun 2004
Location: Spain
Distribution: FC5
Posts: 1,993
Blog Entries: 1

Rep: Reputation: 46
So why the error message??
 
Old 08-30-2005, 05:15 PM   #12
Komakino
Senior Member
 
Registered: Feb 2004
Location: Somerset, England
Distribution: Slackware 10.2, Slackware 10.0, Ubuntu 9.10
Posts: 1,938

Rep: Reputation: 53
Quote:
Originally posted by linmix
So why the error message??
The only error message he has is from (probably) CUPS. The only other error message is from the unnecessary step of trying to install GTK-2.0 when the application clearly states it wants GTK-1.2, which I repeat are completely different libraries and not just different versions of the same library/
 
Old 08-30-2005, 05:21 PM   #13
linmix
Senior Member
 
Registered: Jun 2004
Location: Spain
Distribution: FC5
Posts: 1,993
Blog Entries: 1

Rep: Reputation: 46
so where does this:

Requested 'glib-2.0 >= 2.7.1' but version of GLib is 2.6.3
configure: error: Package requirements (glib-2.0 >= 2.7.1 atk >= 1.0.1 pango >= 1.9.0 cairo >= 0.9.2) were not met.

fit in. It's not about gtk, but about glib (not trying to be aggressive, just trying to learn something and hoping to get some good reasons)
 
Old 08-30-2005, 05:29 PM   #14
Komakino
Senior Member
 
Registered: Feb 2004
Location: Somerset, England
Distribution: Slackware 10.2, Slackware 10.0, Ubuntu 9.10
Posts: 1,938

Rep: Reputation: 53
Quote:
Originally posted by linmix
so where does this:

Requested 'glib-2.0 >= 2.7.1' but version of GLib is 2.6.3
configure: error: Package requirements (glib-2.0 >= 2.7.1 atk >= 1.0.1 pango >= 1.9.0 cairo >= 0.9.2) were not met.

fit in. It's not about gtk, but about glib (not trying to be aggressive, just trying to learn something and hoping to get some good reasons)
Ahhh, now I see why you're questioning me!

Right, well glib is part of gtk. To build gtk-2.0 you need glib-2.0, atk and pango installed beforehand (they all make up gtk-2.0 really). BUT he doesn't need to be upgrading his version of gtk-2.0 because the printer driver doesn't even use it (I'm not sure why he's gotten on to trying to upgrade it because it really isn't necessary and isn't going to make the slightest difference even if he does succeed). The driver specifies it needs CUPS (the Common Unix Printing System) and GTK-1.2. That last bit is important: GTK-1.2 is a different library to GTK-2.0, not just a different version but a completely different library - the two can happily co-exist on the same system. Gnome 1.2 used GTK-1.2, Gnome 2.x uses GTK-2.0. What I think (and what another guy thinks above) is that he needs to install CUPS as that's what his error message is actually about. There is also the possibility that he doesn't have GTK-1.2 on his system as most modern apps with the exception of xmms don't use it. But even so, installing GTK+ 2.7 (or whatever) isn't going to solve that problem in the slightest.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
install printer driver comprookie2000 Red Hat 3 02-22-2004 12:27 PM
Cannot install Lexmark printer driver jayelitumbiolo Linux - Newbie 2 10-28-2003 12:26 PM
cannot install printer driver snatale1 Linux - Software 0 08-21-2003 01:04 PM
install the driver of my printer jeanrev Linux - Hardware 1 08-13-2003 03:30 PM
Install driver for printer futurist Linux - General 1 03-17-2003 01:24 AM


All times are GMT -5. The time now is 04:46 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration