LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 01-30-2006, 11:15 PM   #1
Crotalid
LQ Newbie
 
Registered: Jan 2006
Location: Northern California
Distribution: Kubuntu 8.04.2 64-bit with KDE 3.5.9
Posts: 23

Rep: Reputation: 15
How to get Wine working properly?


My install of Wine apparently worked, on my AMD64 system. After solving the
problem where Wine couldn't find the libwine.so.1 and libwine_unicode.so1,
I still can't get Wine to load a program, because it won't open a window.
In this case, I am trying to run Ultra Fractal under it.

This is the error I get :
Code:
[root@netblock-XX-XXX-XXX-XXX sbin]# wine /usr/local/UltraFractal3/uf3.exe
err:imagelist:ImageList_ReplaceIcon no color!
err:imagelist:ImageList_ReplaceIcon no color!
err:imagelist:ImageList_ReplaceIcon no color!
err:imagelist:ImageList_ReplaceIcon no color!
Application tries to create a window, but no driver could be loaded.
Make sure that your X server is running and that $DISPLAY is set correctly.
[root@netblock-XX-XXX-XXX-XXX sbin]

I have also read, while trying to find a solution, that Wine under AMD64 works best under a chroot, but I still don't know quite how to set that up.

Do I need to set up a chroot, or can I fix this problem some other way?

-- Crotalid
 
Old 01-31-2006, 04:07 AM   #2
cs-cam
Senior Member
 
Registered: May 2004
Location: Australia
Distribution: Gentoo
Posts: 3,544
Blog Entries: 4

Rep: Reputation: 56
Obvious question out of the way first, are you running a X server?
 
Old 01-31-2006, 04:11 AM   #3
Crotalid
LQ Newbie
 
Registered: Jan 2006
Location: Northern California
Distribution: Kubuntu 8.04.2 64-bit with KDE 3.5.9
Posts: 23

Original Poster
Rep: Reputation: 15
Quote:
Obvious question out of the way first, are you running a X server?
Yes, I was. I cut-and-pasted those lines directly from Konsole.

-- Crotalid
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wine install but not working properly xIEatxChildrenx Linux - Software 4 12-29-2004 08:42 PM
Arview 3.2 works with wine, but window doesn't maximize or restore properly. pepeq Linux - Software 0 11-12-2004 09:56 AM
Text in Wine not displaying properly. Pi Man Linux - Software 3 09-17-2004 11:02 PM
X not working properly. MylesCLin Linux - Software 1 09-15-2004 10:46 AM
Wine: Red Alert: screen resolution not changed properly drowstar Linux - Games 2 05-21-2004 08:02 AM


All times are GMT -5. The time now is 06:45 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration