LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 09-08-2004, 02:47 PM   #1
SciYro
Senior Member
 
Registered: Oct 2003
Location: hopefully not here
Distribution: Gentoo
Posts: 2,038

Rep: Reputation: 51
how to get exim to send email?


I'm currently using thrunderbird to try and send email to my online email address (just for no reason, i got bored today)

anyways, I'm using exim as the MTA, and qpopper as the pop3 server (i think it should work right?)

anyways, i installed them, but right now I'm stuck with exim not sending my email

i have thunderbird configured to use the loopback device as the server, and it works fine, but exim keeps returning (at least acording to thurnderbird)

"
Varification failed for
<username@127.0.0.1>

Unrouteable address

sender verify failed" ... then it asks me to check preferences (the username is my username, and the address i used was both 127.0.0.1 and my ip address according to ifconfig

anyways, i tried going thru the manuals and docs, and even the default config file (tried removing the ACL's but that just led to it saying there was a internal error

anyone know how to get this thing to send email?
 
Old 09-08-2004, 03:59 PM   #2
bulliver
Senior Member
 
Registered: Nov 2002
Location: Edmonton AB, Canada
Distribution: Gentoo x86_64; Gentoo PPC; FreeBSD; OS X 10.9.4
Posts: 3,760
Blog Entries: 4

Rep: Reputation: 77
Make sure you have these in your exim.conf:
Code:
hostlist   relay_from_hosts = 127.0.0.1
# allows mail from localhost to be relayed to an external server
allow_domain_literals
# allow "user@127.0.0.1" addresses.
Note that "allow_domain_literals" is NOT a recommended setting, especially on a production machine. If I understand, you are just fooling around with this, but ip addresses can easily be spoofed, turning your box into an open relay for spammers.

A better idea is to create a hostname for your box (if you haven't already) then edit/add these lines in exim.conf:
Code:
primary_hostname = your_hostname
domainlist local_domains = your_hostname
If this still doesn't work for you, you can test if the problem is with exim or not by telneting to port 25 and sending mail manually:
Code:
[me@mine]$ telnet localhost 25
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
220 nina.badcomputer ESMTP Exim 4.41 Wed, 08 Sep 2004 12:51:57 -0700
helo localhost
250 nina.badcomputer Hello localhost [127.0.0.1]
mail from:user@address.com
250 OK
rcpt to:another_user@another_address.com
250 OK
data
354 Enter message, ending with "." on a line by itself
This is a test email
.
250 OK id=1C58a9-00043g-M6
quit
221 nina.badcomputer closing connection
Connection closed by foreign host.
 
Old 09-08-2004, 06:56 PM   #3
SciYro
Senior Member
 
Registered: Oct 2003
Location: hopefully not here
Distribution: Gentoo
Posts: 2,038

Original Poster
Rep: Reputation: 51
ah thanks,..

ok, the problem is diffidently not exim, well. at least i can telnet into it and send a simple message just fine, (curiously tho, there was no address on the message when it arived at my yahoo inbox )

anyways, thunderbird is still not getting along with exim , any ideas? (i tried both of those options and thunderbird is still not playing)

also i have one more question, is there some special setting needed for qpopper ? when i try to get my mail (well,... not like i have any, just checking is i can) it keeps coming back saying something like "pam :unknown module (28) " ... any ideas on that either?
 
Old 09-08-2004, 07:29 PM   #4
foo_bar_foo
Senior Member
 
Registered: Jun 2004
Posts: 2,553

Rep: Reputation: 51
qpopper distributes a very good manual called GUIDE.pdf
if it's not in your docs you can get it from the website and it's in the source tarball as well
 
Old 09-08-2004, 08:26 PM   #5
SciYro
Senior Member
 
Registered: Oct 2003
Location: hopefully not here
Distribution: Gentoo
Posts: 2,038

Original Poster
Rep: Reputation: 51
thanks ... looks like i can look forward to reading manules in the next few days

shame thres no program that can whip misfit programs into shape ./...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot send mail due to exim log file permission zahoo Linux - General 3 11-03-2005 12:42 PM
email/Exim Problems bassfreq Debian 1 04-02-2005 03:49 PM
[EXIM] I can send mail without giving a password? Akropolis Linux - Networking 0 06-09-2004 02:21 PM
exim, email, and dns edfinegan Linux - Software 0 10-05-2003 08:58 PM
exim/mutt - local user can't send mail to isp lea Linux - Software 1 12-12-2002 08:31 AM


All times are GMT -5. The time now is 02:22 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration