LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 03-19-2010, 10:36 PM   #1
amritpalpathak
Member
 
Registered: Feb 2010
Posts: 116

Rep: Reputation: 15
Question HOW TO FIX ""The requested URL /phpMyAdmin was not found on this server.""


i have install apache,php,mysql and then I have installed the phpmyadmin by issueing the command in terminal
sudo apt-get install phpmyadmin
after this ,in my web brower i type... localhost/phpmyadmin ,it give the error message

"Not Found

The requested URL /phpMyAdmin was not found on this server.
Apache/2.2.12 (Ubuntu) Server at localhost Port 80"


Please help me to solve it
 
Click here to see the post LQ members have rated as the most helpful post in this thread.
Old 03-20-2010, 12:02 AM   #2
smoker
Senior Member
 
Registered: Oct 2004
Distribution: Fedora Core 4, 12, 13, 14, 15, 17
Posts: 2,279

Rep: Reputation: 248Reputation: 248Reputation: 248
Quote:
Should you get a 404 "Not Found" error when you point your browser to the location of phpMyAdmin (such as: http://localhost/phpmyadmin) this is likely caused by not checking the 'Apache 2' selection during installation. To redo the installation run the following:

Code:
 sudo dpkg-reconfigure -plow phpmyadmin
Then select Apache 2 for the webserver you wish to configure.

If this does not work, then you can do the following to include the phpMyadmin-shipped Apache configuration into Apache:

Code:
sudo ln -s /etc/phpmyadmin/apache.conf /etc/apache2/conf.d/phpmyadmin.conf
sudo /etc/init.d/apache2 reload
https://help.ubuntu.com/community/phpMyAdmin
 
2 members found this post helpful.
Old 11-27-2010, 09:08 PM   #3
james_noob
LQ Newbie
 
Registered: Nov 2010
Location: Welling, Kent, UK
Distribution: Ubuntu 10.04 LTS
Posts: 1

Rep: Reputation: 0
phpmyadmin not found - resolved

Smoker,

thanks you so much for your detailed (and working!) explanation.

Regards,

James
 
Old 03-29-2011, 12:08 AM   #4
twhd
LQ Newbie
 
Registered: Mar 2011
Posts: 1

Rep: Reputation: 0
am still getting the error ,not sure what to do now am new to all this, any help would be good thanks

Last edited by twhd; 03-29-2011 at 12:10 AM. Reason: added txt
 
Old 06-08-2011, 08:19 AM   #5
shorebizgal
LQ Newbie
 
Registered: Jun 2011
Posts: 1

Rep: Reputation: Disabled
Just wanted to thank you for the help. After numerous purges and reinstalls with the same results your fix worked. The first code gave no change, but the second code gave me the results I needed. Again, Thanks to Smoker for the help.
 
Old 07-11-2011, 05:06 PM   #6
donadoni
LQ Newbie
 
Registered: Feb 2009
Posts: 3

Rep: Reputation: 0
Thank you very much worked 1st time.
 
Old 07-21-2011, 11:45 AM   #7
lixzzy
LQ Newbie
 
Registered: Jul 2011
Posts: 1

Rep: Reputation: Disabled
Thread: HOW TO FIX ""The requested URL /phpMyAdmin was not found on this server.

thanks for the help. worked great.

I have to say that what I have to do first was to edit the file /etc/phpmyadmin/apache.config

in the bottom part of the doc there is this:

# Authorize for setup
<Directory /usr/share/phpmyadmin/setup>
<IfModule mod_authn_file.c>
AuthType Basic
AuthName "phpMyAdmin Setup"
AuthUserFile /etc/phpmyadmin/htpasswd.setup
</IfModule>
Require valid-user
</Directory>

# Disallow web access to directories that don't need it
<Directory /usr/share/phpmyadmin/libraries>
Order Deny,Allow
Require valid-user--------------------here there was as Deny from All---------------
</Directory>
<Directory /usr/share/phpmyadmin/setup/lib>
Order Deny,Allow
Require valid-user--------------------same as above--------------------------------
</Directory>


with this change when I access the localhost/phpmyadmin it prompts a username password field that was setup at the phpadmin install process.

thanks again!!!
 
Old 07-26-2011, 12:46 AM   #8
enrishi
LQ Newbie
 
Registered: Jul 2011
Posts: 1

Rep: Reputation: Disabled
My thanks also go to smoker.

I had the same problem and while the first suggestion didn't work, the second suggestion worked immediately. Voila!
 
Old 08-02-2011, 09:53 AM   #9
mselema
LQ Newbie
 
Registered: May 2010
Posts: 3

Rep: Reputation: 0
thanks to @smoker it worked to me as well !!! now enjoyin lamp!
 
Old 12-01-2011, 01:17 PM   #10
agriz
Member
 
Registered: Nov 2011
Posts: 174

Rep: Reputation: Disabled
I am getting the same error. But I am using CentOS

I installed with yum command.
yum install phpmyadmin

The above solutions are not working for me
 
Old 12-01-2011, 03:14 PM   #11
lithos
Senior Member
 
Registered: Jan 2010
Location: SI : 45.9531, 15.4894
Distribution: CentOS, OpenNA/Trustix, testing desktop openSuse 12.1 /Cinnamon/KDE4.8
Posts: 1,144

Rep: Reputation: 217Reputation: 217Reputation: 217
Quote:
Originally Posted by agriz View Post
I am getting the same error. But I am using CentOS

I installed with yum command.
yum install phpmyadmin

The above solutions are not working for me
Because you don't need to install it with yum.

Create a directory on your server, like /var/www/html/phpmyadmin
and download and unpack phpMyAdmin, let's say v2.11.11.3 (d/l with wget ....)

then all you need to do is create an alias in Apache /etc/httpd/conf/httpd.conf
for phpmyadmin under some virtual host or other nameserver directive:
Code:
Alias /phpmyadmin "/var/www/html/phpmyadmin/"

<Directory /var/www/html/phpmyadmin>
Options FollowSymLinks
DirectoryIndex index.php

<IfModule mod_php5.c>
AddType application/x-httpd-php .php

php_flag magic_quotes_gpc Off
php_flag track_vars On
php_flag register_globals Off
php_value include_path .
</IfModule>

</Directory>
then restart apache/httpd and try :
Code:
http://www.yourdomain.net/phpmyadmin
you should see something.
 
Old 12-01-2011, 03:16 PM   #12
agriz
Member
 
Registered: Nov 2011
Posts: 174

Rep: Reputation: Disabled
I am using suphp.

Quote:
<IfModule mod_php5.c>
Should i make any changes on this ?
 
Old 12-02-2011, 11:09 AM   #13
lithos
Senior Member
 
Registered: Jan 2010
Location: SI : 45.9531, 15.4894
Distribution: CentOS, OpenNA/Trustix, testing desktop openSuse 12.1 /Cinnamon/KDE4.8
Posts: 1,144

Rep: Reputation: 217Reputation: 217Reputation: 217
Quote:
Originally Posted by agriz View Post
I am using suphp.

Should i make any changes on this ?
I don't know what changes would be needed,
but here it states that
Quote:
suPHP does not support the php_value/php_admin_value directive known by mod_php to parse configuration options
Try it, you can't lose anything.
 
Old 12-02-2011, 01:35 PM   #14
agriz
Member
 
Registered: Nov 2011
Posts: 174

Rep: Reputation: Disabled
Quote:
Cannot start session without errors, please check errors given in your PHP and/or webserver log file and configure your PHP installation properly.
I can see this error.
It seems SELinux is doing something. Not sure.

Quote:
SELinux policy enabled; httpd running as context unconfined_u:system_r:httpd_t:s0
 
Old 12-03-2011, 02:54 AM   #15
agriz
Member
 
Registered: Nov 2011
Posts: 174

Rep: Reputation: Disabled
Quote:
Alias /phpmyadmin "/var/www/html/phpmyadmin/"

<Directory "/var/www/html/phpmyadmin">
Options FollowSymLinks
DirectoryIndex index.php
Order allow,deny
Allow from all
<IfModule mod_php5.c>
AddType application/x-httpd-php .php

php_flag magic_quotes_gpc Off
php_flag track_vars On
php_flag register_globals Off
php_value include_path .
</IfModule>

</Directory>
Quote:
Forbidden
You don't have permission to access /phpmyadmin/index.php on this server.
In error log, I found this.
I tried to disable comment <IfModule mod_php5.c>, But still same error.
SuPHP is configured.

I gave chown to the suphp user and group
I changed the files to 644 and folder to 755

ERROR LOG

Quote:
[Sat Dec 03 14:20:57 2011] [notice] SELinux policy enabled; httpd running as context unconfined_u:system_r:httpd_t:s0
[Sat Dec 03 14:20:57 2011] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Sat Dec 03 14:20:57 2011] [notice] Digest: generating secret for digest authentication ...
[Sat Dec 03 14:20:57 2011] [notice] Digest: done
[Sat Dec 03 14:20:57 2011] [notice] Apache/2.2.15 (Unix) DAV/2 PHP/5.3.2 mod_ssl/2.2.15 OpenSSL/1.0.0-fips configured -- resuming normal operations
[Sat Dec 03 14:21:00 2011] [error] [client 117.193.66.141] (13)Permission denied: access to /phpmyadmin/index.php denied
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
automount 5.0.3 with auto.smb script yields "key "<name>" not found in map" rbergen Linux - Software 0 01-01-2010 12:27 PM
on url "http://localhost/" error ""The requested URL could not be retrieved " renuaseri Linux - Newbie 1 04-07-2009 12:23 AM
LFS6.3 - Ch5.4.1 "/bin/sh sort not found" error at "make bootstrap" ubyt3m3 Linux From Scratch 2 06-23-2008 12:09 AM
Standard commands give "-bash: open: command not found" even in "su -" and "su root" mibo12 Linux - General 4 11-11-2007 10:18 PM
difference between "Web server local URL" and "IPv4 address"? kpachopoulos Linux - General 2 09-17-2004 01:30 PM


All times are GMT -5. The time now is 01:07 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration