LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-15-2003, 07:07 AM   #1
vous
Member
 
Registered: Mar 2003
Location: Macondo
Distribution: Mandrake 9.1, 10.1, SuSE 8.1 pro, 10.1, Red Hat 8.0/9.0
Posts: 380

Rep: Reputation: 30
How to enable SuSE to be shut down by a user?


Hello all,

I am trying to enable my local users to shutdown a SuSE Box....

I went to the SuSE YaST2 Control Center--> Security And Users --> Security Settings--> Custom Settings --> Boot Settings --> Shutdown Behavior of KDM = "All Users"

The users have tried it but you still have to type in the root password to shut it down....!!!

What am I doing wrong here?
 
Old 09-15-2003, 07:08 AM   #2
Caeda
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Suse 6.0+, Mandrake 5.0-10.0, Redhat 6.0-9.0, Gentoo 1.2+, Gnoppix, Knoppix, Sabayon, Ubuntu 5.04+
Posts: 1,811

Rep: Reputation: 45
I believe the prompt says "Password" not root password? As mine asks for a password too, but it only needs a user's password to work.
 
Old 09-15-2003, 07:20 AM   #3
vous
Member
 
Registered: Mar 2003
Location: Macondo
Distribution: Mandrake 9.1, 10.1, SuSE 8.1 pro, 10.1, Red Hat 8.0/9.0
Posts: 380

Original Poster
Rep: Reputation: 30
It actually asks explicitly for the root password...

Any other thoughts? Is there another setting that I could be missing?
 
Old 09-15-2003, 07:46 AM   #4
vous
Member
 
Registered: Mar 2003
Location: Macondo
Distribution: Mandrake 9.1, 10.1, SuSE 8.1 pro, 10.1, Red Hat 8.0/9.0
Posts: 380

Original Poster
Rep: Reputation: 30
In the meantime I have also tried...rebooting the server to see if it had anything to do with some config file that probably wasn't read, but still no luck.

I also tried setting the behavior of the Ctrl-Alt_Delete to: HALT "All Users" , but the users still can't shutdown!!!

Any other thoughts?
 
Old 09-16-2003, 12:11 PM   #5
vous
Member
 
Registered: Mar 2003
Location: Macondo
Distribution: Mandrake 9.1, 10.1, SuSE 8.1 pro, 10.1, Red Hat 8.0/9.0
Posts: 380

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by Caeda
I believe the prompt says "Password" not root password? As mine asks for a password too, but it only needs a user's password to work.

So, what settings do you have in order to get prompted for just the user password and not the root password?
 
Old 09-16-2003, 10:47 PM   #6
Caeda
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Suse 6.0+, Mandrake 5.0-10.0, Redhat 6.0-9.0, Gentoo 1.2+, Gnoppix, Knoppix, Sabayon, Ubuntu 5.04+
Posts: 1,811

Rep: Reputation: 45
I dont know. I have mine set to, "Shutdown Behavior" All users, so, it works on mine. ... It should be working on yours too.
 
Old 09-17-2003, 09:21 AM   #7
davholla
Member
 
Registered: Jun 2003
Location: London
Distribution: Linux Mint 13 Maya
Posts: 711

Rep: Reputation: 32
I just go to the Suse icon and I can shut it down without being root.
 
Old 09-18-2003, 09:15 PM   #8
Caeda
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Suse 6.0+, Mandrake 5.0-10.0, Redhat 6.0-9.0, Gentoo 1.2+, Gnoppix, Knoppix, Sabayon, Ubuntu 5.04+
Posts: 1,811

Rep: Reputation: 45
Good for you davholla. Now read the rest of the posts and notice that there is a bug in Suse linux which takes away this ability.
 
Old 09-19-2003, 04:30 AM   #9
davholla
Member
 
Registered: Jun 2003
Location: London
Distribution: Linux Mint 13 Maya
Posts: 711

Rep: Reputation: 32
Quote:
Originally posted by Caeda
Good for you davholla. Now read the rest of the posts and notice that there is a bug in Suse linux which takes away this ability.
Do not be patronisiing I did read the other posts.
However what I was saying that on my machine which has Suse 8.2 does not have this bug, so I was surpised that others do have it. The only thing that I have changed is that my machine is set up to boot in X server automatically.


The only problem I have is that my machine does not turn the power off but to come out of linux no password is required.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Enable User account nitro Linux - Newbie 6 12-01-2005 07:00 PM
How to Enable User or Add New User omeryasin Linux - Software 3 10-29-2005 06:16 AM
xfce will not shut down for user walterbyrd Linux - Software 5 07-11-2005 02:40 PM
allow user to shut down? GetMooked *BSD 3 05-15-2005 07:41 PM
With Suse 9.0 my PC doesn't shut down. kpachopoulos Linux - Newbie 2 02-05-2004 08:45 PM


All times are GMT -5. The time now is 11:00 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration