LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   How to Downgrade to a Working Version of AVIDemux? (http://www.linuxquestions.org/questions/linux-software-2/how-to-downgrade-to-a-working-version-of-avidemux-4175440017/)

thund3rstruck 12-04-2012 12:48 PM

How to Downgrade to a Working Version of AVIDemux?
 
Well, avidemux-2.6.0-1.fc17.x86_64 is hopelessly broken. I have installed V2.6.0.1 on both Windows and Linux and the timeline crashes at some point while editing videos.

I downgraded the windows version to V2.5.6 and that one works perfectly. Now I'm trying to downgrade the Fedora version and I can't figure it out. I downloaded the source code but the README file is empty and cmake generates 5 pages of errors.

I then tried to use yum downgrade:

Code:

yum downgrade avidemux avidemux-libs avidemux-qt avidemux-gui --skip-broken

# Which produces this hideous output:
# Error: Package: avidemux-help-2.6.0-1.fc17.noarch (@rpmfusion-free-updates)
#          Requires: avidemux-gui = 2.6.0-1.fc17
#          Removing: avidemux-qt-2.6.0-1.fc17.x86_64 (@rpmfusion-free-updates)
#              avidemux-gui = 2.6.0-1.fc17
#          Downgraded By: avidemux-qt-2.5.6-8.fc17.x86_64 (rpmfusion-free)
#              avidemux-gui = 2.5.6-8.fc17
#          Available: avidemux-gtk-2.5.6-8.fc17.x86_64 (rpmfusion-free)
#              avidemux-gui = 2.5.6-8.fc17.1
#          Available: avidemux-gtk-2.6.0-1.fc17.x86_64 (rpmfusion-free-updates)
#              avidemux-gui = 2.6.0-1.fc17.1
# You could try using --skip-broken to work around the problem
# ** Found 3 pre-existing rpmdb problem(s), 'yum check' output follows:
# netbeans-apisupport-6.9-5.fc16.noarch has missing requires of netbeans-platform12 >=  ('0', '6.9', None)
# netbeans-ide-6.9-5.fc16.noarch has missing requires of netbeans-platform12 >= ('0', '6.9', None)
# netbeans-java-6.9-5.fc16.noarch has missing requires of netbeans-platform12 >= ('0', '6.9', None)

Not sure what to do now....How do I downgrade to a working earlier version of avidemux?

ArfaSmif 12-04-2012 05:08 PM

Have you tried to uninstall avidemux first and then reinstall the old version from rpms?

thund3rstruck 12-04-2012 05:44 PM

Quote:

Originally Posted by ArfaSmif (Post 4842791)
Have you tried to uninstall avidemux first and then reinstall the old version from rpms?

I haven't because of all the dependencies. Is there no way to tell yum to install the previous version (and dependencies)?

ArfaSmif 12-05-2012 02:26 AM

Quote:

Originally Posted by thund3rstruck (Post 4842811)
I haven't because of all the dependencies. Is there no way to tell yum to install the previous version (and dependencies)?

If you type in :-

yum erase avidemux

that should take care of all of the dependencies for you.

Then I would download the rpm of the version of avidemux you want from one of the mirrors, and then do a :-

yum localinstall avidemux-downloaded.rpm (where the avidemux-downloaded.rpm is the one you downloaded :-) )

which should pull in all the correct dependencies for you.

thund3rstruck 12-05-2012 09:02 AM

Quote:

Originally Posted by ArfaSmif (Post 4843005)
If you type in :-

yum erase avidemux

that should take care of all of the dependencies for you.

Then I would download the rpm of the version of avidemux you want from one of the mirrors, and then do a :-

yum localinstall avidemux-downloaded.rpm (where the avidemux-downloaded.rpm is the one you downloaded :-) )

which should pull in all the correct dependencies for you.

Awesome, I'll give that a try after work tonight!

Thank You!

thund3rstruck 03-05-2013 09:57 AM

Quote:

Originally Posted by thund3rstruck (Post 4843211)
Awesome, I'll give that a try after work tonight!

Thank You!

Luckily, avidemux was updated in the repositories before I had a chance to dig into this problem. The new one works!

ArfaSmif 03-06-2013 12:10 AM

Which avidemux are you running? I've got avidemux3_qt4.


All times are GMT -5. The time now is 04:30 AM.