LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   How to disable java (not javascript) with Firefox 11.0 (http://www.linuxquestions.org/questions/linux-software-2/how-to-disable-java-not-javascript-with-firefox-11-0-a-4175425289/)

SharpyWarpy 09-02-2012 03:27 PM

How to disable java (not javascript) with Firefox 11.0
 
How can I disable java with Firefox 11.0? I'm using Fedora 16 64 bit. I can't access that option in preferences. The option to disable javascript is there but not java. Thanks in advance.

craigevil 09-02-2012 05:18 PM

Add-ons>Plugins

Or install and use the QuickJava extension

John VV 09-02-2012 05:43 PM

in the VERY old ( by FF standards ) Firefox 11 ???
as above BUT install the current Firefox 15 first

however most distros are using the "icetea" openJDK and are NOT using the Oracle java 7 and the BROKEN update Oracle update released late Thursday that ALSO has a security hole in it

and fedora is 100% using openjdk and is NOT using Oracle java 7
http://icedtea.classpath.org/wiki/IcedTea-Web

SharpyWarpy 09-02-2012 08:52 PM

Quote:

Originally Posted by John VV (Post 4770886)
in the VERY old ( by FF standards ) Firefox 11 ???
as above BUT install the current Firefox 15 first

I use 64 bit Fedora 16 and updated Firefox from an update repo and it installed Firefox 11. Firefox 15 is available only for 32 bit Fedora 16.

Quote:

however most distros are using the "icetea" openJDK and are NOT using the Oracle java 7 and the BROKEN update Oracle update released late Thursday that ALSO has a security hole in it and fedora is 100% using openjdk and is NOT using Oracle java 7
http://icedtea.classpath.org/wiki/IcedTea-Web
I just want to disable java. Thanks :)

SharpyWarpy 09-02-2012 08:54 PM

Quote:

Originally Posted by craigevil (Post 4770871)
Add-ons>Plugins

Or install and use the QuickJava extension

I'll look into those. I wonder why the option to disable java is gone? Oh well, I'll let that go. Thanks, craigevil.

SharpyWarpy 09-02-2012 08:57 PM

I just opened "Tools > Plugins" and found "IcedTea-Web Plugin" and it says there it executes java applets. So I'll disable that and try it.

SharpyWarpy 09-02-2012 09:05 PM

Quote:

Originally Posted by SharpyWarpy (Post 4770994)
I just opened "Tools > Plugins" and found "IcedTea-Web Plugin" and it says there it executes java applets. So I'll disable that and try it.

That does the job. I'm marking this thread SOLVED. Thanks for your replies, gentlemen.

EDDY1 09-02-2012 11:39 PM

You can manually install FF. Just need to replace the /usr/bin/ff file


All times are GMT -5. The time now is 12:08 AM.