LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   How to disable gnome-keyring? (http://www.linuxquestions.org/questions/linux-software-2/how-to-disable-gnome-keyring-361545/)

fannymites 09-08-2005 06:08 PM

How to disable gnome-keyring?
 
After updating from ubuntu hoary to breezy, I was asked to select a password for the default keyring.
Not knowing what this was or what it did I just entered the root password and now whenever I run apps as root I get a dialogue box saying the default keyring is locked and to enter the password.
I now want to permenantly disable gnome keyring altogether as I don't have any use for it but I can't find a way.
I've also tried deleting the keyrings via gnome-keyring-manager but after a reboot I get asked again.

deepsix 09-08-2005 08:23 PM

:) well why dont you send me your keyring and ill have a look at it ........
j/k.....

kanem 09-09-2005 02:49 PM

I went to /home/me/.gnome2/keyrings/ and erased default.keyring in that folder, and that worked. No more prompt for the keyring password. I made a backup of it though somewhere else just in case it's actually needed.

nsfx 07-12-2006 03:39 PM

I know this is a pretty old post but I'm stuck with this same problem. I can't seem to disable gnome key ring and it's really annoying.

tyoungblood 08-25-2006 10:06 AM

I generated an rsa key a week or so ago thinking it would make things more convenient when I ssh to other machines. Man, was I wrong. Now I get asked for two passwords everytime (one for the local key and one for accessing the remote system) instead of just one as the keyring functionality in fc5 appears to ignore the 'save password on keyring' option.

What a PITA.

hydride 06-18-2008 01:19 PM

worked for me
 
solution 1:

from menu: System -> Preferences -> Sessions. Add new, with command "killall gnome-keyring-manager"

solution 2:
edit /etc/gconf/schemas/gnome-keyring.schemas as root, and search for "TRUE" in text, there should be one for ssh and one for pkcs, substitute "TRUE" with "FALSE" and ur done..

samrat563n 04-28-2009 03:45 AM

Hi hydride

tried both options but not working for me. I am using fedora 10.

Lee_Ball 04-28-2009 04:10 AM

I fixed this one time on my system:

http://www.leenukes.co.uk/?p=50

elbie 11-11-2009 11:17 AM

Quote:

Originally Posted by samrat563n (Post 3523237)
Hi hydride

tried both options but not working for me. I am using fedora 10.

In Fedora 11, you should be able to go to System->Preferences->Startup Applications, and uncheck "GNOME Keyring Daemon". I imagine it's similar for FC10.

You can then either log out and log back in, or just search for the gnome-keyring related processes owned by your userid and kill them.

tavvva 08-31-2010 07:20 AM

The gnome-keyring-daemon seems to be started by evolution each time I start evolution.
I workarounded the problem by renaming the /usr/bin/gnome-keyring-daemon to /usr/bin/gnome-keyring-daemon.bak

It doesn't bother me anymore :D

10110111 08-31-2010 07:35 AM

The solution for me was when i was asked for new keyring password, i just pressed enter with empty password.

tavvva 08-31-2010 07:52 AM

Empty password didn't work for me ... as well as the same password like the login password. It's a bug, because I was getting new keyring files in ~/.gnome2/keyrings each time I was asked to enter a password.

rikijpn 08-31-2010 08:00 AM

I'm so glad I wasn't the only one who got annoyed by this feature... especially when using ssh><. gnome is starting to get too "user-friendly" if you ask me, I didn't like having gnome-panel and the new gnome wouldn't allow me to just disable it, so I ended up switching to sawfish.
Anyway, the "easiest" way to disable anything gnome, is using the gconf-editor. In the terminal type gconf-editor. Search for keyring (or ssh, etc) then just unclick (set to false/null) all the values you don't need.

agivati 06-07-2011 08:32 AM

It's easy in Ubuntu 11.4
 
If you have Ubuntu 11.4 - this easy procedure worked for me:
1. Click on "Application" (in the application starter on the screen left side).
2. Type in the word "startup"
3. Select the "Startup Application" icon
4. In the "Additional Startup Programs" list, clear the check-box of all Keyring services. I have 3 of them:
- "Certificate and Keyring Storage"
- "Secret Storage Service"
- "SSH Key Agent"
5. Click "Close" button
6. Restart the machine
That's it...

Enjoy.

krustybaguette 01-12-2012 02:14 PM

Quote:

Originally Posted by hydride (Post 3188331)
solution 1:

from menu: System -> Preferences -> Sessions. Add new, with command "killall gnome-keyring-manager"

solution 2:
edit /etc/gconf/schemas/gnome-keyring.schemas as root, and search for "TRUE" in text, there should be one for ssh and one for pkcs, substitute "TRUE" with "FALSE" and ur done..

Under Linux Mint 9 isadora I had same problem and finding gnome-keyring.schemas was a bit of a problem but once there I found THREE "TRUE's" to swap to "FALSE". There's also a setting at Menu/Preferences/StartupApplications which has THREE keyring related items. I unchecked all three. (I'm guessing that it's just a GUI that would have accomplished the same thing as editing the file manually!) In any case, after a reboot I saw no need to login to a "default Keyring". I had to enter my password for my wireless router however, so it remains to be seen if I have disabled the auto login for my wireless network.

Wow. I rebooted and saved my Firefox tabs and they were still here when rebooting done. No need to login to router. Hooray


All times are GMT -5. The time now is 10:22 AM.