LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 04-10-2007, 02:26 PM   #1
etechnophile
LQ Newbie
 
Registered: Jun 2006
Location: India
Distribution: OpenSUSE 12.1
Posts: 29

Rep: Reputation: 15
Smile how to configure amarok for proxy


I'm using amaroK 1.3.8 (Using KDE 3.5.1 Level "a" OpenSUSE 10.1). I access internet through a squid proxy. While I can easily configure Firefox for accessing internet through a proxy, I can't find the similar option for amaroK. As a result, the lyrics-fetching feature isn't working. Whenever I click the lyrics tab in amaroK, I get a small message sliding up near the left bottom corner typically saying "Could not access http://lyrc.com.ar/en/tema1en.php?ar...ayingCurrently. Offline mode active."

I'd be grateful for any ideas about how to make amaroK work with a proxy.
 
Old 04-10-2007, 05:06 PM   #2
almatic
Member
 
Registered: Mar 2007
Distribution: Debian
Posts: 547

Rep: Reputation: 67
have you tried to globally set a proxy in the kde control center ?
 
Old 04-14-2007, 11:43 AM   #3
etechnophile
LQ Newbie
 
Registered: Jun 2006
Location: India
Distribution: OpenSUSE 12.1
Posts: 29

Original Poster
Rep: Reputation: 15
No, I'll try that and let you know. Thanks for helping me out.
 
Old 04-16-2007, 07:49 AM   #4
etechnophile
LQ Newbie
 
Registered: Jun 2006
Location: India
Distribution: OpenSUSE 12.1
Posts: 29

Original Poster
Rep: Reputation: 15
Question Doesn't work

I tried setting the proxy in KDE control centre, but I keep on getting the same error which says amaroK is in offline mode. I entered the same proxy I use for firefox. Tried it both with and without http:// in front of the IP address, but doesn't work either way.

Am I doing something wrong? I chose the option to specify the settings manually.
 
Old 04-16-2007, 08:36 AM   #5
almatic
Member
 
Registered: Mar 2007
Distribution: Debian
Posts: 547

Rep: Reputation: 67
does fetching covers from amazon work ? Try that, if it works, then your proxy is set up correctly. I'm absolutely sure that amarok fetches it's proxy info from the global kde settings, even if you'd use gnome.

However, lyrics are fetched via an external script (ruby, perl or whatever) which is launched by amarok and not necessarily use the kde default settings. Here's what you can try:

- check if there is a proxy-setting-option for the lyrics-script. (extras -> script manager)

- Set an environment variable:
export http_proxy=http://yourproxy.com:8080

- download a better lyrics script in the above mentioned script-manager
 
Old 04-18-2007, 09:12 AM   #6
etechnophile
LQ Newbie
 
Registered: Jun 2006
Location: India
Distribution: OpenSUSE 12.1
Posts: 29

Original Poster
Rep: Reputation: 15
Arrow

No, fetching covers from amazon does not work either. I get this error.

Could not access http://xml.amazon.com/onca/xml3?t=we...s&page=1&f=xml. Offline mode active.

And I use KDE, not Gnome; So I really don't know why amaroK isn't paying attention to the global proxy I've configured in KDE Control Centre. Is there any other application that doesn't have proxy settings of its own, but takes the settings from KDE Control Center? That way, I can test whether I've configured the proxy correctly there and stop blaming amaroK unnecessarily.

Thanks for the advice. I really appreciate it, since lyrics is the only part I miss in amaroK compared to Windows Media Player.
 
Old 04-18-2007, 11:26 AM   #7
almatic
Member
 
Registered: Mar 2007
Distribution: Debian
Posts: 547

Rep: Reputation: 67
Quote:
Originally Posted by etechnophile
Offline mode active.
Check in the konqueror settings in cache section if you have maybe set it to offline mode.
I don't know if I have translated that right, here is a screenshot of what I mean.

http://freenet-homepage.de/dateigarage/sc54.jpg
 
Old 04-19-2007, 12:36 PM   #8
etechnophile
LQ Newbie
 
Registered: Jun 2006
Location: India
Distribution: OpenSUSE 12.1
Posts: 29

Original Poster
Rep: Reputation: 15
Lightbulb That might be it!

Hey, I think that's it! I vaguely remember putting Konqueror in offline mode. Didn't realize at the time that this would affect KDE global settings. Unfortunately I don't have access to that particular machine right now, but I'll try this out tomorrow and keep you posted.

Oh, and extra thanks for posting that screen shot. It made things clear all right!
 
Old 04-25-2007, 12:47 PM   #9
etechnophile
LQ Newbie
 
Registered: Jun 2006
Location: India
Distribution: OpenSUSE 12.1
Posts: 29

Original Poster
Rep: Reputation: 15
Solved!

Yup, that worked! Thank you so much!
 
  


Reply

Tags
amarok, proxy


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
configure squid proxy with cc proxy as a parent proxy faisi Linux - Networking 1 08-10-2010 02:16 PM
configure squid proxy with microsoft proxy as a parent proxy nintykola Linux - Software 1 08-28-2007 02:38 AM
./configure finds this problem with Amarok Stevetgn Linux - Software 1 01-10-2005 03:38 PM
configure proxy anonazyet Linux - Networking 2 03-29-2002 06:36 AM


All times are GMT -5. The time now is 06:09 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration