LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   how to configure amarok for proxy (http://www.linuxquestions.org/questions/linux-software-2/how-to-configure-amarok-for-proxy-544875/)

etechnophile 04-10-2007 01:26 PM

how to configure amarok for proxy
 
I'm using amaroK 1.3.8 (Using KDE 3.5.1 Level "a" OpenSUSE 10.1). I access internet through a squid proxy. While I can easily configure Firefox for accessing internet through a proxy, I can't find the similar option for amaroK. As a result, the lyrics-fetching feature isn't working. Whenever I click the lyrics tab in amaroK, I get a small message sliding up near the left bottom corner typically saying "Could not access http://lyrc.com.ar/en/tema1en.php?ar...ayingCurrently. Offline mode active."

I'd be grateful for any ideas about how to make amaroK work with a proxy.

almatic 04-10-2007 04:06 PM

have you tried to globally set a proxy in the kde control center ?

etechnophile 04-14-2007 10:43 AM

No, I'll try that and let you know. Thanks for helping me out.

etechnophile 04-16-2007 06:49 AM

Doesn't work
 
I tried setting the proxy in KDE control centre, but I keep on getting the same error which says amaroK is in offline mode. I entered the same proxy I use for firefox. Tried it both with and without http:// in front of the IP address, but doesn't work either way.

Am I doing something wrong? I chose the option to specify the settings manually.

almatic 04-16-2007 07:36 AM

does fetching covers from amazon work ? Try that, if it works, then your proxy is set up correctly. I'm absolutely sure that amarok fetches it's proxy info from the global kde settings, even if you'd use gnome.

However, lyrics are fetched via an external script (ruby, perl or whatever) which is launched by amarok and not necessarily use the kde default settings. Here's what you can try:

- check if there is a proxy-setting-option for the lyrics-script. (extras -> script manager)

- Set an environment variable:
export http_proxy=http://yourproxy.com:8080

- download a better lyrics script in the above mentioned script-manager

etechnophile 04-18-2007 08:12 AM

No, fetching covers from amazon does not work either. I get this error.

Could not access http://xml.amazon.com/onca/xml3?t=we...s&page=1&f=xml. Offline mode active.

And I use KDE, not Gnome; So I really don't know why amaroK isn't paying attention to the global proxy I've configured in KDE Control Centre. Is there any other application that doesn't have proxy settings of its own, but takes the settings from KDE Control Center? That way, I can test whether I've configured the proxy correctly there and stop blaming amaroK unnecessarily.

Thanks for the advice. I really appreciate it, since lyrics is the only part I miss in amaroK compared to Windows Media Player.

almatic 04-18-2007 10:26 AM

Quote:

Originally Posted by etechnophile
Offline mode active.

Check in the konqueror settings in cache section if you have maybe set it to offline mode.
I don't know if I have translated that right, here is a screenshot of what I mean.

http://freenet-homepage.de/dateigarage/sc54.jpg

etechnophile 04-19-2007 11:36 AM

That might be it!
 
Hey, I think that's it! I vaguely remember putting Konqueror in offline mode. Didn't realize at the time that this would affect KDE global settings. Unfortunately I don't have access to that particular machine right now, but I'll try this out tomorrow and keep you posted.

Oh, and extra thanks for posting that screen shot. It made things clear all right! :)

etechnophile 04-25-2007 11:47 AM

Solved!
 
Yup, that worked! Thank you so much!


All times are GMT -5. The time now is 04:42 AM.