LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   how i install older version of gcc 2.95.3 in fedora core 8 or fedora core 12 ? (http://www.linuxquestions.org/questions/linux-software-2/how-i-install-older-version-of-gcc-2-95-3-in-fedora-core-8-or-fedora-core-12-a-795292/)

maunik 03-14-2010 05:33 AM

how i install older version of gcc 2.95.3 in fedora core 8 or fedora core 12 ?
 
i download the rpm package of gcc ...

knudfl 03-14-2010 06:14 AM

gcc-2.95 .. .. gcc-2.96
 
No, sorry, that's not possible. gcc may work, g++ will not.
And it is not possible to build it from source either. AFAIK.

The perfect solution is to install CentOS 3.9 .
gcc-c++-3.2.3 can compile ns-2.26 .
compat-gcc-7.3-2.96 can compile ns-2.1b8
The resultant binaries can be used on any Fedora.

If this is about ns-2.27, I guess the "compat-g++-3.3"
from Debian / Ubuntu can be used in Fedora.
Please ask, if you need anything for ns-allinone-2.27 .
.....

John VV 03-14-2010 03:31 PM

rewrite the programs that are very old ( from 1999 to 2001) and wrote for gcc 2 ( very very very old programs)

raju.mopidevi 03-14-2010 05:58 PM

don't take rpm, take tar.gz files.
If you want to compile a project with your own make file, use the line for the gcc = /opt/gcc33/bin/gcc or g++

you must keep existing version of gcc so that other application should work.

whenever you want to run your project, then manually load environment variables for them.

knudfl 03-15-2010 01:59 AM

@ raju.mopidevi : ""Don't use rpm"" : Why do you say that, when
you know you have "all rpm" for Suse 11.2 meant for /usr/ :
gcc33-3.3.3 , gcc41-4.1.2 , gcc43-4.3.4 , gcc44-4.4.1 , etc. etc.

.....

raju.mopidevi 03-15-2010 02:13 AM

@knudfl ; Actually my point was to intall with different name, put a different path-name.
not as a regular path name gcc, use another path name like gcc29 ..etc..

because if we use the gcc, then this may effect the latest version of gcc path. This leads to problem for the applications which relay on latest gcc.

I followed this way to install old gcc to run project.
* extracted gcc with a different name as gcc33 in the same directory where latest gcc lies.
* I gave a name gcc33 to folder. and extracted their gcc3.3 files
* Now whenever i need to run project , i made a change as CC=gcc33 ( Actually CC=GCC )

John VV 03-15-2010 02:27 AM

what i think is that "raju.mopidevi" meant that it is possible to install
MAYBE ???? but installing something SO OLD will be VERY VERY hard to do .
it must be put in it's own folder OUTSIDE OF THE SYSTEM PATH
then pass it's location to the configure script and to the build program.


However it will be MUCH easier to rewrite the old software ( from 1999- 2001) to comply with gcc 4.4 that is installed on fedora 12

knudfl 03-15-2010 03:01 AM

@ John VV : My point is just, why reinvent the wheel, when you
have packages. All modern Linux have 2 .. 4 compilers, all meant
to be installed at the same time.
The Suse example : /usr/bin/gcc-3.3 /usr/bin/g++-3.3
/usr/bin/gcc-4.1 /usr/bin/g++-4.1 /usr/bin/gcc-4.3 /usr/bin/g++-4.3
/usr/bin/gcc (4.4.1) /usr/bin/g++ (4.4.1)

Rewriting the code : I doubt anybody have the time ( 2 years ? )
to rewrite the 2000 files.

About the @raju.mopidevi suggestion to compile gcc-2.95.x :
You will need a "10" year old Linux to do that, and only
the gcc executable will work, g++-2.95 cannot be used on
a newer Linux. The latest to use it is Debian Etch.
.....

raju.mopidevi 03-15-2010 08:35 AM

no need of 10 year old linux. I had installed gcc 3.3 with existing gcc 4.4
I was able to run my project without going back to 10 years old linux system.

ashok.alluri8011 12-21-2010 05:05 AM

how to install gcc3.2.3 anad where to find s/w in fedora linux 12 ,
 
I Already installed gcc-g++34, and gcc g++ 4.4.4

My system is Linux localhost.localdomain 2.6.31.5-127.fc12.i686.PAE #1 SMP Sat Nov 7 21:25:57 EST 2009 i686 i686 i386 GNU/Linux
Purpose of giving above line is to tell u that i686 compatible version i need

And i want know which compiler version is suitable for ns-2.26?? ...and plz post link here

When i installed ns2-allinone-2.26 with gcc34 and gcc4.4.4 im getting errors like



/usr/lib/gcc/i686-redhat-linux/3.4.6/../../../../include/c++/3.4.6/bits/vector.tcc: In member function `void std::vector<_Tp, _Alloc>::_M_fill_insert(__gnu_cxx::__normal_iterator<typename _Alloc::pointer, std::vector<_Tp, _Alloc> >, size_t, const _Tp&)':
/usr/lib/gcc/i686-redhat-linux/3.4.6/../../../../include/c++/3.4.6/bits/vector.tcc:307: error: expected unqualified-id before '(' token
/usr/lib/gcc/i686-redhat-linux/3.4.6/../../../../include/c++/3.4.6/bits/vector.tcc: In member function `void std::vector<_Tp, _Alloc>::_M_range_insert(__gnu_cxx::__normal_iterator<typename _Alloc::pointer, std::vector<_Tp, _Alloc> >, _ForwardIterator, _ForwardIterator, std::forward_iterator_tag)':
/usr/lib/gcc/i686-redhat-linux/3.4.6/../../../../include/c++/3.4.6/bits/vector.tcc:384: error: expected unqualified-id before '(' token
make: *** [diffusion3/ns/difftimer.o] Error 1
Ns make failed!



plz help me...


Thanx in advance

knudfl 12-24-2010 05:15 AM

Post # 10, @ ashok.alluri8011.

'ns-allinone-2.26' compiles with the gcc / gcc-c++ version 3.3.3 from Suse.

Already answered here ( " @ ashok.alluri8011 ns-2.26 " )
http://www.linuxquestions.org/questi...-2-3-a-851561/

..


All times are GMT -5. The time now is 02:06 AM.