LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 04-17-2009, 05:51 PM   #1
urentity
Member
 
Registered: Jan 2009
Posts: 48

Rep: Reputation: 15
how do you start typing in emacs?


boy this must be stupid question of the week at least.

I'm a vi/vim user and also pity anybody who has to ask "how do I start typing in vi?" However, they usually end up typing "i" by accident and then it dawns.

However, I'm having trouble in emacs. I've googled and I'm just getting the usual verbose introductions. I thought I could just go and type, but nothing is happening.

I suspect I'm in the wrong mode ... so what the indicator for the mode I am in? What is the "insert" key for emacs?

thanks for patient replies.
 
Old 04-18-2009, 04:48 AM   #2
Zmyrgel
Senior Member
 
Registered: Dec 2005
Location: Finland
Distribution: Slackware, CentOS, RHEL, OpenBSD
Posts: 1,006

Rep: Reputation: 36
Are you serious?

Emacs doesn't have modes like Vi/Vim. When you open it you can start typing straight away.

Could be that the buffer is read-only but it should give message in the lower part of screen in that case.

Is the Emacs screen empty when you start typing or does it contain any text already? For example if you are in the startup info page you can't type but I think it should vanish as soon as you type something. It then should be in the scratch buffer and nothing should prevent you from typing.
 
Old 04-18-2009, 07:02 AM   #3
urentity
Member
 
Registered: Jan 2009
Posts: 48

Original Poster
Rep: Reputation: 15
yes, I'm being serious ... you see some frivolity in the way I'm writing? Well it shouldn't be there.

Granted, it's a stupid question, but I admitted that from the very first minute.

So this situation continues. What I get is a welcome screen full of help type text and the emacs logo. Typing keys doesn't work here.

I create a new horizontal window via "ctrl+x,2" and it gives me the same welcome page, again, no reaction to typing.

If I "touch" a file before starting emacs and run emacs on it, I am in fact able to type in it no problem.

So, this seems to affect only the open, "welcome" buffer. Perhaps it should be that way, I'm not sure.
 
Old 04-18-2009, 01:33 PM   #4
j-ray
Senior Member
 
Registered: Jan 2002
Location: germany
Distribution: ubuntu
Posts: 1,434

Rep: Reputation: 100Reputation: 100
call emacs
emacs somefile
then you can write to somefile and save with Ctrl-xs.

if you open just with "emacs" you can call Ctrl-xf and you'll be prompted to enter the name of the file you want to edit...

Last edited by j-ray; 04-18-2009 at 01:36 PM.
 
Old 04-18-2009, 01:40 PM   #5
AlucardZero
Senior Member
 
Registered: May 2006
Location: USA
Distribution: Debian
Posts: 4,647

Rep: Reputation: 524Reputation: 524Reputation: 524Reputation: 524Reputation: 524Reputation: 524
Thanks, as a vi user myself, the concept of needing a file name first is foreign to me. You can start vi, hit 'i' and start typing, and the welcome text disappears.
 
Old 04-18-2009, 05:30 PM   #6
bgoodr
Member
 
Registered: Dec 2006
Location: Oregon
Distribution: RHEL[45] {x86,x86_64}, Debian "testing" {x86,x86_64}
Posts: 219

Rep: Reputation: 36
Quote:
Originally Posted by urentity View Post
yes, I'm being serious ... you see some frivolity in the way I'm writing? Well it shouldn't be there.
When I read your post, I thought at first that you might have something seriously busted with your setup. But it is actually a limitation of the Emacs startup buffer that can trip up new users.

See Emacs Bootstrap Tutorial that I've written that should help you avoid the some of the initial pitfalls when first starting to use Emacs.

bgoodr
 
Old 04-19-2009, 03:50 AM   #7
Zmyrgel
Senior Member
 
Registered: Dec 2005
Location: Finland
Distribution: Slackware, CentOS, RHEL, OpenBSD
Posts: 1,006

Rep: Reputation: 36
You can add following to your ~/.emacs file to disable the default startup screen
Code:
(setq inhibit-startup-message t)         ; no splash screen
 
  


Reply

Tags
emacs, startup, tutorials


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Emacs does not start linuxfan2008 Slackware 1 01-07-2009 11:16 AM
emacs won't start on Slack 12.1 brokencog Linux - Software 2 09-21-2008 09:48 AM
(x)emacs doesn't start thelonius Debian 8 07-21-2006 12:30 PM
How do you start programs without typing ./ jwijesundra Linux - General 2 07-01-2004 06:36 AM
How can I start typing in the commands? Rutnut Linux - Newbie 1 12-13-2000 04:48 AM


All times are GMT -5. The time now is 02:53 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration