LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   how do you start typing in emacs? (http://www.linuxquestions.org/questions/linux-software-2/how-do-you-start-typing-in-emacs-719943/)

urentity 04-17-2009 05:51 PM

how do you start typing in emacs?
 
boy this must be stupid question of the week at least.

I'm a vi/vim user and also pity anybody who has to ask "how do I start typing in vi?" However, they usually end up typing "i" by accident and then it dawns.

However, I'm having trouble in emacs. I've googled and I'm just getting the usual verbose introductions. I thought I could just go and type, but nothing is happening.

I suspect I'm in the wrong mode ... so what the indicator for the mode I am in? What is the "insert" key for emacs?

thanks for patient replies.

Zmyrgel 04-18-2009 04:48 AM

Are you serious?

Emacs doesn't have modes like Vi/Vim. When you open it you can start typing straight away.

Could be that the buffer is read-only but it should give message in the lower part of screen in that case.

Is the Emacs screen empty when you start typing or does it contain any text already? For example if you are in the startup info page you can't type but I think it should vanish as soon as you type something. It then should be in the scratch buffer and nothing should prevent you from typing.

urentity 04-18-2009 07:02 AM

yes, I'm being serious ... you see some frivolity in the way I'm writing? Well it shouldn't be there.

Granted, it's a stupid question, but I admitted that from the very first minute.

So this situation continues. What I get is a welcome screen full of help type text and the emacs logo. Typing keys doesn't work here.

I create a new horizontal window via "ctrl+x,2" and it gives me the same welcome page, again, no reaction to typing.

If I "touch" a file before starting emacs and run emacs on it, I am in fact able to type in it no problem.

So, this seems to affect only the open, "welcome" buffer. Perhaps it should be that way, I'm not sure.

j-ray 04-18-2009 01:33 PM

call emacs
emacs somefile
then you can write to somefile and save with Ctrl-xs.

if you open just with "emacs" you can call Ctrl-xf and you'll be prompted to enter the name of the file you want to edit...

AlucardZero 04-18-2009 01:40 PM

Thanks, as a vi user myself, the concept of needing a file name first is foreign to me. You can start vi, hit 'i' and start typing, and the welcome text disappears.

bgoodr 04-18-2009 05:30 PM

Quote:

Originally Posted by urentity (Post 3513112)
yes, I'm being serious ... you see some frivolity in the way I'm writing? Well it shouldn't be there.

When I read your post, I thought at first that you might have something seriously busted with your setup. But it is actually a limitation of the Emacs startup buffer that can trip up new users.

See Emacs Bootstrap Tutorial that I've written that should help you avoid the some of the initial pitfalls when first starting to use Emacs.

bgoodr

Zmyrgel 04-19-2009 03:50 AM

You can add following to your ~/.emacs file to disable the default startup screen
Code:

(setq inhibit-startup-message t)        ; no splash screen


All times are GMT -5. The time now is 07:00 PM.