LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-20-2004, 03:48 PM   #1
SSJ-sHaDoW
LQ Newbie
 
Registered: Oct 2003
Location: Canada
Distribution: Mandrake 9.1
Posts: 29

Rep: Reputation: 15
How do you change the resolution so that it scales (no scrolling)...?


I'm trying to set it to 640x480, but of course all it does is zoom in and you have to scroll around everywhere... I don't even know why that exists, because it's a pain in the ass. I want everything to fit on the screen.

How can I do this (if it's possible)?
 
Old 01-20-2004, 03:49 PM   #2
SSJ-sHaDoW
LQ Newbie
 
Registered: Oct 2003
Location: Canada
Distribution: Mandrake 9.1
Posts: 29

Original Poster
Rep: Reputation: 15
And I just realized it might have been better to put this in General.

Oh well.
 
Old 01-20-2004, 07:28 PM   #3
Pres
Member
 
Registered: Jun 2002
Location: Australia
Distribution: Slack 9.1
Posts: 232

Rep: Reputation: 30
Cntl + Alt + keypad "-" will possibly do what you want.

A more permanent solution can be achieved by changing the XF86Config file, but the exact parameters are not known to me.
 
Old 01-20-2004, 11:26 PM   #4
SSJ-sHaDoW
LQ Newbie
 
Registered: Oct 2003
Location: Canada
Distribution: Mandrake 9.1
Posts: 29

Original Poster
Rep: Reputation: 15
The control+alt method produces the same problem.

I also tried editing the config file so that the order of resolutions started with 640x480... and it does boot up in 640x480, but the same thing still happens.

Anyone else have any ideas?

Last edited by SSJ-sHaDoW; 01-20-2004 at 11:28 PM.
 
Old 01-20-2004, 11:30 PM   #5
Onemessedupjedi
Member
 
Registered: Sep 2003
Location: Oregon
Distribution: Slackware 9.1
Posts: 194

Rep: Reputation: 30
post your XF86Config

in the case of something that has a config it is best to post it and any output you can get from the program.
Just be careful about giving out information in the configs that you don't want others to know if you are administering a company.

the ctrl alt thing is pretty cool, I love learning new useless stuff like that.
 
Old 01-20-2004, 11:52 PM   #6
jtshaw
Senior Member
 
Registered: Nov 2000
Location: Seattle, WA USA
Distribution: Ubuntu @ Home, RHEL @ Work
Posts: 3,892
Blog Entries: 1

Rep: Reputation: 67
Ya, post your config file (usually /etc/X11/XF86Config or XF86Config-4). You should have a section like this somewhere, which determines the resolution it runs at:
Code:
Section "Screen"
    Identifier  "Screen 1"
    Device      "NVIDIA"
    Monitor     "VX2000"
    DefaultDepth 24

    Subsection "Display"
        Depth       8
        Modes       "1600x1200" "800x600"
        ViewPort    0 0
    EndSubsection
    Subsection "Display"
        Depth       16
        Modes       "1600x1200" "800x600"
        ViewPort    0 0
    EndSubsection
    Subsection "Display"
        Depth       24
        Modes       "1600x1200" "800x600"
        ViewPort    0 0
    EndSubsection
EndSection
There is probably some option you have set in there, or around there, which tells it to use a virual screen size. All ctrl alt does is scroll through the different resolutions listed for whatever color depth you are running at.
 
Old 01-21-2004, 01:47 AM   #7
SSJ-sHaDoW
LQ Newbie
 
Registered: Oct 2003
Location: Canada
Distribution: Mandrake 9.1
Posts: 29

Original Poster
Rep: Reputation: 15
Yeah, that's what I tried editing before.

Here's the whole file:

Code:
Section "Files"
    # Multiple FontPath entries are allowed (they are concatenated together)
    # By default, Mandrake 6.0 and later now use a font server independent of
    # the X server to render fonts.
    FontPath "unix/:-1"
EndSection

Section "ServerFlags"
    #DontZap # disable <Crtl><Alt><BS> (server abort)
    AllowMouseOpenFail # allows the server to start up even if the mouse doesn't work
    #DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
EndSection

Section "Module"
    Load "dbe" # Double-Buffering Extension
    Load "v4l" # Video for Linux
    Load "extmod"
    Load "type1"
    Load "freetype"
    Load "glx" # 3D layer
EndSection

Section "InputDevice"
    Identifier "Keyboard1"
    Driver "Keyboard"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "us"
    Option "XkbCompat" ""
    Option "XkbOptions" ""
EndSection

Section "InputDevice"
    Identifier "Mouse1"
    Driver "mouse"
    Option "Protocol" "PS/2"
    Option "Device" "/dev/psaux"
    Option "Emulate3Buttons"
    Option "Emulate3Timeout" "50"
EndSection

Section "Monitor"
    Identifier "monitor1"
    VendorName "Generic"
    ModelName "1024x768 @ 60 Hz"
    HorizSync 31.5-48.5
    VertRefresh 50-70
    
    # Sony Vaio C1(X,XS,VE,VN)?
    # 1024x480 @ 85.6 Hz, 48 kHz hsync
    ModeLine "1024x480"    65.00 1024 1032 1176 1344   480  488  494  563 -hsync -vsync
    
    # TV fullscreen mode or DVD fullscreen output.
    # 768x576 @ 79 Hz, 50 kHz hsync
    ModeLine "768x576"     50.00  768  832  846 1000   576  590  595  630
    
    # 768x576 @ 100 Hz, 61.6 kHz hsync
    ModeLine "768x576"     63.07  768  800  960 1024   576  578  590  616
EndSection

Section "Device"
    Identifier "device1"
    VendorName "nVidia Corporation"
    BoardName "RIVA TNT2"
    Driver "nvidia"
    Option "DPMS"
    Option "NvAGP" "0"
    Option "IgnoreDisplayDevices" "DFP, TV"
    Option "NoLogo" "true"
EndSection

Section "Screen"
    Identifier "screen1"
    Device "device1"
    Monitor "monitor1"
    DefaultColorDepth 24
    
    Subsection "Display"
        Depth 8
        Modes "1024x768" "800x600" "640x480"
    EndSubsection
    
    Subsection "Display"
        Depth 15
        Modes "1024x768" "800x600" "640x480"
    EndSubsection
    
    Subsection "Display"
        Depth 16
        Modes "1024x768" "800x600" "640x480"
    EndSubsection
    
    Subsection "Display"
        Depth 24
        Modes "1024x768" "800x600" "640x480"
    EndSubsection
EndSection

Section "ServerLayout"
    Identifier "layout1"
    InputDevice "Keyboard1" "CoreKeyboard"
    InputDevice "Mouse1" "CorePointer"
    Screen "screen1"
EndSection
I tried changing the last Display subsection to:

Code:
    Subsection "Display"
        Depth 24
        Modes "640x480" "800x600" "1024x768"
    EndSubsection
When it's like that, it starts up in 640x480, but it still scrolls.

I don't see any virtual desktop stuff in there, or maybe I'm just blind.
 
Old 01-21-2004, 06:21 PM   #8
SSJ-sHaDoW
LQ Newbie
 
Registered: Oct 2003
Location: Canada
Distribution: Mandrake 9.1
Posts: 29

Original Poster
Rep: Reputation: 15
Anyone? Anyone?
 
Old 01-22-2004, 09:23 PM   #9
SSJ-sHaDoW
LQ Newbie
 
Registered: Oct 2003
Location: Canada
Distribution: Mandrake 9.1
Posts: 29

Original Poster
Rep: Reputation: 15
*sigh* I don't even know why I bothered asking. I never get the right help from this place.
 
Old 01-22-2004, 10:07 PM   #10
DrOzz
Senior Member
 
Registered: May 2003
Location: Sydney, Nova Scotia, Canada
Distribution: slackware
Posts: 4,185

Rep: Reputation: 59
well worse comes to worse, re-run xf86config and the very last step will ask what you want your default mode to be, so just state your color depth and resolution that you want as defaults ...
 
Old 01-24-2004, 07:55 AM   #11
morrolan
Member
 
Registered: Sep 2003
Location: Manchester UK
Posts: 262

Rep: Reputation: 30
no no no! Run xf86config again, and when it asks you if the resolutions are in the correct default order, say NO, and change them to whatever order you want, i.e. "640x480" "800x600", and the most important thing is, when you do that, it will ask you if you want to enable the virtual screen or something - thats is where you have to say NO. Do that for each colour-depth and it will then scale to the correct resolution.

I'm sorry but I don't know where the output of this question is in the /etc/X11/XF86Config file, I only know where it asks the question...

Oh btw, it also helps if you let us know what distro you are using - the above works for Debian and Slackware, and I'd assume the rest too!
 
Old 01-25-2004, 04:27 AM   #12
Onemessedupjedi
Member
 
Registered: Sep 2003
Location: Oregon
Distribution: Slackware 9.1
Posts: 194

Rep: Reputation: 30
Sorry I didn't respond sooner, I don't have a broadband connection so I jump on and off every once in a while.

KDE does have a purpose. If you go into the dreaded KDE control panel and go to x server it'll list resolution and virtual desktop. See if virtual desktop is set to anything and if it isn't then possibly it's bad drivers.
or
comment out your monitor refresh rates. Maybe that interfers with DMPS. this is just a guess but I know I have never needed refresh rates set.
Save your current XF86Config and replace it with a generic VESA config file since your card SHOULD support that. Goodluck

To the guy that posted above me:
You should actually edit the config files yourself....it's much nicer then using any auto program because then you know what to troubleshoot when you make mistakes.

Last edited by Onemessedupjedi; 01-25-2004 at 04:34 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Text Resolution, Graphic resolution. Change from prompt dlublink SUSE / openSUSE 2 01-28-2005 11:50 AM
hard scrolling vs soft scrolling (console) haxcess Linux - General 2 08-30-2004 12:17 AM
to change mouse scrolling direction comporell Linux - Newbie 8 05-12-2004 01:31 AM
Resolution does not change Kuki Linux - Newbie 2 03-04-2004 11:32 AM
Screen resolution & Scrolling moose Linux - Hardware 1 05-24-2003 02:26 AM


All times are GMT -5. The time now is 01:21 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration