LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 11-10-2011, 10:48 PM   #1
baronobeefdip
Senior Member
 
Registered: Jul 2009
Distribution: Debian Squeeze
Posts: 1,203

Rep: Reputation: 32
how do i use network-manager in backtrack instead of wicd


i am using backtrack wireless and i am getting tired of using wicd for numerious reasons like the wicd isn't as nice to wpa2 enterprise active directories while network-manager is for some reason i can't get my computer to connect to the wireless network we use a wpa2 enterprise with leap for the security function so wicd doesn't connect to it so how do i go about installing network-manager and using it instead of wicd
 
Old 11-13-2011, 05:54 PM   #2
Brains
Member
 
Registered: Apr 2009
Distribution: Debian testing
Posts: 258

Rep: Reputation: 42
Seeing as Backtrack is Ubuntu based, Ubuntu is Debian based, you can either use apt-get or synaptics if installed. Just remove wicd and install network-manager and network-manager-applet from source as it appears it is not available in Backtrack repos. After reboot the applet should be somewhere, click on it and configure.
 
Old 11-13-2011, 07:36 PM   #3
baronobeefdip
Senior Member
 
Registered: Jul 2009
Distribution: Debian Squeeze
Posts: 1,203

Original Poster
Rep: Reputation: 32
the network manager is available in the repos but i don't know about the applet but i am assuming that it was installed correctly since i just saw the little radio wave icon in the corner but for some reason when i enabled networking the app didn't scan for any wireless APs, i restarted the machine to see if network-manager would negate wicd's processes and the radio wave icon disappeared and now i am left with no networking capabilities, so what was i supposed to do then
 
Old 11-13-2011, 09:05 PM   #4
rokytnji
Senior Member
 
Registered: Mar 2008
Location: Waaaaay out West Texas
Distribution: AntiX 13 , MacPup,Linux-Lite 2.0, SaliX
Posts: 2,844
Blog Entries: 18

Rep: Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912
Quote:
i restarted the machine to see if network-manager would negate wicd's processes
Wicd and Network manager installed side by side conflicts with the other.

Brains said

Quote:
Just remove wicd
which from your later post seems like you did not do.
 
Old 11-14-2011, 12:33 AM   #5
baronobeefdip
Senior Member
 
Registered: Jul 2009
Distribution: Debian Squeeze
Posts: 1,203

Original Poster
Rep: Reputation: 32
i did remove wicd but i guess that was after i installed network manager so i am assuming that i was suppossed to uninstall wicd and install network-manager at the same time. because when wicd goes away i have no more internet connection and that means that i won't be able to install network-manager. is there at least something that i should do after i install it which is what will happen after i uninstall wicd.
 
Old 11-14-2011, 12:54 AM   #6
rokytnji
Senior Member
 
Registered: Mar 2008
Location: Waaaaay out West Texas
Distribution: AntiX 13 , MacPup,Linux-Lite 2.0, SaliX
Posts: 2,844
Blog Entries: 18

Rep: Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912
Quote:
i did remove wicd but i guess that was after
Ok. That is OK. As Long as the 2 are not running side by side.

As far as wpa for network manager. I run wicd and wpa2 encryption just fine with no disconnects or troubles.

Not sure why network manager disappears when you click on it either. Not a Back Track user myself.

I guess you could look through

Code:
sudo ifconfig -a
or
Code:
sudo ip addr show
A good site to look through since you are running backtrack

http://www.tty1.net/blog/2010-04-21-...arison_en.html
 
Old 11-14-2011, 02:39 AM   #7
Brains
Member
 
Registered: Apr 2009
Distribution: Debian testing
Posts: 258

Rep: Reputation: 42
At the Backtrack site there is a FAQ link, number 17 might help. Also, there are many tutorials for configuring /etc/network/interfaces file to have your wireless card configured upon boot up. There are also many tutorials to connect via command line, an example below. Apparently from what synaptic says about Fluxbox, there should be a way to enable a network applet if FAQ 17 still don't show something, but I have no Fluxbox experience. If there is no way to get an applet, then installing from source might get one for you.

Code:
run command: ifconfig to see name of wireless interface, if wlan0, try next commands
iwlist wlan0 scan
iwconfig wlan0 ap XX:XX:XX:XX:XX:XX    (replace Xs with numbers for your router's mac address)
iwconfig wlan0 essid "ap_name"         (replace ap_name with your router's essid name)
iwconfig wlan0 mode managed
iwconfig wlan0 key s:12345             (replace 12345 with your wpa2psk key)
dhclient wlan0
Every wireless router I've come in contact with has four rj45 ports to connect a computer via the NIC. For some stupid reason, ISP providers do not throw in a six foot network cable with the router for days when you have wireless issues. Anyway they are cheap to buy and are handy for dealing with issues like this so you can always have an internet connection, unless you are borrowing the neighbors wireless broadcast signal.
 
Old 11-14-2011, 10:48 AM   #8
baronobeefdip
Senior Member
 
Registered: Jul 2009
Distribution: Debian Squeeze
Posts: 1,203

Original Poster
Rep: Reputation: 32
never not without their permission, besides i also have another thing. on some wireless networks i come into contact with wpa2 enterprise with peap encryption which requires a username and password. i tried it in wicd and no dice but every time i do it in debian's network-manager applet it works fine so i was figuring that this would make things a little easier when it comes to encryption like this.

i also seriously need to change my wireless encryption i still use wep and i need to move on to wpa2.

Last edited by baronobeefdip; 11-14-2011 at 11:40 AM.
 
Old 11-14-2011, 09:12 PM   #9
baronobeefdip
Senior Member
 
Registered: Jul 2009
Distribution: Debian Squeeze
Posts: 1,203

Original Poster
Rep: Reputation: 32
Quote:
Originally Posted by rokytnji View Post
As far as wpa for network manager. I run wicd and wpa2 encryption just fine with no disconnects or troubles.
have you ever tried it with active directory login credentials.
normally in distros like Fedora, Ubuntu and Debian they tell us how to log in with the network manager nobody ever mentioned wicd so i'll tell you. in the wireless window we were told to select wpa2 enterprise. the authentication is PEAP and the inner authentication is MSCHAPv2. some how i found this in wicd but it doesn't connect instead it just times out, i never had this problem with networkmanager before so i want to try it
 
Old 11-14-2011, 11:17 PM   #10
rokytnji
Senior Member
 
Registered: Mar 2008
Location: Waaaaay out West Texas
Distribution: AntiX 13 , MacPup,Linux-Lite 2.0, SaliX
Posts: 2,844
Blog Entries: 18

Rep: Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912
Quote:
have you ever tried it with active directory login credentials
I personally don't use Windows if that (quote above) is what you mean on my home network. My wife is the only Windows 7 user and I don't use her laptop as a server. My wireless is set up as WPA-Personal (psk).

Antix wicd handles that just fine. Same for when I have to access wpa wireless networks on the road like motels.

Have you even read The Ubuntu documention on Network Manager for installing it properly on different Desktops than Gnome.

Quote:
Notes
Gnome
Go to System -> Preferences -> Sessions In the Startup Programs tab, click Add type "nm-applet", click OK. log out of your gnome session, and log back in again.

Other Window Managers/Desktop Environments
add nm-applet to your startup

Note: nm-applet is now part of the network-manager-gnome package which is recommended when you install the network-manager package but may not have been installed.
You can find out if nm-applet is installed I guess with the command

Code:
apt-cache policy nm-applet
For startup I guess. To find the command.

Code:
which nm-applet
should probably output /usr/bin/nm-applet. You won't need the /usr/bin/ part for startup. Just nm-applet & .

That goes in your hidden startup file in /home/your user name/.fluxbox/startup.

Fluxbox wiki

Good Luck again.

Last edited by rokytnji; 11-14-2011 at 11:23 PM.
 
Old 11-17-2011, 02:20 AM   #11
baronobeefdip
Senior Member
 
Registered: Jul 2009
Distribution: Debian Squeeze
Posts: 1,203

Original Poster
Rep: Reputation: 32
alright i just uninstalled wicd and installed network-manager-gnome and for a while i was able to bring up the applet in the corner of the screen but for some reason it couldn't start managing the network so i did a reboot. on reboot the little radio signal icon is once again missig so i opened a terminal and typed this
Code:
#nm-applet
the command came back and told me that another instance of nm-applet was running but i didn't see it. i then discovered that it was off to the side too uch since i could click the mouse button in the far top right corner of the screen i tried to move it into visibility but when i unlocked the notification field it wasn't showing now i have lost the icon and i want to get it back typing nm-applet in the terminal doesn't help

another thing that got me is that the wireless card functioned perfectly in wicd but i never got "wireless networks found" bubble on the screen could this be because the icon wasn't visible? i really want to get that icon back
 
Old 11-17-2011, 05:45 PM   #12
baronobeefdip
Senior Member
 
Registered: Jul 2009
Distribution: Debian Squeeze
Posts: 1,203

Original Poster
Rep: Reputation: 32
is there at least someone that has connected to a wireless network that uses the encryption
WPA2 enterprise
PEAP (Protected EAP)
MSCHAPv2

and you need to enter a username and password. this connection worked fine in Debian (which is what backtrack is based one when you look at it underneath the Ubuntu similarities)

and the applet on the top bar disappeared after i was able to get it up and working but after i removed wicd i had to restart because the icon wasn't listing any network and when i did it still wasn't listing anythig while being completely hidden from the screen i was able to view it's option by clicking to the corner of the screen in the far top right btu after another restart it was gone for good so now i don't have a networking manager program.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Networking in Virtualbox, WICD and no Gnome network manager yanfaun Linux - Virtualization and Cloud 8 06-01-2010 06:07 PM
Can not install wicd (conflicts with network manager) Ehlyah Linux - Software 3 04-21-2010 09:14 AM
* starting network connection manager wicd [fail] vin_akleh Linux - Newbie 0 02-22-2010 10:54 PM
WICD tray icon says not connected, WICD manager says conneted to wired network?!?! intheshadows Linux - Newbie 1 12-24-2009 01:15 PM
LXer: Network-Manager-GNOME vs. Wicd Reviewed LXer Syndicated Linux News 1 12-03-2007 05:26 PM


All times are GMT -5. The time now is 07:15 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration