LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 08-15-2003, 05:36 AM   #1
RyanA
LQ Newbie
 
Registered: Nov 2002
Posts: 16

Rep: Reputation: 0
How do I make SSH use the MAIL variable set by /etc/login.defs?


The problem I'm having is when a user logs in with SSH the $MAIL var = /var/mail/user! If I "su - user" MAIL is correctly set to ~user/mail


Next, I edited /etc/login.defs commenting out MAIL_DIR and setting the correct path for QMAIL_DIR & MAIL_FILE

exim is configured to deliver email to: ~user/mail -- I have verified that mail is correctly being delivered to ~user/mail/new

updated login & ssh in /etc/pam.d/ so that can correctly inform users of new mail upon login -- This works as expected
 
Old 08-15-2003, 11:03 AM   #2
RyanA
LQ Newbie
 
Registered: Nov 2002
Posts: 16

Original Poster
Rep: Reputation: 0
I finally managed to solve this by adding MAIL=~/mail to /etc/profile ... I'm not sure if that's the best way to solve the problem. mail now gives me the error
Quote:
mail: /home/user/mail/: Is a directory
...which means mail isn't configured to support the Maildir format and I haven't been able to find any information on how to change that through searching. MUTT does work, though!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
umask & /etc/login.defs gepesz Linux - Software 2 09-04-2011 03:02 AM
/etc/ Login.defs will not save my settings??? wardialer Linux - Security 2 03-09-2005 08:37 AM
Startup script=/etc/login.defs? ~zoey~ Linux - Newbie 2 11-12-2004 11:44 PM
Set Global variable for daemon without login RX100 Linux - Software 3 10-08-2004 08:50 AM
MAIL variable not set in X tjpick Slackware 1 08-14-2003 02:27 AM


All times are GMT -5. The time now is 05:56 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration