LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 11-14-2003, 04:12 AM   #1
vasudevadas
Member
 
Registered: Jul 2003
Location: Bedford, UK
Distribution: Slackware 11.0, LFS 6.1
Posts: 519

Rep: Reputation: 30
How do I get xmms to play a CD?


This should be easily answered. I do have the CD audio player plugin installed and enabled, btw.
 
Old 11-14-2003, 04:35 AM   #2
Vlad_M
Member
 
Registered: Aug 2002
Location: Cape Town, South Africa
Distribution: Red Hat 8.0 (Home), Red Hat 8.0 (Work)
Posts: 388

Rep: Reputation: 30
I found that a much easier way to get cd audio working is just to use a cable between your soundcard and cd rom.
 
Old 11-14-2003, 04:37 AM   #3
vasudevadas
Member
 
Registered: Jul 2003
Location: Bedford, UK
Distribution: Slackware 11.0, LFS 6.1
Posts: 519

Original Poster
Rep: Reputation: 30
It already has one. I can listen to CDs on my computer using the KDE cd player application. (Although my hi-fi sounds much better). I just wondered how to get xmms to do it.
 
Old 11-14-2003, 06:21 AM   #4
hulkt
Member
 
Registered: Oct 2003
Posts: 172

Rep: Reputation: 30
there is a plugin for xmms to play cd.
forgot the name, its in mandrake distro anyway
 
Old 11-14-2003, 07:15 AM   #5
vasudevadas
Member
 
Registered: Jul 2003
Location: Bedford, UK
Distribution: Slackware 11.0, LFS 6.1
Posts: 519

Original Poster
Rep: Reputation: 30
I believe I already have it installed. In the Audio I/O plugins screen, one of the plugins listed is called "CD Audio Player 1.2.7 [libcdaudio.so]" which sounds very much like the ticket. It is enabled, too. So, how do I use it? I'm finding it less than obvious.
 
Old 11-14-2003, 08:15 AM   #6
Tramontane
Member
 
Registered: Oct 2003
Distribution: Debian
Posts: 39

Rep: Reputation: 15
That's what I thought, too. But there is another plugin you'll have to get.
You need to download and install the "xmms-cdread" plugin. I've seen it packaged for debian and redhat. Then make sure that the current account has access to your cd device. For instance, I had to add my user account to group 'disk' since "ls -l /dev/hdc " returned something like
"br--r----- 1 root disk ....."

ftp://ftp.stack.nl/pub/users/willem/...d-0.14a.tar.gz

Then configure your plugins and try to point xmms to the device. In the 'open/add file' dialog, I just had to point it to '/dev/hdc'. I had to have both cd-related plugins enabled though, so maybe that will help.

Remember, if you add a user to a group, the changes won't take effect until that user logs in again. You don't have to have the audio cable, nor do you have to mount the drive.


edit:
You may be able to disable the cdaudio plugin. I was so glad that I got it to play that I didn't bother seeing if it still worked after disabling it. Apparently the cdaudio plugin is meant to be used with the analog cable.

Last edited by Tramontane; 11-14-2003 at 08:41 AM.
 
Old 11-14-2003, 08:29 AM   #7
randomblast
Member
 
Registered: Aug 2003
Location: Manchester, England, UK, The World....
Distribution: Gentoo/SuSE 9.0
Posts: 291

Rep: Reputation: 30
xmms can read CDs out of the box, in the xmms options dialog select the CD Player input plugin, click configure
add your CD drive(s) if you have a decent drive you can use digital audio extraction, point it at the device (/dev/hdd) and the mount point (/mnt/hdd)
i don't recommend using the /dev/cdrom because it is just a symlink to /dev/hd(b,c,d) or whatever your drive is
do "ls -l /dev/cdrom" to see where it's pointing.
click "check drive" to test it, if it says tests OK then all is well, if it bitches about not having permissions ar something similar, do what Tremontane said, set the /dev/hd(b,c,d) file to readable by everyone (as root "chmod 444 /dev/hd(b,c,d)"
then to do the actual playing you open the directory /mnt/hd(b,c,d) or whatever you put in the xmms CD configuration
 
Old 11-14-2003, 08:36 AM   #8
Tramontane
Member
 
Registered: Oct 2003
Distribution: Debian
Posts: 39

Rep: Reputation: 15
hey, if you get it working, let us know what you did. good luck
 
Old 11-14-2003, 08:42 AM   #9
hulkt
Member
 
Registered: Oct 2003
Posts: 172

Rep: Reputation: 30
open file, open cdda track from cd, itll play all cd...
like this on my system, without plugin, cant open...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
XMMS won't play anything garyozzy Linux - Software 18 10-20-2005 07:06 PM
XMMS won't play MP3s NightMICU Linux - General 9 08-09-2005 01:09 PM
cant play anything with XMMS jaakkop Linux - Software 1 07-16-2005 06:54 AM
How to play mp3 with XMMS vanhelsing Linux - Software 12 05-31-2004 07:04 PM
Can't play audio CD with xmms pointdexter Linux - General 1 09-16-2003 07:43 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 10:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration