LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-10-2002, 01:36 AM   #1
DiscoStoo
LQ Newbie
 
Registered: Mar 2002
Distribution: Slackware 10.1
Posts: 24

Rep: Reputation: 15
Question Sound problem in Slack 8


When I installed Slackware 8 it didn't create any devices for my sound card or my CDROM, and I was wondering how I could get those. Actually I got the CDROM to work once, all the sudden when I booted there were the /dev/hdc devices, but it never worked again after that. Sound I've never been able to get to work. I'm from a Mandrake background here, so I don't know how to do this crap by hand yet.

Last edited by DiscoStoo; 03-10-2002 at 02:45 AM.
 
Old 03-10-2002, 02:44 AM   #2
DiscoStoo
LQ Newbie
 
Registered: Mar 2002
Distribution: Slackware 10.1
Posts: 24

Original Poster
Rep: Reputation: 15
Ok, I figured out why the devices weren't being created, it was a devfs problem. I fixed that and now I can mount my cdrom, but I'm still having sound troubles. /dev/dsp is there, and when I cat stuff to it I hear sounds, but xmms and other apps say they "can't open /dev/dsp". Any ideas anybody?
 
Old 03-10-2002, 03:00 AM   #3
jrbush82
Member
 
Registered: Mar 2002
Location: Hampton, VA
Posts: 86

Rep: Reputation: 15
permissions problem

as root, type:

chmod 666 /dev/dsp
chmod 666 /dev/mixer
chmod 666 /dev/audio

should work as user now
 
Old 03-10-2002, 12:48 PM   #4
DiscoStoo
LQ Newbie
 
Registered: Mar 2002
Distribution: Slackware 10.1
Posts: 24

Original Poster
Rep: Reputation: 15
Okay, that did the trick, thanks. Now I've got sound running with the enlightened sound daemon, but it's pretty crappy sounding, and it makes the sound delayed by almost a second. That CAN'T be normal...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
unable to Mount cdrom in slack 10.2 valjoux Linux - Hardware 2 10-04-2005 08:04 PM
slack 10 - moved cdrom - not detected AM1SHFURN1TURE Linux - Hardware 2 04-11-2005 11:19 PM
Slack install w/o floppy or cdrom eversi0n Linux - Newbie 1 06-02-2004 11:08 PM
How do I set up CDROM and CDRW in Slack? lumpfish Slackware 7 11-16-2003 02:36 PM
install slack without floppie without cdrom xcobra Linux - Software 1 08-24-2003 04:58 PM


All times are GMT -5. The time now is 02:50 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration