LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-11-2004, 04:54 AM   #16
win32sux
LQ Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 376Reputation: 376Reputation: 376Reputation: 376

well the microphone feedback is very good news... sounds like we're making some progress...

=)



anyways, it looks like you don't have xmms' alsa support installed... to install it just do a:


urpmi xmms-alsa


then your xmms should be ready to use the advanced linux sound architecture...

remember to close xmms before installing xmms-alsa and stuff...


also, you might wanna add some skins to your xmms while you're at it:


urpmi xmms-skins


of course you can install more than one package at a time... for example, this would install the two from above plus mpg video support and some eye candy:


urpmi xmms-alsa xmms-skins xmms-smpeg xmms-more-vis-plugins


or whatever else you want...

=)





-----------------------------------------

i've noticed that on some sound chips (mostly ac97 from what i've seen), on xmms you need to configure the output plugin to use software volume control... you do that by clicking on "configure" after selecting the output plugin (alsa in this case)... of course this is just a maybe... if your volume control has no effect, then you know you need to configure this...

Last edited by win32sux; 03-11-2004 at 04:57 AM.
 
Old 03-11-2004, 05:05 AM   #17
/home/kyle
Member
 
Registered: Mar 2004
Posts: 148

Original Poster
Rep: Reputation: 15
CoOl skins and visuals ..HmmMm, BuT..bad news

I ran urpmi xmms-alsa, went back into xmms, selected the alsa driver that is there now, clicked aply, exited xmms, went back into it...and still no sound , I am worried that my onboard sound may not be compatable with Linux
 
Old 03-11-2004, 05:15 AM   #18
win32sux
LQ Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 376Reputation: 376Reputation: 376Reputation: 376
when you enter xmms does the volume fall to zero immediately???

when you try to play an mp3 and there's no sound, is the spectrum analyzer on xmms active???

try this, just as a test, not as a replacement for xmms or anything:


urpmi mpg123


that would install a command-line based player...

once it's installed, try to play an mp3 with it to see if it works...

open a terminal and just type the command followed by the mp3s name... example:


mpg123 /home/kyle/radiohead-rabbit_in_your_headlights.mp3


also, post the output of these:

ls -l /dev/mixer

ls -l /dev/dsp


also try running the alsamixer, maybe the sound is muted or something:

alsamixer


if mpg123 gives you sound then xmms might just need some tweakin'... most likely you'd just have to play around in the "configure" option of the output plugin...

Last edited by win32sux; 03-11-2004 at 05:26 AM.
 
Old 03-11-2004, 05:27 AM   #19
/home/kyle
Member
 
Registered: Mar 2004
Posts: 148

Original Poster
Rep: Reputation: 15
On alsamixer everything is up but Line In & PCM, I tried to turn them both up, but they dont turn up.

No sound when I do 'mp123 song1.mp3' says it is playing.

ls -l /dev/mixer
lr-xr-xr-x 1 root root 11 Mar 9 21:26 /dev/mixer -> sound/mixer

ls -l /dev/dps
lr-xr-xr-x 1 root root 9 Mar 9 21:26 /dev/dsp -> sound/dsp

edit: forgot somethin

Yes the spectrum thingy (the bars that go up and down) do move.

Last edited by /home/kyle; 03-11-2004 at 05:30 AM.
 
Old 03-11-2004, 05:30 AM   #20
win32sux
LQ Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 376Reputation: 376Reputation: 376Reputation: 376
well you need pcm to be up... if your alsamixer is like mine you just move around with the side arrows and modify the levels with the up and down arrows...

the spectrum being active is good news...

=)


you'll probably need to activate the software volume control i mentioned earlier... the volume control on xmms controls pcm by default...

Last edited by win32sux; 03-11-2004 at 05:32 AM.
 
Old 03-11-2004, 05:31 AM   #21
/home/kyle
Member
 
Registered: Mar 2004
Posts: 148

Original Poster
Rep: Reputation: 15
Yea, I jsut edited my post up there and said that I cant turn line in, or PCM up, it wont let me. I can only turn all the other stuff up/down.

I want sound. I hate not being able to hear things!

Last edited by /home/kyle; 03-11-2004 at 05:32 AM.
 
Old 03-11-2004, 05:34 AM   #22
win32sux
LQ Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 376Reputation: 376Reputation: 376Reputation: 376
hmmm... okay, what about using kde's built-in mixer... kmix...

it's in the kde menu in there somewhere...

i guess you can call it from the command line also:


kmix


also, this will sound stupid, but make sure your speakers are on...

i've never seen the spectrum on xmms work when the sound is not working... of course it might do that though, i'm not sure...

Last edited by win32sux; 03-11-2004 at 05:39 AM.
 
Old 03-11-2004, 05:38 AM   #23
/home/kyle
Member
 
Registered: Mar 2004
Posts: 148

Original Poster
Rep: Reputation: 15
Yes, I have been to that already, that is where I turned the micophone feedback off, everything is up and lookin good there to, nothing muted..except the microphone thing that was causing those beeps and blips.
 
Old 03-11-2004, 05:43 AM   #24
/home/kyle
Member
 
Registered: Mar 2004
Posts: 148

Original Poster
Rep: Reputation: 15
I broke my speakers while II was moving, right now I am using my sony MDR - V150 head phones.
 
Old 03-11-2004, 05:47 AM   #25
win32sux
LQ Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 376Reputation: 376Reputation: 376Reputation: 376
okay your lsmod said you've got oss up also so try telling xmms to use oss instead of alsa... or also make sure the alsa configuration (in xmms) has the right device selected and stuff... of course that wouldn't explain why mpg123 doesn't get any sound out...

hmmmmm...

i'm sure your card has to work somehow, i mean it would have been impossible to get microphone feedback if it didn't work at all... plus your xmms is using the spectrum analyzer and everything... usually when your sound is not set-up right, xmms will give you errors, and even kde will give you errors... xmms will tell you to go check your sound card and all this stuff... right now it's as if like xmms feels everything is fine...
 
Old 03-11-2004, 05:47 AM   #26
/home/kyle
Member
 
Registered: Mar 2004
Posts: 148

Original Poster
Rep: Reputation: 15
Hmm, I just unpluged my head phons, and pluged em back in, and it make the little...I dunno how to explain it, but if u unplug ur speakers, then plug them it, they make a little sound, and that usualy only happens when the sound is working...but im still not hearing anything.
 
Old 03-11-2004, 05:49 AM   #27
/home/kyle
Member
 
Registered: Mar 2004
Posts: 148

Original Poster
Rep: Reputation: 15
I just noticed this, every time I start up XMMS, the volume is at zero, at the bottom of the grid.. DOes that mean anything?
 
Old 03-11-2004, 05:52 AM   #28
/home/kyle
Member
 
Registered: Mar 2004
Posts: 148

Original Poster
Rep: Reputation: 15
Nope nvm, I just got it to stay up, made no difference

ANd yes, ALSA is using the correct device.. 'SiS SI7012' , the same device I used on Windows.

Last edited by /home/kyle; 03-11-2004 at 05:55 AM.
 
Old 03-11-2004, 05:53 AM   #29
win32sux
LQ Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 376Reputation: 376Reputation: 376Reputation: 376
yeah i mentioned that earlier cuz i've seen it happen when the sound hasn't been set-up right... once it's right it seems it comes up at whatever volume pcm has been set or whatever volume you had it set last...

i'm still wondering why you can't control the pcm volume on your mixer... hmmm... not even as root in alsamixer???
 
Old 03-11-2004, 05:54 AM   #30
win32sux
LQ Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 376Reputation: 376Reputation: 376Reputation: 376
did you select the software volume control option in xmms???
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
a7n8x-x onboard sound working? bobbens Linux - Hardware 5 09-24-2004 08:16 AM
Onboard Sound not working. Please guide !!! rh_l_nb Linux - Hardware 8 09-13-2004 02:56 AM
Microphone not working with A7V8X-X mobo w/ onboard sound n4zmz Linux - Hardware 0 04-23-2004 01:12 PM
Onboard AC'97 sound not working even with correct driver Lfsve82 Mandriva 4 02-07-2004 01:11 PM
Onboard sound not working on Asus P4C800-E Igman Linux - General 0 01-05-2004 10:01 PM


All times are GMT -5. The time now is 04:51 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration