Visit the LQ Articles and Editorials section
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 04-16-2004, 09:34 PM   #1
LQ Newbie
Registered: Apr 2004
Posts: 3

Rep: Reputation: 0
How do I get my GUI interface back during boot up?

I need help getting my Mandrake 9.2 box to boot up to a GUI interface again please! I am fairly new to Linux and am not sure what happened.

Here is what happened....

*I installed some new hardware.

*During the next boot, it asked if I wanted to run the correct configuration tools. I selected yes.

*Something about XFree? during boot up comes up and I select yes.

Now, my machine boots to a command line interface instead of a screen where I can select the user and login to a Gnome interface.

Please please help. I am still pretty new to Linux and do not know enough about the OS yet to get it to boot back up to the GUI interface.

Thank you for your help.

Old 04-16-2004, 11:09 PM   #2
LQ Newbie
Registered: Nov 2003
Distribution: redhat 9
Posts: 15

Rep: Reputation: 0
check the file /etc/inittab
and look for a line like this
if it is 3 instead of 5 change it
Old 04-16-2004, 11:15 PM   #3
LQ Newbie
Registered: Apr 2004
Posts: 3

Original Poster
Rep: Reputation: 0
How do I change the contents of the file? I can see it. But not sure what to do to open or even edit it.

Thank you,

Old 04-16-2004, 11:28 PM   #4
LQ Newbie
Registered: Apr 2004
Posts: 3

Original Poster
Rep: Reputation: 0
Ok, I figured out how to use Vim to look at /etc/inittab

id:5:initdefault: was already set to 5.

Old 04-16-2004, 11:38 PM   #5
Registered: Aug 2002
Location: St Louis, MO
Distribution: Xubuntu, RHEL, Solaris 10
Posts: 929

Rep: Reputation: 30
Typing "startx" after you login will get you back to a GUI. At that point, going into the Mandrake Control Center (and going to "Boot", I believe), should somewhere present you with a checkbox to select whether or not to boot into a GUI interface.

Old 04-16-2004, 11:49 PM   #6
Registered: Jan 2004
Location: /lost+found
Distribution: Slack`er-current
Posts: 845

Rep: Reputation: 32
I don't think it should be id:5:initdefault: it should be id:4:initdefault: then you shouldn't have to startx everytime.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to get back into command line interface bonniehandi Linux - Newbie 1 11-19-2005 12:07 AM
Switch back to graphical interface revenge80200 Linux - Newbie 5 06-02-2004 07:41 PM
SU under a gui interface??? TuxNewb Linux - Newbie 4 12-07-2003 06:19 PM
System is hanging at :BRinging up loop back interface" svyshna Linux - General 1 09-21-2003 06:54 PM
Loop back Interface siddiqu Linux - Networking 2 11-17-2001 08:34 PM

All times are GMT -5. The time now is 11:32 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration