LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   How do I get my GUI interface back during boot up? (http://www.linuxquestions.org/questions/linux-software-2/how-do-i-get-my-gui-interface-back-during-boot-up-171149/)

Nihen 04-16-2004 09:34 PM

How do I get my GUI interface back during boot up?
 
I need help getting my Mandrake 9.2 box to boot up to a GUI interface again please! I am fairly new to Linux and am not sure what happened.

Here is what happened....

*I installed some new hardware.

*During the next boot, it asked if I wanted to run the correct configuration tools. I selected yes.

*Something about XFree? during boot up comes up and I select yes.

Now, my machine boots to a command line interface instead of a screen where I can select the user and login to a Gnome interface.

Please please help. I am still pretty new to Linux and do not know enough about the OS yet to get it to boot back up to the GUI interface.

Thank you for your help.

Nihen.

pradu 04-16-2004 11:09 PM

check the file /etc/inittab
and look for a line like this
id:5:initdefault:
if it is 3 instead of 5 change it

Nihen 04-16-2004 11:15 PM

How do I change the contents of the file? I can see it. But not sure what to do to open or even edit it.

Thank you,

Nihen

Nihen 04-16-2004 11:28 PM

Ok, I figured out how to use Vim to look at /etc/inittab

id:5:initdefault: was already set to 5.





Nihen.

rose_bud4201 04-16-2004 11:38 PM

Typing "startx" after you login will get you back to a GUI. At that point, going into the Mandrake Control Center (and going to "Boot", I believe), should somewhere present you with a checkbox to select whether or not to boot into a GUI interface.

HTH,
Laura

Linux~Powered 04-16-2004 11:49 PM

I don't think it should be id:5:initdefault: it should be id:4:initdefault: then you shouldn't have to startx everytime.


All times are GMT -5. The time now is 02:39 PM.