LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 11-25-2010, 08:16 AM   #1
nokangaroo
Member
 
Registered: Nov 2009
Posts: 138

Rep: Reputation: 23
how do I disable builtin microphone in audacity?


I am trying to record audio via line-in with audacity (iMac 7.1, ubuntu lucid, 2.6.31-11-rt, ALSA; I uninstalled pulseaudio) and I get input simultaneously from line-in and the builtin microphone. There does not seem to be any option to turn it off, and disabling mic in Alsamixer does not work. I don't think reinstalling pulse will solve this; other people on the net seem to have the same problem with audacity, but I did not find a solution.
 
Old 11-25-2010, 08:21 AM   #2
stress_junkie
Senior Member
 
Registered: Dec 2005
Location: Massachusetts, USA
Distribution: Ubuntu 10.04 and CentOS 5.5
Posts: 3,873

Rep: Reputation: 331Reputation: 331Reputation: 331Reputation: 331
You may want to switch from Alsa to Jack.
http://jackaudio.org/
Jack is extremely configurable. It's purpose is to perform complex routing of audio signals. It should provide you with better control over your audio devices than Alsa.

Last edited by stress_junkie; 11-25-2010 at 08:22 AM.
 
Old 11-25-2010, 10:13 AM   #3
nokangaroo
Member
 
Registered: Nov 2009
Posts: 138

Original Poster
Rep: Reputation: 23
Thanks for the URL. Looks interesting. The problem is probably alsamixer; the "line" switch affects both line-in and the internal microphone (which is very noisy).
 
Old 11-25-2010, 02:05 PM   #4
nokangaroo
Member
 
Registered: Nov 2009
Posts: 138

Original Poster
Rep: Reputation: 23
Just tried to compile audacity from source, but I get an error "no suitable configuration for wxWidgets found", even though I just compiled the latest version of wxWidgets without errors. What is going wrong here?
 
Old 11-25-2010, 02:44 PM   #5
jefro
Guru
 
Registered: Mar 2008
Posts: 11,711

Rep: Reputation: 1439Reputation: 1439Reputation: 1439Reputation: 1439Reputation: 1439Reputation: 1439Reputation: 1439Reputation: 1439Reputation: 1439Reputation: 1439
I just go to the top of audacity and select what input I want to use. You could also slide the volume to 0 on input and it ought to stay there as default.

It could be that you have another setting enabled. I think it is under transport or something. I use it to record over songs so I can hear them and record.
 
Old 11-27-2010, 04:07 PM   #6
nokangaroo
Member
 
Registered: Nov 2009
Posts: 138

Original Poster
Rep: Reputation: 23
Solved - upgraded to Maverick (and pulseaudio; the test input sound in gstreamer-properties that always crackled in lucid is clear in maverick).
 
Old 11-27-2010, 04:12 PM   #7
stress_junkie
Senior Member
 
Registered: Dec 2005
Location: Massachusetts, USA
Distribution: Ubuntu 10.04 and CentOS 5.5
Posts: 3,873

Rep: Reputation: 331Reputation: 331Reputation: 331Reputation: 331
Thank you for posting the answer.
 
  


Reply

Tags
audacity, audio, recording, ubuntu


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Microphone problem with skype & audacity ... =( malikcpp Slackware 2 03-26-2012 07:20 PM
[audacity][skype] can't get a microphone to work RRH Linux - Software 3 10-03-2009 04:46 AM
microphone, audacity, skype, recording le1 Linux - Hardware 10 08-21-2008 08:28 AM
no microphone signal with audacity Hewson Linux - Software 1 10-26-2007 05:26 PM
Disable builtin PDF handling - Mozilla 1.7.5 scuzzman Linux - Software 6 03-30-2005 07:46 AM


All times are GMT -5. The time now is 04:58 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration