LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   how do I disable builtin microphone in audacity? (http://www.linuxquestions.org/questions/linux-software-2/how-do-i-disable-builtin-microphone-in-audacity-846500/)

nokangaroo 11-25-2010 08:16 AM

how do I disable builtin microphone in audacity?
 
I am trying to record audio via line-in with audacity (iMac 7.1, ubuntu lucid, 2.6.31-11-rt, ALSA; I uninstalled pulseaudio) and I get input simultaneously from line-in and the builtin microphone. There does not seem to be any option to turn it off, and disabling mic in Alsamixer does not work. I don't think reinstalling pulse will solve this; other people on the net seem to have the same problem with audacity, but I did not find a solution.

stress_junkie 11-25-2010 08:21 AM

You may want to switch from Alsa to Jack.
http://jackaudio.org/
Jack is extremely configurable. It's purpose is to perform complex routing of audio signals. It should provide you with better control over your audio devices than Alsa.

nokangaroo 11-25-2010 10:13 AM

Thanks for the URL. Looks interesting. The problem is probably alsamixer; the "line" switch affects both line-in and the internal microphone (which is very noisy).

nokangaroo 11-25-2010 02:05 PM

Just tried to compile audacity from source, but I get an error "no suitable configuration for wxWidgets found", even though I just compiled the latest version of wxWidgets without errors. What is going wrong here?

jefro 11-25-2010 02:44 PM

I just go to the top of audacity and select what input I want to use. You could also slide the volume to 0 on input and it ought to stay there as default.

It could be that you have another setting enabled. I think it is under transport or something. I use it to record over songs so I can hear them and record.

nokangaroo 11-27-2010 04:07 PM

Solved - upgraded to Maverick (and pulseaudio; the test input sound in gstreamer-properties that always crackled in lucid is clear in maverick).

stress_junkie 11-27-2010 04:12 PM

Thank you for posting the answer.


All times are GMT -5. The time now is 01:13 AM.