LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   How do I disable autocomplete in Gnome's/Cairo-Dock's "open file" dialog? (http://www.linuxquestions.org/questions/linux-software-2/how-do-i-disable-autocomplete-in-gnomes-cairo-docks-open-file-dialog-4175416102/)

DaneM 07-11-2012 07:27 AM

How do I disable autocomplete in Gnome's/Cairo-Dock's "open file" dialog?
 
Hello.

I'm going mad dealing with Gnome 3's/Cairo-Dock's (not sure which it is, exactly) involuntary autocompletion of text that I type into the location bar of "open file" dialogs.

For example:
I enable the "Trash" applet, and want to change the empty and full icons to something more befitting my desktop theme. So, I right-click the icon and choose, "Configure this applet." I click the "Configuration" tab and then the "Open" button next to the entry for the applet's "empty" image.

Now, I have a dialogue that reads, "pick up a file" (not sure why it says that...) at the top, and a typical "breadcrumbs" view of the folder I'm in, with a tree to the left and a list of files and folders in the middle. I know where I'm going, so I press CTRL-L to bring up a text entry box for the location, and ATTEMPT to type the following:

/usr/share/icons/oxygen

...but while I type each word, the program completes it as soon as it can determine which directory's name I'm typing, so if I keep typing as normal, I get this:

/usr/src//share/icons/oxygen
or
/usr/share/are/icons/oxygen
or
/usr/share/icons/ns/oxygen

...depending on when I realize that it's typing the ends of words for me--starting at unpredictable points within those words.

Does anyone know how to end this stupid behavior? (I mean the program's stupid behavior--not mine--just to be clear; the latter is immutable, I think.) ;-) Being something of a typist, it's quite a bit slower to stop and read what it's typing for me than it is to just type the whole thing, myself--and it's driving me nuts! I'd love to know just how to disable this auto-complete "feature." :banghead:

Thanks for any help you can give.

--Dane


All times are GMT -5. The time now is 06:21 PM.