LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 07-11-2012, 06:27 AM   #1
DaneM
Member
 
Registered: Oct 2003
Location: Chico, CA, USA
Distribution: Linux Mint
Posts: 734

Rep: Reputation: 78
Unhappy How do I disable autocomplete in Gnome's/Cairo-Dock's "open file" dialog?


Hello.

I'm going mad dealing with Gnome 3's/Cairo-Dock's (not sure which it is, exactly) involuntary autocompletion of text that I type into the location bar of "open file" dialogs.

For example:
I enable the "Trash" applet, and want to change the empty and full icons to something more befitting my desktop theme. So, I right-click the icon and choose, "Configure this applet." I click the "Configuration" tab and then the "Open" button next to the entry for the applet's "empty" image.

Now, I have a dialogue that reads, "pick up a file" (not sure why it says that...) at the top, and a typical "breadcrumbs" view of the folder I'm in, with a tree to the left and a list of files and folders in the middle. I know where I'm going, so I press CTRL-L to bring up a text entry box for the location, and ATTEMPT to type the following:

/usr/share/icons/oxygen

...but while I type each word, the program completes it as soon as it can determine which directory's name I'm typing, so if I keep typing as normal, I get this:

/usr/src//share/icons/oxygen
or
/usr/share/are/icons/oxygen
or
/usr/share/icons/ns/oxygen

...depending on when I realize that it's typing the ends of words for me--starting at unpredictable points within those words.

Does anyone know how to end this stupid behavior? (I mean the program's stupid behavior--not mine--just to be clear; the latter is immutable, I think.) ;-) Being something of a typist, it's quite a bit slower to stop and read what it's typing for me than it is to just type the whole thing, myself--and it's driving me nuts! I'd love to know just how to disable this auto-complete "feature."

Thanks for any help you can give.

--Dane
 
  


Reply

Tags
auto-complete, cairo-dock, file dialog, gnome 3


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
"Open" (select a file) dialog - single click vs. double click taylorkh Ubuntu 3 10-18-2011 03:00 AM
pckage "cairo" required by cairo" not found barunparichha Linux - Software 4 06-25-2008 08:29 AM
cairo-dock, gnome-dock, kiba-dock?? LinuxNewbie999 *BSD 0 04-03-2008 09:16 AM
GNOME refuses to open certain file types without using the "open with" menu Xzyx987X Linux - Software 2 01-10-2007 06:15 PM
Get location bar in "Open File" dialog box ZeroFill Linux - Newbie 1 06-30-2006 06:10 PM


All times are GMT -5. The time now is 06:38 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration