LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
LinkBack Search this Thread
Old 08-15-2006, 08:08 PM   #1
RHLinuxGUY
Member
 
Registered: Oct 2003
Distribution: Ubuntu 7.04
Posts: 889
Blog Entries: 1

Rep: Reputation: 30
How do I 'reserve' my sound device? So more then one piece of software can use sound


How do I allow my sound to be used across several applications instead of one at a time? I have ESD disabled, and I am using ALSA. My hardware is Intel HD Advance Audio, and the code is snd_hda_intel with the required OSS emulation.
 
Old 08-15-2006, 08:25 PM   #2
AzrielMacKay
Member
 
Registered: Jul 2001
Location: Moody, AL
Distribution: Debian and Kubuntu
Posts: 249

Rep: Reputation: 30
It doesn't support full duplex? If so thats what you need to enable. If you use kde you need to enable it for artsd. arts can be kind of a pain in the butt
 
Old 08-16-2006, 06:13 AM   #3
RHLinuxGUY
Member
 
Registered: Oct 2003
Distribution: Ubuntu 7.04
Posts: 889
Blog Entries: 1

Original Poster
Rep: Reputation: 30
Sadly I don't have KDE, and other threads about enabling full duplex is with ethtool (for ethernet?) and ARTSD. I have gnome and gentoo. How about that?
 
Old 08-16-2006, 11:27 PM   #4
bluelightning
Member
 
Registered: Mar 2006
Location: Redmond, WA
Distribution: FC4, WinXP Pro
Posts: 37

Rep: Reputation: 15
Are you absolutely sure you are using ALSA directly and not OSS-emulation? Very rarely does software automatically use ALSA. If you are using ALSA, which ALSA device are you using? default? hw:0,0?

Some sound cards don't support hardware mixing (playing multiple streams at the same time through hardware). My USB sound devices are like that. For those rare cases, you need to use a dmix device (software mixing) in ALSA.

Unfortunately, that usually boils down to putting some cryptic statements into /etc/asound.conf. If possible, it should be avoided.
 
Old 12-06-2006, 10:42 PM   #5
RHLinuxGUY
Member
 
Registered: Oct 2003
Distribution: Ubuntu 7.04
Posts: 889
Blog Entries: 1

Original Poster
Rep: Reputation: 30
Uh.. crap I forgot about this: Anyways... I am using /dev/dsp which is soft linked to /dev/sound/dsp. And I do have OSS emulation enabled in my kernel.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mplayer sound error: "Could not open/initialize audio device -> no sound" GTBlackwell Linux - Software 9 06-11-2008 02:23 PM
No Sound FC5, device detected (Power Mac sound) paz117 Linux - Hardware 8 08-07-2006 04:10 AM
Intel8x0 sound, ALSA /dev/dsp device busy, is card locked or is it software? bigearsbilly Linux - Hardware 9 12-15-2005 03:49 AM
How does Linux decide what device in /dev to use for a piece of hardware? BrianHenderson Linux - Hardware 4 08-30-2004 04:06 PM
no sound from cd player, good sound from audio device test fmickel Linux - Hardware 5 06-04-2004 12:46 PM


All times are GMT -5. The time now is 11:37 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration