LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   How Can I Speed Up Ubuntu Without Reducing Movie Quality ?? (http://www.linuxquestions.org/questions/linux-software-2/how-can-i-speed-up-ubuntu-without-reducing-movie-quality-659123/)

taurusx5 07-29-2008 07:12 PM

How Can I Speed Up Ubuntu Without Reducing Movie Quality ??
 
I followed a tip to reduce color usage on my ubuntu 7.10 in order to improve my computer's speed. The tip called for entering 'sudo gedit /etc/X11/xorg.conf' in terminal and changing the color depth from 24 to 16. In doing so, my computer actually ran a lot faster. But, when I look at a movie, it comes out very pixelated. I then changed the color depth back to 24 which makes it sluggish to being with. Is there a way I can reduce the color depth without sacrificing movie quality?

Jomen, if you're reading this, I hope you can help me with this one.

.

jomen 07-30-2008 12:34 PM

First lets find some info on your machine:
Code:

lspci -v
Then look in /etc/X11/xorg.conf or in /var/log/Xorg.0.log for info on what driver for your video card is in use.

Code:

less /var/log/Xorg.0.log
to scan manually throug the whole thing
Code:

less /var/log/Xorg.0.log | grep chipset
might find it faster
You can use any editor instead of "less" - but it is a quicker way to me.

[edit]
while we are at it - please also post the output of this command:
Code:

less /var/log/Xorg.0.log|grep '(WW)'

taurusx5 07-31-2008 02:43 PM

Quote:

Originally Posted by jomen (Post 3231185)
First lets find some info on your machine:
Code:

lspci -v
Then look in /etc/X11/xorg.conf or in /var/log/Xorg.0.log for info on what driver for your video card is in use.

Code:

less /var/log/Xorg.0.log
to scan manually throug the whole thing
Code:

less /var/log/Xorg.0.log | grep chipset
might find it faster
You can use any editor instead of "less" - but it is a quicker way to me.

[edit]
while we are at it - please also post the output of this command:
Code:

less /var/log/Xorg.0.log|grep '(WW)'


Hi, jomen. Thanks for replying. I upgraded to 8.04 yesterday, just to let you know. Here's info from lspci -v:

x@xx:~$ lspci -v
00:00.0 Host bridge: Intel Corporation 82852/82855 GM/GME/PM/GMV Processor to I/O Controller (rev 02)
Subsystem: Rioworks Unknown device 203e
Flags: bus master, fast devsel, latency 0
Memory at <unassigned> (32-bit, prefetchable)
Capabilities: <access denied>

00:00.1 System peripheral: Intel Corporation 82852/82855 GM/GME/PM/GMV Processor to I/O Controller (rev 02)
Subsystem: Rioworks Unknown device 203e
Flags: bus master, fast devsel, latency 0

00:00.3 System peripheral: Intel Corporation 82852/82855 GM/GME/PM/GMV Processor to I/O Controller (rev 02)
Subsystem: Rioworks Unknown device 203e
Flags: bus master, fast devsel, latency 0

00:02.0 VGA compatible controller: Intel Corporation 82852/855GM Integrated Graphics Device (rev 02) (prog-if 00 [VGA controller])
Subsystem: Rioworks Unknown device 203e
Flags: bus master, fast devsel, latency 0, IRQ 18
Memory at e8000000 (32-bit, prefetchable) [size=128M]
Memory at e0000000 (32-bit, non-prefetchable) [size=512K]
I/O ports at 1800 [size=8]
Capabilities: <access denied>

00:02.1 Display controller: Intel Corporation 82852/855GM Integrated Graphics Device (rev 02)
Subsystem: Rioworks Unknown device 203e
Flags: bus master, fast devsel, latency 0
Memory at f0000000 (32-bit, prefetchable) [size=128M]
Memory at e0080000 (32-bit, non-prefetchable) [size=512K]
Capabilities: <access denied>

00:1d.0 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1 (rev 03) (prog-if 00 [UHCI])
Subsystem: Rioworks Unknown device 203e
Flags: bus master, medium devsel, latency 0, IRQ 18
I/O ports at 1820 [size=32]

00:1d.1 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2 (rev 03) (prog-if 00 [UHCI])
Subsystem: Rioworks Unknown device 203e
Flags: bus master, medium devsel, latency 0, IRQ 16
I/O ports at 1840 [size=32]

00:1d.2 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3 (rev 03) (prog-if 00 [UHCI])
Subsystem: Rioworks Unknown device 203e
Flags: bus master, medium devsel, latency 0, IRQ 19
I/O ports at 1860 [size=32]

00:1d.7 USB Controller: Intel Corporation 82801DB/DBM (ICH4/ICH4-M) USB2 EHCI Controller (rev 03) (prog-if 20 [EHCI])
Subsystem: Rioworks Unknown device 203e
Flags: bus master, medium devsel, latency 0, IRQ 20
Memory at e0100000 (32-bit, non-prefetchable) [size=1K]
Capabilities: <access denied>

00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 83) (prog-if 00 [Normal decode])
Flags: bus master, fast devsel, latency 0
Bus: primary=00, secondary=02, subordinate=06, sec-latency=216
Memory behind bridge: e0200000-e02fffff

00:1f.0 ISA bridge: Intel Corporation 82801DBM (ICH4-M) LPC Interface Bridge (rev 03)
Flags: bus master, medium devsel, latency 0

00:1f.1 IDE interface: Intel Corporation 82801DBM (ICH4-M) IDE Controller (rev 03) (prog-if 8a [Master SecP PriP])
Subsystem: Rioworks Unknown device 203e
Flags: bus master, medium devsel, latency 0, IRQ 19
I/O ports at 01f0 [size=8]
I/O ports at 03f4 [size=1]
I/O ports at 0170 [size=8]
I/O ports at 0374 [size=1]
I/O ports at 1810 [size=16]
Memory at 70000000 (32-bit, non-prefetchable) [size=1K]

00:1f.3 SMBus: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) SMBus Controller (rev 03)
Subsystem: Rioworks Unknown device 203e
Flags: medium devsel, IRQ 10
I/O ports at 1880 [size=32]

00:1f.5 Multimedia audio controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 03)
Subsystem: Rioworks Unknown device 203e
Flags: bus master, medium devsel, latency 0, IRQ 17
I/O ports at 1c00 [size=256]
I/O ports at 18c0 [size=64]
Memory at e0100c00 (32-bit, non-prefetchable) [size=512]
Memory at e0100800 (32-bit, non-prefetchable) [size=256]
Capabilities: <access denied>

00:1f.6 Modem: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Modem Controller (rev 03) (prog-if 00 [Generic])
Subsystem: Rioworks Unknown device 2030
Flags: bus master, medium devsel, latency 0, IRQ 17
I/O ports at 2400 [size=256]
I/O ports at 2000 [size=128]
Capabilities: <access denied>

02:07.0 CardBus bridge: Texas Instruments PCIxx21/x515 Cardbus Controller
Subsystem: Rioworks Unknown device 203e
Flags: bus master, medium devsel, latency 168, IRQ 16
Memory at e020a000 (32-bit, non-prefetchable) [size=4K]
Bus: primary=02, secondary=03, subordinate=06, sec-latency=176
Memory window 0: 74000000-77fff000 (prefetchable)
Memory window 1: 78000000-7bfff000
I/O window 0: 00001400-000014ff
I/O window 1: 00002800-000028ff
16-bit legacy interface ports at 0001

02:07.2 FireWire (IEEE 1394): Texas Instruments OHCI Compliant IEEE 1394 Host Controller (prog-if 10 [OHCI])
Subsystem: Rioworks Unknown device 203e
Flags: bus master, medium devsel, latency 32, IRQ 16
Memory at e0209000 (32-bit, non-prefetchable) [size=2K]
Memory at e0200000 (32-bit, non-prefetchable) [size=16K]
Capabilities: <access denied>

02:07.3 Mass storage controller: Texas Instruments PCIxx21 Integrated FlashMedia Controller
Subsystem: Rioworks Unknown device 203e
Flags: bus master, medium devsel, latency 57, IRQ 16
Memory at e0204000 (32-bit, non-prefetchable) [size=8K]
Capabilities: <access denied>

02:08.0 Ethernet controller: Broadcom Corporation BCM4401 100Base-T (rev 01)
Subsystem: Rioworks Unknown device 203e
Flags: bus master, fast devsel, latency 32, IRQ 17
Memory at e0206000 (32-bit, non-prefetchable) [size=8K]
Capabilities: <access denied>

02:09.0 Network controller: Intel Corporation PRO/Wireless 2200BG Network Connection (rev 05)
Subsystem: Intel Corporation Unknown device 2701
Flags: bus master, medium devsel, latency 32, IRQ 17
Memory at e0208000 (32-bit, non-prefetchable) [size=4K]
Capabilities: <access denied>


-------------------
-------------------------------------------------------------------------

Next, is the results of 'less /var/log/Xorg.0.log'. Since it was pretty long, I had to cut out huge chunks. I hope I didn't cut out anything relevant. Here it is:


X.Org X Server 1.4.0.90
Release Date: 5 September 2007
X Protocol Version 11, Revision 0
Build Operating System: Linux Ubuntu (xorg-server 2:1.4.1~git20080131-1ubuntu9)
Current Operating System: Linux xx 2.6.24-16-generic #1 SMP Thu Apr 10 13:23:42 UTC 2008 i686
Build Date: 15 April 2008 05:26:17PM

(**) | |-->Device "Intel Corporation 82852/855GM Integrated Graphics Device"

(==) RgbPath set to "/etc/X11/rgb"
(==) ModulePath set to "/usr/lib/xorg/modules"
(II) Open ACPI successful (/var/run/acpid.socket)
(II) Loader magic: 0x81dc500
(II) Module ABI versions:
X.Org ANSI C Emulation: 0.3
X.Org Video Driver: 2.0
X.Org XInput driver : 2.0
X.Org Server Extension : 0.3
X.Org Font Renderer : 0.5
(II) Loader running on linux
(II) LoadModule: "pcidata"
(II) Loading /usr/lib/xorg/modules//libpcidata.so
(II) Module pcidata: vendor="X.Org Foundation"
compiled for 1.4.0.90, module version = 1.0.0
ABI class: X.Org Video Driver, version 2.0
(++) using VT number 7

(II) PCI-to-CardBus bridge:
(II) Bus 3: bridge is at (2:7:0), (2,3,6), BCTRL: 0x05c0 (VGA_EN is cleared)
(--) PCI:*(0:2:0) Intel Corporation 82852/855GM Integrated Graphics Device rev 2, Mem @ 0xe8000000/27, 0xe0000000/19, I/O @ 0x1800/3
(--) PCI: (0:2:1) Intel Corporation 82852/855GM Integrated Graphics Device rev 2, Mem @ 0xf0000000/27, 0xe0080000/19

(II) LoadModule: "intel"
(II) Loading /usr/lib/xorg/modules/drivers//intel_drv.so
(II) Module intel: vendor="X.Org Foundation"
compiled for 1.4.0.90, module version = 2.2.1
Module class: X.Org Video Driver
ABI class: X.Org Video Driver, version 2.0
(II) LoadModule: "kbd"
(II) Loading /usr/lib/xorg/modules/input//kbd_drv.so
(II) Module kbd: vendor="X.Org Foundation"
compiled for 1.4.0, module version = 1.2.2
Module class: X.Org XInput Driver
ABI class: X.Org XInput driver, version 2.0
(II) LoadModule: "mouse"
(II) Loading /usr/lib/xorg/modules/input//mouse_drv.so
(II) Module mouse: vendor="X.Org Foundation"
compiled for 1.4.0, module version = 1.2.3
Module class: X.Org XInput Driver
ABI class: X.Org XInput driver, version 2.0
(II) LoadModule: "synaptics"
(II) Loading /usr/lib/xorg/modules/input//synaptics_drv.so
(II) Module synaptics: vendor="X.Org Foundation"
compiled for 4.3.99.902, module version = 1.0.0
Module class: X.Org XInput Driver
ABI class: X.Org XInput driver, version 2.0
(II) intel: Driver for Intel Integrated Graphics Chipsets: i810,
i810-dc100, i810e, i815, i830M, 845G, 852GM/855GM, 865G, 915G,
E7221 (i915), 915GM, 945G, 945GM, 945GME, 965G, G35, 965Q, 946GZ,
965GM, 965GME/GLE, G33, Q35, Q33, Intel Integrated Graphics Device
(II) Primary Device is: PCI 00:02:0
(--) Chipset 852GM/855GM found

(==) intel(0): Default visual is TrueColor
(II) intel(0): Integrated Graphics Chipset: Intel(R) 855GM
(--) intel(0): Chipset: "852GM/855GM"
(--) intel(0): Linear framebuffer at 0xE8000000

(II) intel(0): VESA VBE Total Mem: 32576 kB
(II) intel(0): VESA VBE OEM: Intel(r)852GM/852GME/855GM/855GME Graphics Chip Accelerated VGA BIOS
(II) intel(0): VESA VBE OEM Software Rev: 1.0
(II) intel(0): VESA VBE OEM Vendor: Intel Corporation
(II) intel(0): VESA VBE OEM Product: Intel(r)852GM/852GME/855GM/855GME Graphics Controller
(II) intel(0): VESA VBE OEM Product Rev: Hardware Version 0.0
(II) intel(0): I2C bus "DVODDC_D" initialized.
(II) Loading sub module "sil164"
(II) LoadModule: "sil164"
(II) Loading /usr/lib/xorg/modules/drivers//sil164.so


----------------------
------------------------------------------------------------------

And finally, here's output from code: less /var/log/Xorg.0.log|grep '(WW)':

x@xx:~$ sudo gedit less /var/log/Xorg.0.log | grep chipset
[sudo] password for x:
x@xx:~$ less /var/log/Xorg.0.log|grep '(WW)'
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
(WW) intel(0): Bad V_BIOS checksum
(WW) intel(0): Register 0x61200 (PP_STATUS) changed from 0xc0000008 to 0xd0000009
(WW) intel(0): PP_STATUS before: on, ready, sequencing idle
(WW) intel(0): PP_STATUS after: on, ready, sequencing on
(WW) intel(0): xf86AllocateGARTMemory: allocation of 1536 pages failed
(WW) intel(0): Allocation error, framebuffer compression disabled
(WW) intel(0): xf86AllocateGARTMemory: allocation of 10 pages failed
(WW) intel(0): EXA greedy migration mode enabled.
(WW) AIGLX: 3D driver claims to not support visual 0x23
(WW) AIGLX: 3D driver claims to not support visual 0x24
(WW) AIGLX: 3D driver claims to not support visual 0x25
(WW) AIGLX: 3D driver claims to not support visual 0x26
(WW) AIGLX: 3D driver claims to not support visual 0x27
(WW) AIGLX: 3D driver claims to not support visual 0x28
(WW) AIGLX: 3D driver claims to not support visual 0x29
(WW) AIGLX: 3D driver claims to not support visual 0x2a
(WW) AIGLX: 3D driver claims to not support visual 0x2b
(WW) AIGLX: 3D driver claims to not support visual 0x2c
(WW) AIGLX: 3D driver claims to not support visual 0x2d
(WW) AIGLX: 3D driver claims to not support visual 0x2e
(WW) AIGLX: 3D driver claims to not support visual 0x2f
(WW) AIGLX: 3D driver claims to not support visual 0x30
(WW) AIGLX: 3D driver claims to not support visual 0x31
(WW) AIGLX: 3D driver claims to not support visual 0x32



If you think there's a need to upgrade my video driver, I would welcome that. It would be great to upgrade it if I need to. Let me know, and thanks for everything, jomen !!!!


All times are GMT -5. The time now is 10:18 AM.