LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 09-27-2011, 02:29 AM   #1
nokangaroo
Member
 
Registered: Nov 2009
Posts: 135

Rep: Reputation: 23
How can I disable a redundant menu item in Thunar?


I am just trying to configure Thunar in LXDE oneiric (I use nautilus in natty which works very well but not in oneiric). Pcmanfm still handles the desktop, and I have set a custom Thunar action "set as wallpaper" with the command

pcmanfm --set-wallpaper %f

which works when right-clicking image files but I also get a redundant "set as wallpaper" entry which does not work and which I did not create. Is there an xml file somewhere to edit to get rid of it, or is this behaviour hardcoded? I do not wish to install the entire XFCE environment (I heart openbox).
 
Old 09-27-2011, 03:00 PM   #2
qlue
Member
 
Registered: Aug 2009
Location: Umzinto, South Africa
Distribution: Crunchbang
Posts: 604
Blog Entries: 1

Rep: Reputation: 138Reputation: 138
I'd recommend you go snooping around your home directory. Look in ~/.config/Thunar/thunarrc for example.
(find similar for pcmanfm)
 
Old 09-27-2011, 10:18 PM   #3
nokangaroo
Member
 
Registered: Nov 2009
Posts: 135

Original Poster
Rep: Reputation: 23
Thank you, but if it were something like this I'd have found it already. The corresponding file for Nautilus was in /usr/share/nautilus/ui, but there is nothing useful in /usr/share/Thunar. To be sure it is not a very serious problem, but I hate it when I can't customize everything.
 
Old 09-27-2011, 10:58 PM   #4
qlue
Member
 
Registered: Aug 2009
Location: Umzinto, South Africa
Distribution: Crunchbang
Posts: 604
Blog Entries: 1

Rep: Reputation: 138Reputation: 138
The tilde '~' is your home folder. so it would be
Code:
/home/[your login name here]/.config/Thunar/thunarrc
To see the hidden files and directories in your home folder, press Ctrl+h
This works in most file managers including Thunar.
Nautilus is a bit more complicated, but it would also have user specifig configuration settings somewhere in the home folder!
 
Old 09-28-2011, 01:21 AM   #5
nokangaroo
Member
 
Registered: Nov 2009
Posts: 135

Original Poster
Rep: Reputation: 23
Are you kidding??????????
 
Old 09-28-2011, 01:39 AM   #6
nokangaroo
Member
 
Registered: Nov 2009
Posts: 135

Original Poster
Rep: Reputation: 23
When I install the full XFCE environment the original menu entry works. So the code to execute it resides in xfdesktop instead of thunar where it belongs. I have filed a bug report.
 
  


Reply

Tags
lxde, thunar, ubuntu


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
application menu disappeared and the main menu item has no response sunnior Ubuntu 12 11-03-2011 04:28 AM
How to disable the hover (menu) item in Gnome Kanon Linux - Newbie 2 02-22-2009 08:59 PM
thunar contextual menu problem mariogarcia Linux - Software 1 12-14-2007 07:33 PM
New Terminal menu item does nothing flgal3 Red Hat 11 02-05-2006 09:27 PM
Menu item in Madrake 9.2 Veli Mandriva 2 07-11-2004 06:24 AM


All times are GMT -5. The time now is 09:13 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration