LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 07-24-2004, 08:25 PM   #1
Braveheart1980
Member
 
Registered: Jan 2004
Location: Greece!
Distribution: Ubuntu 9.10
Posts: 633
Blog Entries: 1

Rep: Reputation: 30
How can i change file associations under fedora core 2?


I was wondering how can i change file associations under fedora core 2.eg to play a wmv file with mplayer

PS I've done right click --> open with --> gmplayer and choose to always open such files with mplayer , a bar pops up updating information but next time i double click an wmv file gmplayer doesn't open!
 
Old 07-25-2004, 09:23 AM   #2
Andrew Benton
Senior Member
 
Registered: Aug 2003
Location: Birkenhead/Britain
Distribution: Linux From Scratch
Posts: 2,073

Rep: Reputation: 64
The menus are different in Fedora, (sorry I can't be bothered rebooting) but in regular Gnome 2.6 if you click the Main Menu> Applications> Desktop Preferences> Advanced> File Types and Programs, scroll down to Video, click it to expand the menu then click Microsoft WMV video .wmv and then click Edit. Fill in gmplayer in the Program to run box, click OK and close everything up and you're done.
 
Old 07-25-2004, 09:42 AM   #3
Braveheart1980
Member
 
Registered: Jan 2004
Location: Greece!
Distribution: Ubuntu 9.10
Posts: 633
Blog Entries: 1

Original Poster
Rep: Reputation: 30
I use KDE !
 
Old 07-25-2004, 10:51 AM   #4
qwijibow
Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Rep: Reputation: 47
Settings->Configure Konqueror->File Associations
 
Old 07-25-2004, 08:05 PM   #5
Braveheart1980
Member
 
Registered: Jan 2004
Location: Greece!
Distribution: Ubuntu 9.10
Posts: 633
Blog Entries: 1

Original Poster
Rep: Reputation: 30
It seems like a bug 2 me.I've done that choose gmplayer for every video file , the same bar pops up but after that whenever i tr to double click a video file mplayer doesn't start!!!!!!!!!!!!
 
Old 07-25-2004, 09:51 PM   #6
qwijibow
Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Rep: Reputation: 47
like i said.....
set mplayer as the TOP program for use with the video files in the file association section of KDE's konqueror.
 
Old 07-26-2004, 03:58 AM   #7
Braveheart1980
Member
 
Registered: Jan 2004
Location: Greece!
Distribution: Ubuntu 9.10
Posts: 633
Blog Entries: 1

Original Poster
Rep: Reputation: 30
I did!In fact i even erased other programms from the list so only mplayer is there.But whenever i check back the list no program is there!!!!!
 
Old 07-26-2004, 04:35 PM   #8
qwijibow
Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Rep: Reputation: 47
ignore the "List" just click the icon (or double click, depending on your style) and the program at the top of the file associations will run.
 
Old 07-26-2004, 06:37 PM   #9
Braveheart1980
Member
 
Registered: Jan 2004
Location: Greece!
Distribution: Ubuntu 9.10
Posts: 633
Blog Entries: 1

Original Poster
Rep: Reputation: 30
Well that is my problem!I've removed all other programms , left just gmplayer and whenever i check the list there is NO program associated!!!
 
Old 07-28-2004, 06:52 PM   #10
evannextel
Member
 
Registered: Sep 2003
Distribution: Red Hat 9
Posts: 54

Rep: Reputation: 15
yeah im curious about how to do this so i can set xmms for all mp3's. Using fedora core 2 and gnome. I found the preferences and then filetypes, it was set for xmms, but for soem reason rhythm box pops up if i lclick on an mp3

Last edited by evannextel; 07-28-2004 at 06:55 PM.
 
Old 07-29-2004, 03:53 AM   #11
Braveheart1980
Member
 
Registered: Jan 2004
Location: Greece!
Distribution: Ubuntu 9.10
Posts: 633
Blog Entries: 1

Original Poster
Rep: Reputation: 30
Well i figured it out! U have to remove all other programs and then don't set the program u want to open a file just like that ( eg gmplayer ) but u have to put the whole PATH to it ( eg /usr/bin/gmplayer ) . Then it works!
 
Old 07-30-2004, 01:58 PM   #12
titopoquito
Senior Member
 
Registered: Jul 2004
Location: Ruhr Area, Germany
Distribution: Slackware64 14.0
Posts: 1,525

Rep: Reputation: 94
@ evannextel
I had the same problem. Maybe you find the answer in the following thread, where I posted my solution to this problem, it's about Gnome 2.6 and filetypes or mime-types.
Hope this helps ...

Other thread on linuxquestions.org
.
titopoquito
 
Old 08-01-2004, 12:51 PM   #13
evannextel
Member
 
Registered: Sep 2003
Distribution: Red Hat 9
Posts: 54

Rep: Reputation: 15
ok im reading through that. in the freedesktop.org.xml file, mp3 is already listed. Now I'm assumign that all that file does is defines Filetypes. What decides how thoose filetypes are treated.

PS this is really annoying since the program that is set to open mp3's wont play them. I still find it funny that red hat wont support mp3 play back.

Last edited by evannextel; 08-01-2004 at 12:53 PM.
 
Old 08-01-2004, 01:12 PM   #14
titopoquito
Senior Member
 
Registered: Jul 2004
Location: Ruhr Area, Germany
Distribution: Slackware64 14.0
Posts: 1,525

Rep: Reputation: 94
I'm sorry I can't write the entries I made, since I am running Windows right now and have some tasks running ...

I suggest you get the Gnome 2.6 Administrator's Guide. Chapter 5 is focusing on mime-types. There are five files I made additions, one was the shared-mime-thing from freedesktop.org. The other files or locations I made changes to are:

/etc/gnome-vfs-mime-magic ---- here I added some info about file content sniffing. I guess it's no longer used, since the above mentioned freedesktop.org file contains an appropriate entry. I would change it as well, even if it's gain may be minimal or none, it does do no harm either.

/usr/share/mime-info ----- here are .mime as well as .keys files. I think this is the directory you should take a deeper look at.

/usr/share/application-registry, here especially gnome-vfs.applications --- this file contains the applications known to Gnome and the mime-types they are able to open.


In my special case I had to create an mpc (Musepack) mime-type and to assign it to an program (xmms). Along this I run into one or two files for the totem-movieplayer (I guess it was in /usr/share/mime-info), that did my mp3s open in totem-movieplayer. I had to remove the lines concerning mp3-files and put them in an extra file (xmms.mime or xmms.keys, I don't remember).

Hope this helps. If you need it, I could post the chages I made for the Musepack-audio-files.

titopoquito
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora Core 4 - Boot Splash Change foustware Linux - Software 7 01-06-2006 01:36 AM
Change boot image in Fedora Core 2 how?? virussx Fedora 1 10-23-2004 04:00 AM
Where to change CFLAGS in Fedora Core 2? black hole sun Fedora 3 09-26-2004 06:17 PM
Can't change resolution in Fedora Core 1 thaitea Fedora 1 04-16-2004 05:44 PM
How to change refresh rates on Fedora Core 1.0?? in a RUSH Linux - Hardware 0 12-01-2003 11:50 AM


All times are GMT -5. The time now is 09:50 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration